Пожалуйста, помогтме решить задачи на Pasсal?

Информатика | 5 - 9 классы

Пожалуйста, помогтме решить задачи на Pasсal.

Во всех задачах массив состоит из 10 элементов и задаётся из интервала от 1 до 99.

1. Написать программу, которая выводит на экран все четные элементы массива и их количество.

2. Написать программу, которая выводит на экран все двузначные элементы массива и их количество.

3. Написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по индексу).

. Написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по значению).

5. Написать программу, которая выводит на экран количество элементов оканчивающихся на 5.

Ответить на вопрос
Ответы (1)
Nuta1619 31 дек. 2020 г., 10:12:29

1. var a : array[1.

10] of integer ; i, kol : Integer ;

Begin for i : = 1 to 10 do read(a[i]) ; kol : = 0 ; for i : = 1 to 10 do if a[i] mod 2 = 0 then begin kol : = kol + 1 ; write(a[i], ' ') ; end ; writeln ; writeln(kol) ;

End.

2. var a : array[1.

10] of integer ; i, kol : Integer ;

Begin for i : = 1 to 10 do read(a[i]) ; kol : = 0 ; for i : = 1 to 10 do if a[i] > ; 9 then begin kol : = kol + 1 ; write(a[i], ' ') ; end ; writeln ; writeln(kol) ;

End.

3. var a : array[1.

10] of integer ; i : Integer ;

Begin for i : = 1 to 10 do read(a[i]) ; for i : = 1 to 10 do if a[i] mod 2 = 0 then write(a[i], ' ') ; for i : = 1 to 10 do if a[i] mod 2 = 1 then write(a[i], ' ') ;

End.

4. var a : array[1.

10] of integer ; i, r : Integer ;

Begin for i : = 1 to 10 do read(a[i]) ; i : = 1 ; while i < ; 10 do if a[i + 1] < ; a[i] then begin r : = a[i + 1] ; a[i + 1] : = a[i] ; a[i] : = r ; i : = 1 ; end else i : = i + 1 ; for i : = 1 to 10 do if a[i] mod 2 = 0 then write(a[i], ' ') ; for i : = 1 to 10 do if a[i] mod 2 = 1 then write(a[i], ' ') ;

End.

5. var a : array[1.

10] of integer ; i, kol : Integer ;

Begin for i : = 1 to 10 do read(a[i]) ; for i : = 1 to 10 do if a[i] mod 10 = 5 then kol : = kol + 1 ; writeln(kol) ;

End.

Ирусик28 24 мая 2020 г., 11:02:09 | 5 - 9 классы

Составьте программу, которая позволяет вводить с клавиатуры элементы массива а [1?

Составьте программу, которая позволяет вводить с клавиатуры элементы массива а [1.

10] и вывода на экран элементов с четными индексами.

Къабу 25 сент. 2020 г., 20:11:15 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО составьте программу, которая заполняет массива а [1?

ПОМОГИТЕ СРОЧНО составьте программу, которая заполняет массива а [1.

8] соучайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и суумму элементов массива с нечетными значениями.

Alinaiva 14 февр. 2020 г., 17:49:42 | 10 - 11 классы

Составьте программу ввода с клавиатуры элементов массива а [1?

Составьте программу ввода с клавиатуры элементов массива а [1.

10] и вывода на экран элементов с четными значениями и четными индексами.

Женя127 22 мар. 2020 г., 18:39:51 | 5 - 9 классы

Помогите пожалуйста) Составьте программу, которая заполняет массив a[1?

Помогите пожалуйста) Составьте программу, которая заполняет массив a[1.

8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями.

Dinasonikov 31 янв. 2020 г., 18:56:20 | 5 - 9 классы

Составьте программу, которая позволяет ввести элементы массива а [1?

Составьте программу, которая позволяет ввести элементы массива а [1.

10] с клавиатуры и выводит на экран количество отрицательных элементов и их индексы.

Maks3442 4 сент. 2020 г., 22:50:48 | 5 - 9 классы

Составьте программу, которая позволяет вводить с клавиатуры элементы массива а [1?

Составьте программу, которая позволяет вводить с клавиатуры элементы массива а [1.

10] и вывода на экран элементов с четными индексами.

Butusovke 13 дек. 2020 г., 10:23:28 | 5 - 9 классы

Паскаль?

Паскаль.

Написать программу, которая выводит на экран количество чисел Х в массиве.

В массиве N элементов, числа целые.

Х задаётся.

Помогите))).

Murastam 8 сент. 2020 г., 06:07:42 | 5 - 9 классы

Составьте программу ввода с клавиатуры элементов массива а[1?

Составьте программу ввода с клавиатуры элементов массива а[1.

10] и вывода на экран элементов с четными индексами.

Алекс111105 12 окт. 2020 г., 21:47:24 | 5 - 9 классы

Составьте программу, которая заполняет массив a[1?

Составьте программу, которая заполняет массив a[1.

8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями.

НастяЕлизарова 12 сент. 2020 г., 02:22:04 | 5 - 9 классы

Составьте программу ввода с клавиатуры элементов массива а [1?

Составьте программу ввода с клавиатуры элементов массива а [1.

10] и вывода на экран элементов с четными значениями и четными индексами.

Вы находитесь на странице вопроса Пожалуйста, помогтме решить задачи на Pasсal? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.