У Пети есть 20 игрушечных солдатиков различного размера – от самых маленьких до достаточно больших ?

Информатика | 10 - 11 классы

У Пети есть 20 игрушечных солдатиков различного размера – от самых маленьких до достаточно больших .

Вот список их длин в см : 20, 9, 24, 12, 23, 24, 21, 17, 1, 15, 25, 8, 21, 2, 6, 4, 12, 16, 8, 13

Петя хочет выстроит в ряд нескольких из них так, чтобы в каждой паре рядом стоящих солдатиков рост солдатика справа был больше роста солдатика слева по крайней мере на 3 см.

Какое наибольшее количество солдатиков он сможет поставить?

Ответить на вопрос
Ответы (1)
Felenr 30 апр. 2024 г., 04:14:36

Const n = 20 ;

var a : array[1.

20] of integer = ( 20, 9, 24, 12, 23, 24, 21, 17, 1,

  ;   ;   ;   ;   ;   ;   ;   ;   ; 15, 25, 8, 21, 2, 6, 4, 12, 16, 8, 13) ;   ;   ;   ;   ;   ;   ;

  ;   ; i, j, k : integer ;

begin

  ; for i : = 1 to n - 1 do

  ; for j : = i + 1 to n do

  ; if a[j]< ; a[i] then swap(a[i], a[j]) ;

  ; writeln('отсортированный массив : ') ;

  ; for i : = 1 to n do write(a[i], ' ') ;

  ; writeln ;

  ; k : = 0 ;

  ; i : = 1 ; j : = 2 ;

  ; repeat

  ;   ; if a[j] - a[i]> ; = 3 then

  ;   ; begin

  ;   ;   ; writeln('пара : ', a[i], ' ', a[j]) ;   ;   ;

  ;   ;   ; i : = j ;

  ;   ;   ; inc(k) ;

  ;   ; end ;   ;

  ;   ; inc(j) ;

  ; until j> ; n ;

  ; writeln('количество солдат : k + 1) ;

end.

Отсортированный массив :   ;

1 2 4 6 8 8 9 12 12 13 15 16 17 20 21 21 23 24 24 25  ;

пара : 1 4

пара : 4 8

пара : 8 12

пара : 12 15

пара : 15 20

пара : 20 23

количество солдат : 7.

Тимур131205 4 янв. 2024 г., 12:20:10 | студенческий

Вы хотите переслать картинку по электронной почте, но ее размер слишком большой?

Вы хотите переслать картинку по электронной почте, но ее размер слишком большой.

Какую программу можно использовать, чтобы "сжать"картинку?

Katy1998 6 янв. 2024 г., 00:58:31 | 1 - 4 классы

Помогите разгадать последний ресурс, самый нижний?

Помогите разгадать последний ресурс, самый нижний.

Азамат11111 11 янв. 2024 г., 16:24:13 | студенческий

Сгенерируйте список из 10 случайных чисел от 10 до 20 и выведите его в строчку?

Сгенерируйте список из 10 случайных чисел от 10 до 20 и выведите его в строчку.

Напишите программу, которая переставит местами первый и последний элемент в списке (изменит текущий список!

) и выведет его в строчку.

​.

123456789lina 12 янв. 2024 г., 04:50:33 | студенческий

ПОМОГИТЕ ПОЖАЛУЙСТА РЕШИТЬ ЗАДАЧУИнформация о каждом из 88 работников организации 18390 знаков находится в отдельном файле?

ПОМОГИТЕ ПОЖАЛУЙСТА РЕШИТЬ ЗАДАЧУ

Информация о каждом из 88 работников организации 18390 знаков находится в отдельном файле.

Можно ли, не прибегая к архивированию, переписать все эти файлы на один гибкий магнитный диск формата 3, 5?

Potabekova 23 янв. 2024 г., 14:42:11 | 10 - 11 классы

- связь между размером алфавита и информационным весом символа?

- связь между размером алфавита и информационным весом символа.

Aznobino 2 февр. 2024 г., 02:15:50 | 10 - 11 классы

Изучи программный код и определи количество повторений цикла и количество выполнений переключателя?

Изучи программный код и определи количество повторений цикла и количество выполнений переключателя.

Срочно младшему брату нужно​.

Мип12 14 февр. 2024 г., 16:35:23 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА С ЗАДАНИЕМ?

ПОМОГИТЕ ПОЖАЛУЙСТА С ЗАДАНИЕМ!

В ходе телевизионного шоу проводится смс - голосование : каждый телезритель отдат свой голос за одного из 12 артистов - участников шоу, отправляя сообщение с его номером.

Голос каждого телезрителя, отданный за того или иного участника, кодируется одинаковым и минимально возможным количеством бит и сохраняется для подведения итогов.

За время телевизионного шоу в голосовании приняли участие 163840 зрителей.

Определите объем сохраненной информации о голосовании и выразите его в килобайтах.

YanockaKisil 25 февр. 2024 г., 05:08:26 | 5 - 9 классы

Задание №1?

Задание №1.

Напишите программу, которая находит сумму цифр чисел между k и р.

Какую ошибку вы допу - стили при выполнении задания?

Про - верьте работу операторов, расположен - ных в теле цикла, путем трассировки.

​.

Rak2003Masha 26 февр. 2024 г., 00:48:25 | 5 - 9 классы

Определи, является ли данный граф взвешенным?

Определи, является ли данный граф взвешенным.

Возможные ответы 1)Нет, не является взвешенным графом

2)Да, является взвешенным графом

Определи и запиши вес ребра (если определить невозможно, то поставь 0)

gf (Место для ответа).

GuzyaM 29 февр. 2024 г., 13:56:23 | студенческий

Известно, что на доске 8×8 можно расставить 8 ферзей так, чтобы они не били друг друга?

Известно, что на доске 8×8 можно расставить 8 ферзей так, чтобы они не били друг друга.

Вам дана расстановка 8 ферзей на доске, определите, есть ли среди них пара бьющих друг друга.

Входные данные

Программа получает на вход восемь пар чисел, каждое число от 1 до 8 - координаты 8 ферзей.

Анна2118 4 мар. 2024 г., 23:27:40 | 1 - 4 классы

Не верь глазам своим?

Не верь глазам своим.

Какой прямоугольник длиннее, левый или правый?

​.

На этой странице сайта вы найдете ответы на вопрос У Пети есть 20 игрушечных солдатиков различного размера – от самых маленьких до достаточно больших ?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.