1. С клавиатуры вводят слово и символ?

Информатика | 5 - 9 классы

1. С клавиатуры вводят слово и символ.

Составьте программу , которая определяет позицию данного символа.

Ответить на вопрос
Ответы (1)
Krasotka3 12 мар. 2020 г., 10:21:48

Var c : Char ; s : String ; i, k, p : Integer ;

Begin ReadLn(c) ; {Чтение заданного символа} ReadLn(s) ; {Чтение заданного слова} p : = Pos(c, s) ; {Определяем позицию символа} If (p = 0) Then {Функция вернёт 0, если символ не будет найден} WriteLn('Такого символа в слове нет.

') Else {Если символ есть, то .

} Begin WriteLn('Указанный символ расположен на позиции : ', p) ; k : = 0 ; {k хранит количество вхождений} p : = Length(s) ; {p хранит длину строки(слова)} For i : = 1 To p Do {Пробегаем по всем символам слова} If (s[i] = c) Then inc(k) ; {Если символ совпадает, увеличиваем на 1 переменную k} WriteLn('Количество вхождений данного символа : ', k) ; End ;

End.

Zarina97zaza 20 апр. 2020 г., 18:38:56 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая : проверяет, есть ли в этом слове заданный символ.

POLINAKOSHKINA 1 апр. 2020 г., 08:12:41 | 10 - 11 классы

Информатика 10 класс?

Информатика 10 класс.

Составьте программу, которая : а) определяет коды двух введенных с клавиатуры символов ;

Ivanovamarina2 17 мая 2020 г., 02:02:55 | 5 - 9 классы

1. С клавиатуры вводят слово и симвал?

1. С клавиатуры вводят слово и симвал.

Составьте программу , которая а)проверяет, есть ли в этом слове данный симвал.

Б)определяет позицию данного символа.

В)подсчитывает количество входов данного символа.

2. С клавиатуры вводят ряд и слово.

Составьте программу , которая а)определяет позицию данного слова.

Сделайте что сможете пожалуйста!

Ketymailcom 14 июн. 2020 г., 00:15:58 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая определяет позицию заданного символа.

Katyabulanova 18 нояб. 2020 г., 20:22:27 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составить программу, которая : а)проверяет есть ли в этом слове заданный символ б)определяет позицию заданного символа в)подсчитывает количество вхождений заданного символа.

Кэтрин11111 15 апр. 2020 г., 20:13:49 | 5 - 9 классы

Символы вводятся в позицию , которая определяется : а) положением предыдущего символа ; б) Произвольно ; в) адресом ; с) положением курсора?

Символы вводятся в позицию , которая определяется : а) положением предыдущего символа ; б) Произвольно ; в) адресом ; с) положением курсора.

GIRL99love 5 мая 2020 г., 20:10:13 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составте программу которая : подсчитывает количество вхождений заданного символа.

Dasdgffjj 4 апр. 2020 г., 20:51:39 | 5 - 9 классы

Помогите, прошу?

Помогите, прошу.

Составить программу, которая вводит с клавиатуры один символ и выводит на экран два символа стоящие до и после этого символа.

Gulzadab79 26 мар. 2020 г., 18:36:01 | 10 - 11 классы

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ?

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ.

Слово вводится в программе.

PascalABC.

Valerakot 3 окт. 2020 г., 22:50:23 | 10 - 11 классы

С клавиатуры вводят слово?

С клавиатуры вводят слово.

Составьте программу, которая определяет позицию буквы "е" в слове.

Вы находитесь на странице вопроса 1. С клавиатуры вводят слово и символ? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.