С клавиатуры вводят слово и символ?

Информатика | 10 - 11 классы

С клавиатуры вводят слово и символ.

Составте программу которая : подсчитывает количество вхождений заданного символа.

Ответить на вопрос
Ответы (1)
Milaya09 5 мая 2020 г., 20:10:18

Var a : string ;

b : char ;

i, sum : integer ;

begin

readln(a, b) ;

for i : = 1 to length(a) do begin

if pos(b, a)< ; > ; 0 then begin

sum : = sum + 1 ;

delete(a, 1, pos(b, a)) ;

end ;

end ;

writeln(sum) ;

end.

Rybyska 12 мар. 2020 г., 10:21:47 | 5 - 9 классы

1. С клавиатуры вводят слово и символ?

1. С клавиатуры вводят слово и символ.

Составьте программу , которая определяет позицию данного символа.

Zarina97zaza 20 апр. 2020 г., 18:38:56 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая : проверяет, есть ли в этом слове заданный символ.

Masia123456789 15 окт. 2020 г., 20:40:44 | 5 - 9 классы

Срочно нужна помощь?

Срочно нужна помощь!

1. С клавиатуры вводят слово и символ.

Составть программу, которая :

а) проверяет, есть ли в этом слове заданный символ ;

б) определяет позицию заданного символа ;

в) подсчитывает количество вхождений заданного символа.

2. С клавиатуры вводят строку и слово.

Составть программу, которая :

а) определяет позицию заданного слова ;

б) удаляет заданное слово ;

в) вставляет в строку заданное слово.

3. Составть программу, которая :

а) из строки "Волга, Днепр, Неман, Енисей" удаляет названия рек, не протекающих по территории Беларуси ;

б) из строки "Брест, Бобруйск, Витебск, Гомель, Мозырь, Могилев" удаляет названия городов, не являющихся областными центрами.

4. Составть программу, которая :

а) в строке "край озер" добавляет слова "лесов и рек" ;

б) в строке "я учусь в школе" заменить слова "в школе" на "в 10 - ом классе".

5. Составть программу, которая переставляет на первое место :

а) в строке "моя родина Беларусь" слово "Беларусь" ; б) в строке "люблю цябе мой родны кут" слова "мой родны кут".

Ivanovamarina2 17 мая 2020 г., 02:02:55 | 5 - 9 классы

1. С клавиатуры вводят слово и симвал?

1. С клавиатуры вводят слово и симвал.

Составьте программу , которая а)проверяет, есть ли в этом слове данный симвал.

Б)определяет позицию данного символа.

В)подсчитывает количество входов данного символа.

2. С клавиатуры вводят ряд и слово.

Составьте программу , которая а)определяет позицию данного слова.

Сделайте что сможете пожалуйста!

Рппрь 7 сент. 2020 г., 09:12:57 | 10 - 11 классы

Помогите паскаль?

Помогите паскаль!

Срочно нужно!

20Балов за 4 задачи 3Составте программу , которая определяет , какое из 2 - х слов более длиннее и выводит это слово 4, С клавиатуры вводят 2 слова .

Составте программу, которая выводит на экран слова в обратном порядке 5, С клавиатуры вводят слово .

Составте программу которая выводит количество символов в нем 6, Составте программу , которая определяет какое из 2 - х введенных с клавиатуры слов короче , и выводит это слово.

Ketymailcom 14 июн. 2020 г., 00:15:58 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая определяет позицию заданного символа.

Katyabulanova 18 нояб. 2020 г., 20:22:27 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составить программу, которая : а)проверяет есть ли в этом слове заданный символ б)определяет позицию заданного символа в)подсчитывает количество вхождений заданного символа.

Nohchi958795 2 апр. 2020 г., 12:19:25 | 10 - 11 классы

Составить программу которая копирует из строки заданный символ и подсчитывает число его вхождений (, )?

Составить программу которая копирует из строки заданный символ и подсчитывает число его вхождений (, ).

Dasdgffjj 4 апр. 2020 г., 20:51:39 | 5 - 9 классы

Помогите, прошу?

Помогите, прошу.

Составить программу, которая вводит с клавиатуры один символ и выводит на экран два символа стоящие до и после этого символа.

Gulzadab79 26 мар. 2020 г., 18:36:01 | 10 - 11 классы

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ?

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ.

Слово вводится в программе.

PascalABC.

На этой странице находится вопрос С клавиатуры вводят слово и символ?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.