Написать программу в Паскаль абс по теме функции?

Информатика | 10 - 11 классы

Написать программу в Паскаль абс по теме функции.

Задача : найти сумму цифр трех чисел.

Ответить на вопрос
Ответы (1)
Klapanda 17 нояб. 2020 г., 19:47:31

/ / PascalABC.

NET 3.

1, сборка 1219 от 16.

04. 2016

function SoD(n : int64) : integer ;

begin Result : = 0 ; while n> ; 0 do begin Result + = n mod 10 ; n : = n div 10 end

end ;

begin var a : = ReadArrInteger('Введите три натуральных числа : ', 3) ; Write('Суммы цифр чисел : ') ; a.

Select(x - > ; SoD(x)).

Println ; Writeln('Общая сумма цифр всех чисел : ', a.

Select(x - > ; SoD(x)).

Sum)

end.

Тестовое решение :

Введите три натуральных числа : 56325 23131 784545223

Суммы цифр чисел : 21 10 40

Общая сумма цифр всех чисел : 71.

Яна89011 31 окт. 2020 г., 17:17:10 | 5 - 9 классы

Написать программу в паскале определяющую и выводящую наибольшее из трех чисел?

Написать программу в паскале определяющую и выводящую наибольшее из трех чисел.

Дима20051 6 июн. 2020 г., 20:28:55 | 5 - 9 классы

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку?

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.

Myrick 10 авг. 2020 г., 07:02:32 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму цифр числа.

(Написать программу на языке Паскаль).

Бэллучи 13 дек. 2020 г., 18:17:35 | 5 - 9 классы

Составьте листик программы Паскаль вычисляющий сумму трех дробных чисел?

Составьте листик программы Паскаль вычисляющий сумму трех дробных чисел.

Koshak109 23 сент. 2020 г., 21:31:22 | 10 - 11 классы

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс?

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс.

Olesay3478 23 июл. 2020 г., 16:15:24 | 5 - 9 классы

Найти сумму двух чисел А и Б написать код программы на языке паскаль?

Найти сумму двух чисел А и Б написать код программы на языке паскаль.

Dadaev241 25 янв. 2020 г., 23:11:11 | 5 - 9 классы

Найти сумму натуральных чисел от 1 до 50?

Найти сумму натуральных чисел от 1 до 50.

Программу написать на языке паскаль, по теме "вложенность цикла".

Rjirfvecmrf 10 авг. 2020 г., 18:35:17 | 10 - 11 классы

Задается массив из n натуральных чисел?

Задается массив из n натуральных чисел.

Найти сумму чисел в которых цифры упорядочены по возрастанию.

Язык - паскаль.

Задачу сделать надо через функцию.

Котубийца 1 авг. 2020 г., 08:24:58 | 5 - 9 классы

Задача по информатике?

Задача по информатике.

Найти сумму цифр данного целого числа.

Программа.

Паскаль.

99Денис 15 сент. 2020 г., 16:03:54 | 5 - 9 классы

Составьте программу которая выводит на экран все двузначные числа сумма цифр которых четнаяв Паскаль абс?

Составьте программу которая выводит на экран все двузначные числа сумма цифр которых четная

в Паскаль абс.

Если вам необходимо получить ответ на вопрос Написать программу в Паскаль абс по теме функции?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.