Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс?

Информатика | 10 - 11 классы

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс.

Ответить на вопрос
Ответы (1)
Карина2003год 23 сент. 2020 г., 21:31:24

Const m = 10 ; n = 8 ;

var a : array[1.

M, 1.

N] of integer ; i, j : integer ; p : double ;

begin Randomize ; Writeln('Исходный массив') ; for i : = 1 to m do begin for j : = 1 to n do begin a[i, j] : = Random(101) - 50 ; Write(a[i, j] : 4) ; end ; Writeln end ; p : = 1 ; for j : = 1 to n do if a[3, j]> ; 0 then p : = p * a[3, j] ; Writeln('Искомое произведение : ', p)

end.

Тестовое решение :

Исходный массив 35 30 35 - 25 - 50 8 - 20 47 - 34 - 26 - 7 34 - 9 - 31 10 - 46 - 17 - 21 27 8 27 41 35 - 48 30 - 44 25 48 30 - 20 10 - 6 - 3 - 10 45 - 33 3 - 38 - 11 - 8 47 - 25 - 27 - 7 2 - 20 - 4 - 48 - 38 32 - 29 - 41 31 16 46 44 45 33 - 4 45 34 - 18 - 33 37 15 49 - 14 - 49 - 25 - 8 1 - 30 41 - 15 11 1 17 - 8 0 - 1

Искомое произведение : 8368920.

Katrin2008 19 июл. 2020 г., 23:46:05 | 10 - 11 классы

ПАСКАЛЬ АБС?

ПАСКАЛЬ АБС!

СРОЧНО!

ПОМОГИТЕ ПОЖАЛУЙСТА!

1. напишите программу формирования массива размером 5 * 5 с помощью датчика случайных чисел.

Замените в нем нечетные значения элементов максимальным.

Выведите на экран исходный и измененный массивы.

2. Составьте программу формирования и вывода на печать одномерного массива, состоящего из максимальных элементов строк двумерного массива, заданного с помомщью датчика случайных чисел.

Marsovin 7 февр. 2020 г., 08:25:25 | 10 - 11 классы

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел?

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел.

Kateprincess 17 февр. 2020 г., 13:34:20 | 5 - 9 классы

1. Нахождение наибольшего элемента главной диагонали?

1. Нахождение наибольшего элемента главной диагонали.

(Паскаль, двумерные массивы ) 2.

Нахождение наименьших элементов в столбцах массива.

(Паскаль, двумерные массивы ).

5254 16 авг. 2020 г., 08:32:45 | 1 - 4 классы

Написать программу, которая число считанное с клавиатуры, увеличивает в два раза?

Написать программу, которая число считанное с клавиатуры, увеличивает в два раза.

Паскаль абс.

Ксиния 17 нояб. 2020 г., 19:47:30 | 10 - 11 классы

Написать программу в Паскаль абс по теме функции?

Написать программу в Паскаль абс по теме функции.

Задача : найти сумму цифр трех чисел.

Anna20031407 8 июн. 2020 г., 13:09:02 | 10 - 11 классы

Помогите написать программу на паскале абс "Файловый тип данных?

Помогите написать программу на паскале абс "Файловый тип данных.

" Дан целочисленный файл А.

Записать в файл В все положительные числа.

Катерина706 18 янв. 2020 г., 03:57:13 | 5 - 9 классы

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки?

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки.

(паскаль).

Andriymama 19 апр. 2020 г., 21:15:08 | 5 - 9 классы

Программу в паскале?

Программу в паскале.

Составить программу нахождения произведения положительных чисел одномерного массива В(10), элементы которого задаются датчиком случайных чисел.

Vasyapupkin201 2 июл. 2020 г., 19:43:53 | 5 - 9 классы

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран?

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран.

Язык Паскаль.

Викакарттер 13 сент. 2020 г., 05:08:58 | 10 - 11 классы

Помогите решить ?

Помогите решить .

Составьте программу формирования и вывода на экран одномерного массива , состоящего из элементов главной диагонали двумерного массива , заданного с помощью датчика случайных чисел.

(Паскаль абс) С объяснением .

На этой странице находится ответ на вопрос Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.