Задается массив из n натуральных чисел?

Информатика | 10 - 11 классы

Задается массив из n натуральных чисел.

Найти сумму чисел в которых цифры упорядочены по возрастанию.

Язык - паскаль.

Задачу сделать надо через функцию.

Ответить на вопрос
Ответы (1)
КАРЕНЧИК 10 авг. 2020 г., 18:35:20

Const n = 10 ;

var a : array[1.

N] of integer ; i : integer ;

function sum : integer ;

var tmp, prev, cur, s, i : integer ; flg : boolean ;

begin s : = 0 ; for i : = 1 to n do begin flg : = true ; tmp : = a[i] ; prev : = 9 ; cur : = 0 ; while tmp > ; 0 do begin cur : = tmp mod 10 ; if cur > ; prev then begin flg : = false ; break ; end ; prev : = cur ; tmp : = tmp div 10 ; end ; if flg then inc(s) ; end ; sum : = s ;

end ;

begin writeln('Исходный массив : ') ; for i : = 1 to n do begin a[i] : = random(1000) ; write(a[i], ' ') ; end ; writeln ; writeln('Ответ : ', sum) ;

end.

Jmjmjmjmj500 27 февр. 2020 г., 16:12:32 | 10 - 11 классы

Дан массив натуральных чисел ?

Дан массив натуральных чисел .

Найти сумму элементов , кратных заданному К.

DDDina 17 мар. 2020 г., 18:11:39 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Найти количество тех элементов, значение которых положительны и не превосходят заданного натурального числа А.

(сделайте в паскале).

Yor1356051 13 июл. 2020 г., 23:36:45 | 5 - 9 классы

Составьте на языке Паскаль программу вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N?

Составьте на языке Паскаль программу вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N.

Построить трассировочную таблицу.

Kama8001 25 дек. 2020 г., 07:17:41 | 5 - 9 классы

Решить задачу на Паскале : Вычислите сумму данных 100 натуральных чисел?

Решить задачу на Паскале : Вычислите сумму данных 100 натуральных чисел.

Вводятся 100 чисел, сумму которых необходимо посчитать.

Dadaev241 25 янв. 2020 г., 23:11:11 | 5 - 9 классы

Найти сумму натуральных чисел от 1 до 50?

Найти сумму натуральных чисел от 1 до 50.

Программу написать на языке паскаль, по теме "вложенность цикла".

Tumak98 20 июл. 2020 г., 03:06:30 | 5 - 9 классы

Найти сумму квадратов первых n натуральных чисел / ох, простите?

Найти сумму квадратов первых n натуральных чисел / ох, простите!

: DDD на языке паскаль.

12365874555 3 дек. 2020 г., 09:02:04 | 5 - 9 классы

Написать функцию которая считает количество цифр натурального числа затем в массиве из 10 натуральных чисел найти число с наибольшим количеством цифр?

Написать функцию которая считает количество цифр натурального числа затем в массиве из 10 натуральных чисел найти число с наибольшим количеством цифр.

ПАСКАЛЬ.

ПОМОГИТЕ ПОЖАЛУЙСТА!

Ксиния 17 нояб. 2020 г., 19:47:30 | 10 - 11 классы

Написать программу в Паскаль абс по теме функции?

Написать программу в Паскаль абс по теме функции.

Задача : найти сумму цифр трех чисел.

Golovchak1999 23 мар. 2020 г., 02:22:50 | 5 - 9 классы

Найти сумму n первых нечётных натуральных чисел?

Найти сумму n первых нечётных натуральных чисел.

(Паскаль).

Hilolalola 9 июл. 2020 г., 21:02:48 | 1 - 4 классы

Определить количество натуральных чисел , рассматривая их в порядке возрастания, сумма кубов которых не превышает 50000 Язык Паскаль?

Определить количество натуральных чисел , рассматривая их в порядке возрастания, сумма кубов которых не превышает 50000 Язык Паскаль.

На этой странице находится вопрос Задается массив из n натуральных чисел?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.