Pascal ABCисправьте ошибки, пожалуйста в моей программе?

Информатика | 5 - 9 классы

Pascal ABC

исправьте ошибки, пожалуйста в моей программе.

ВЫБРАТЬ ДЛЯ КОНКУРСА ЧЕЛОВЕКА РОСТОМ ОТ 172 ДО 184см ИЛИ ВЕСОМ ОТ 70 ДО 80 кг.

Program konkyrs ;

var

a, b : integer ;

begin

writeln ('вводим число') ;

readln (a, b) ;

if (a> ; = 172) then if (a< ; = 184) or

if (b> ; = 70) then if (b< ; = 80) then writeln ('подходит для конкурса')

else writeln ('не подходит для конкурса')

else writeln ('не подходит для конкурса')

end.

Ответить на вопрос
Ответы (1)
KateVilays 18 мар. 2020 г., 07:23:35

Program konkyrs ;

var

a, b : integer ;

BEGIN writeln ('введите рост и вес участника через пробел') ; readln(a, b) ; if (a> ; = 172) and (a< ; = 184) then begin if (b> ; = 70) and (b< ; = 80) then writeln('подходит для конкурса') else writeln ('не подходит для конкурса') ; end else writeln ('не подходит для конкурса') ; readln ;

END.

Ошибка была в том что надо использовать вместо or (или) оператор and (и) , а еще были пропущены точка с запятой после команды else .

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Irinakirikovam 24 мая 2020 г., 05:37:28 | 5 - 9 классы

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end.

В чём ошибка?

Blad2000 30 авг. 2020 г., 08:19:58 | 5 - 9 классы

Даны 3 стороны треугольника АВС - напечатать какой имеет вид треугольник?

Даны 3 стороны треугольника АВС - напечатать какой имеет вид треугольник.

Проверьте где у меня ошибки : var

a, b, c : integer ;

begin

write('введите a = ') ; readln(a)

write('введите b = ') ; readln(b)

write('введите c = ') ; readln(c)

if(a = b)and(b = c)then

writeln('равносторонний')

else

if (a = b)or(b = c)or(a = c)then

writeln('равнобедренный')

else

writeln('разносторонний')

end.

Оорр1 6 мар. 2020 г., 00:18:39 | 5 - 9 классы

Program mimi ;var a, b : integer ;beginreadln (a) ;if 99 < ; a < ; thenwriteln('Неверно')elseif a> ; 999 thenwriteln('Неверно')elsewriten('Верно')end?

Program mimi ;

var a, b : integer ;

begin

readln (a) ;

if 99 < ; a < ; then

writeln('Неверно')

else

if a> ; 999 then

writeln('Неверно')

else

writen('Верно')

end.

Выдаёт : pas(5) : Ожидался идентификатор

Что не так?

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Aigulmazh1 4 июн. 2020 г., 06:58:18 | 10 - 11 классы

Var : a, i, b : integer begin readln(a) ; for i : = 1 to a do if a mod i = 0 then b : = b + 1 ; if b = 2 then writeln('простое число') else writeln(' не простое число') end?

Var : a, i, b : integer begin readln(a) ; for i : = 1 to a do if a mod i = 0 then b : = b + 1 ; if b = 2 then writeln('простое число') else writeln(' не простое число') end.

Объясните пожалуйста подробно , что делает эта программа?

В чем суть ?

Буду очень благодарна).

111worni111wormi 5 нояб. 2020 г., 04:49:38 | 5 - 9 классы

Что не так в программе в конце должен вывести какое число больше program primer ; var a, b : integer ; wrateln : ; readln (a, b) ; if a> ; b then writeln(a) else writeln (b) ; end?

Что не так в программе в конце должен вывести какое число больше program primer ; var a, b : integer ; wrateln : ; readln (a, b) ; if a> ; b then writeln(a) else writeln (b) ; end.

Бананчик123213 5 янв. 2020 г., 10:45:30 | 5 - 9 классы

Program vika ; var x, y : integer ; begin writeln ('Ведите x') ; readln (X) ; writeln ('Ведите y') ; readln (y) ; if (x> ; 0) and (y> ; 0) then writeln (' В 1') else (x> ; 0) and (y< ; 0) then?

Program vika ; var x, y : integer ; begin writeln ('Ведите x') ; readln (X) ; writeln ('Ведите y') ; readln (y) ; if (x> ; 0) and (y> ; 0) then writeln (' В 1') else (x> ; 0) and (y< ; 0) then writeln ('В 4') if (x< ; 0) and (y> ; 0) then writeln ('Во 2') else (x< ; 0) and (y< ; 0) then writeln ('В 3') ; end.

Пишет что Встречено 'and', а ожидалось ' ; ' где ошибка?

Буду очень благодарна.

Ряжка 25 дек. 2020 г., 18:21:48 | 5 - 9 классы

Помогите пожалуйста, cрочно?

Помогите пожалуйста, cрочно!

Составить блок - схему.

Program primer6 ;

uses crt ;

x : integer ;

begin

clrscr ;

readln(x) ;

if x mod 2 = 0 then writeln ('да')

else writeln ('нет')

end.

На этой странице находится вопрос Pascal ABCисправьте ошибки, пожалуйста в моей программе?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.