Program vika ; var x, y : integer ; begin writeln ('Ведите x') ; readln (X) ; writeln ('Ведите y') ; readln (y) ; if (x> ; 0) and (y> ; 0) then writeln (' В 1') else (x> ; 0) and (y< ; 0) then?

Информатика | 5 - 9 классы

Program vika ; var x, y : integer ; begin writeln ('Ведите x') ; readln (X) ; writeln ('Ведите y') ; readln (y) ; if (x> ; 0) and (y> ; 0) then writeln (' В 1') else (x> ; 0) and (y< ; 0) then writeln ('В 4') if (x< ; 0) and (y> ; 0) then writeln ('Во 2') else (x< ; 0) and (y< ; 0) then writeln ('В 3') ; end.

Пишет что Встречено 'and', а ожидалось ' ; ' где ошибка?

Буду очень благодарна.

Ответить на вопрос
Ответы (1)
Ramil111182 5 янв. 2020 г., 10:45:33

Program vika ;

var x, y : integer ;

begin

writeln ('Ведите x') ;

readln (X) ;

writeln ('Ведите y') ;

readln (y) ;

if

(x> ; 0) and (y> ; 0) then writeln (' В 1') ;

else

if (x> ; 0) and (y< ; 0) then writeln ('В 4') ;

if

(x< ; 0) and (y> ; 0) then writeln ('Во 2') ;

else

if (x< ; 0) and (y< ; 0) then writeln ('В 3') ;

end.

Немного исправил.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Irinakirikovam 24 мая 2020 г., 05:37:28 | 5 - 9 классы

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end.

В чём ошибка?

Roma00032 3 авг. 2020 г., 02:15:39 | 10 - 11 классы

Ограниченную область, изображенную на рисунке, описывает фрагмент программы : а) if ((X + 1) * (X + 1) + Y * Y)< ; 4 OR (Y< ; 1)) then writeln('ДА’) else writeln('HET') ; б) if (X * X + (Y - 1) * ?

Ограниченную область, изображенную на рисунке, описывает фрагмент программы : а) if ((X + 1) * (X + 1) + Y * Y)< ; 4 OR (Y< ; 1)) then writeln('ДА’) else writeln('HET') ; б) if (X * X + (Y - 1) * (Y - 1))< ; 4 AND (Y> ; 1)) then writeln('ДА') else writeln('HET') ; в) if ((X - 1) * (X - 1) + Y * Y)< ; 4 AND (Y< ; 1)) then writeln('ДА') else writeln('HET') ; г) if ((X - 1) * (X - 1) + Y * Y)> ; 4 AND (Y< ; 1)) then writeln('ДА') else writeln('HET') ;

Blad2000 30 авг. 2020 г., 08:19:58 | 5 - 9 классы

Даны 3 стороны треугольника АВС - напечатать какой имеет вид треугольник?

Даны 3 стороны треугольника АВС - напечатать какой имеет вид треугольник.

Проверьте где у меня ошибки : var

a, b, c : integer ;

begin

write('введите a = ') ; readln(a)

write('введите b = ') ; readln(b)

write('введите c = ') ; readln(c)

if(a = b)and(b = c)then

writeln('равносторонний')

else

if (a = b)or(b = c)or(a = c)then

writeln('равнобедренный')

else

writeln('разносторонний')

end.

Mu1999 8 авг. 2020 г., 05:26:14 | 5 - 9 классы

Решаю программу в Паскаль, все время пишет либо Встречено ' ; ', а ожидалось ')', либо Встречено 'else', а ожидался оператор?

Решаю программу в Паскаль, все время пишет либо Встречено ' ; ', а ожидалось ')', либо Встречено 'else', а ожидался оператор.

Помогите, пожалуйста!

Найдите ошибку!

Program Ves ; Var a1, a2, a3, t1, t2, t3, p, d, vp : Integer ; begin writeln ('программа вычисляет норму для данного ученика') ; writeln ('введи массу учебника 1') ; readln (a1) ; writeln ('введи массу учебника 2') ; readln (a2) ; writeln ('введи массу учебника 3') ; readln (a3) ; writeln ('введи массу тетради 1') ; readln (t1) ; writeln ('введи массу тетради 2') ; readln (t2) ; writeln ('введи массу тетради 3') ; readln (t3) ; writeln ('введи массу пенала') ; readln (p) ; writeln ('введи массу дневника') ; readln (d) ; writeln ('введи массу портфеля') ; readln (vp) ; b : = a1 + a2 + a3 + a4 + t1 + t2 + t3 + p + d + vp ; writeln ('общая масса портфеля, b') if (b< ; = 5) then writeln ('норма') ; else writeln ('ненорма') ; readln ; end.

Оорр1 6 мар. 2020 г., 00:18:39 | 5 - 9 классы

Program mimi ;var a, b : integer ;beginreadln (a) ;if 99 < ; a < ; thenwriteln('Неверно')elseif a> ; 999 thenwriteln('Неверно')elsewriten('Верно')end?

Program mimi ;

var a, b : integer ;

begin

readln (a) ;

if 99 < ; a < ; then

writeln('Неверно')

else

if a> ; 999 then

writeln('Неверно')

else

writen('Верно')

end.

Выдаёт : pas(5) : Ожидался идентификатор

Что не так?

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

111worni111wormi 5 нояб. 2020 г., 04:49:38 | 5 - 9 классы

Что не так в программе в конце должен вывести какое число больше program primer ; var a, b : integer ; wrateln : ; readln (a, b) ; if a> ; b then writeln(a) else writeln (b) ; end?

Что не так в программе в конце должен вывести какое число больше program primer ; var a, b : integer ; wrateln : ; readln (a, b) ; if a> ; b then writeln(a) else writeln (b) ; end.

Ряжка 25 дек. 2020 г., 18:21:48 | 5 - 9 классы

Помогите пожалуйста, cрочно?

Помогите пожалуйста, cрочно!

Составить блок - схему.

Program primer6 ;

uses crt ;

x : integer ;

begin

clrscr ;

readln(x) ;

if x mod 2 = 0 then writeln ('да')

else writeln ('нет')

end.

На этой странице находится вопрос Program vika ; var x, y : integer ; begin writeln ('Ведите x') ; readln (X) ; writeln ('Ведите y') ; readln (y) ; if (x&gt ; 0) and (y&gt ; 0) then writeln (' В 1') else (x&gt ; 0) and (y&lt ; 0) then?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.