Program mimi ;var a, b : integer ;beginreadln (a) ;if 99 < ; a < ; thenwriteln('Неверно')elseif a> ; 999 thenwriteln('Неверно')elsewriten('Верно')end?

Информатика | 5 - 9 классы

Program mimi ;

var a, b : integer ;

begin

readln (a) ;

if 99 < ; a < ; then

writeln('Неверно')

else

if a> ; 999 then

writeln('Неверно')

else

writen('Верно')

end.

Выдаёт : pas(5) : Ожидался идентификатор

Что не так?

Ответить на вопрос
Ответы (1)
Akonstantin 6 мар. 2020 г., 00:18:40

Переписал без ошибок

var a, b : integer ;

begin

readln (a) ;

if 99 < ; a thenwriteln('Неверно')

elseif a> ; 999 thenwriteln('Неверно')

elsewriteln('Верно')

end.

Said48 18 мар. 2020 г., 07:23:32 | 5 - 9 классы

Pascal ABCисправьте ошибки, пожалуйста в моей программе?

Pascal ABC

исправьте ошибки, пожалуйста в моей программе.

ВЫБРАТЬ ДЛЯ КОНКУРСА ЧЕЛОВЕКА РОСТОМ ОТ 172 ДО 184см ИЛИ ВЕСОМ ОТ 70 ДО 80 кг.

Program konkyrs ;

var

a, b : integer ;

begin

writeln ('вводим число') ;

readln (a, b) ;

if (a> ; = 172) then if (a< ; = 184) or

if (b> ; = 70) then if (b< ; = 80) then writeln ('подходит для конкурса')

else writeln ('не подходит для конкурса')

else writeln ('не подходит для конкурса')

end.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Viktoriapusch 15 июл. 2020 г., 07:37:36 | 10 - 11 классы

Program lab1 ; varx, y : real ; begin writeln('введите x') ; readln(x) ; begin if (abs(x)< ; = 1) then y : = sqr(x) - 1 ; else if(abs(x)> ; 1) and (abs(x)< ; = 2) then y : = 2 * x - 1 ; else if ?

Program lab1 ; var

x, y : real ; begin writeln('введите x') ; readln(x) ; begin if (abs(x)< ; = 1) then y : = sqr(x) - 1 ; else if(abs(x)> ; 1) and (abs(x)< ; = 2) then y : = 2 * x - 1 ; else if (abs(x)> ; 2) then y : = exp(5 * ln(x)) - 1 ; end ; writeln ('y = ', y) ; End.

Где ошибка в программе?

Пишет : : Встречено 'else', а ожидался оператор.

Нужно найти у, при определенных значениях х.

Irinakirikovam 24 мая 2020 г., 05:37:28 | 5 - 9 классы

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end.

В чём ошибка?

Umnica1 27 дек. 2020 г., 01:45:22 | 5 - 9 классы

Составить блок схему :var a, b, c : integer ;Beginread(a, b, c) ; if (a> ; b) then a : = a else a : = b ;if (a> ; c) then a : = a else a : = c ;writeln(a) ;End?

Составить блок схему :

var a, b, c : integer ;

Begin

read(a, b, c) ; if (a> ; b) then a : = a else a : = b ;

if (a> ; c) then a : = a else a : = c ;

writeln(a) ;

End.

Sonayxolod 4 апр. 2020 г., 00:00:20 | 10 - 11 классы

Можете объяснить за что отвечает xsearch?

Можете объяснить за что отвечает xsearch?

Program c4 ; var n : integer ; x, y : integer ; xmin, xmax : integer ; xsearch : boolean ; ymin, ymax : integer ; i : integer ; s : real ; begin xsearch : = true ; xmin : = 0 ; xmax : = 0 ; ymin : = 0 ; ymax : = 0 ; readln(n) ; for i : = 1 to n do begin readln(x, y) ; if y = 0 then begin if xsearch or (xif xsearch or (x> ; xmax) then xmax : = x ; xsearch : = false ; end else if yelse if y> ; ymax then ymax : = y end ; if (xmax> ; xmin) and (ymin< ; 0) and (ymax> ; 0) then s : = (xmax - xmin) * (ymax - ymin) / 2 else s : = 0 ; writeln(s) ; end.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

111worni111wormi 5 нояб. 2020 г., 04:49:38 | 5 - 9 классы

Что не так в программе в конце должен вывести какое число больше program primer ; var a, b : integer ; wrateln : ; readln (a, b) ; if a> ; b then writeln(a) else writeln (b) ; end?

Что не так в программе в конце должен вывести какое число больше program primer ; var a, b : integer ; wrateln : ; readln (a, b) ; if a> ; b then writeln(a) else writeln (b) ; end.

Ряжка 25 дек. 2020 г., 18:21:48 | 5 - 9 классы

Помогите пожалуйста, cрочно?

Помогите пожалуйста, cрочно!

Составить блок - схему.

Program primer6 ;

uses crt ;

x : integer ;

begin

clrscr ;

readln(x) ;

if x mod 2 = 0 then writeln ('да')

else writeln ('нет')

end.

Вы зашли на страницу вопроса Program mimi ;var a, b : integer ;beginreadln (a) ;if 99 &lt ; a &lt ; thenwriteln('Неверно')elseif a&gt ; 999 thenwriteln('Неверно')elsewriten('Верно')end?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.