Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Информатика | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Ответить на вопрос
Ответы (1)
Klasskar 25 июн. 2020 г., 21:03:07

1)1ый условный оператор без условия

2)конец программы обозначается End.

, а не End ;

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Toluanchick2014 29 мар. 2020 г., 07:56:03 | 10 - 11 классы

Набрать в программе Pascal программу исправив ошибки : PROGRAM 123 ; USES CRT ; VAR A, S : INTEDGER ; BEGIN WRITELN ( 'ВВЕДИТЕ ДВА ЧИСЛА ') ; READ(Q, W) ; F : = Q / W ; WRITELN ( 'РЕЗУЛЬТАТ ' , F) ; R?

Набрать в программе Pascal программу исправив ошибки : PROGRAM 123 ; USES CRT ; VAR A, S : INTEDGER ; BEGIN WRITELN ( 'ВВЕДИТЕ ДВА ЧИСЛА ') ; READ(Q, W) ; F : = Q / W ; WRITELN ( 'РЕЗУЛЬТАТ ' , F) ; READLN ; END.

Svimpul03 13 нояб. 2020 г., 12:47:01 | 5 - 9 классы

Найдите ошибку пожалуйста Program percentage ; uses crt ; var a, b, c, d : real ; begin writeln('Здравствуйте, вас приветствует программа для нахождения процентов в заданиях ОГЭ?

Найдите ошибку пожалуйста Program percentage ; uses crt ; var a, b, c, d : real ; begin writeln('Здравствуйте, вас приветствует программа для нахождения процентов в заданиях ОГЭ.

Искомую переменную обозначтье (0).

') ; write('Введите переменную a - ') ; read(a) ; write('Введите переменную b - ') ; read(b) ; write('Введите переменную c - ') ; read(c) ; write('Введите переменную d - ') ; read(d) ; writeln ; if a = 0 then begin a : = c * b / d ; writeln(' Ответ : ', a) ; end ; if b = 0 then begin b : = a * d / c ; writeln(' Ответ : ', b) ; end ; if c = 0 then ; begin c : = a * d / b ; writeln(' Ответ : ', c) ; end ; if d = 0 then begin d : = c * b / a ; writeln(' Ответ : ', d) ; end ; writeln('Спасибо за использование программы!

') ; end.

Irinakirikovam 24 мая 2020 г., 05:37:28 | 5 - 9 классы

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end.

В чём ошибка?

Fhcff 11 июн. 2020 г., 17:05:20 | 10 - 11 классы

Помогите объяснить задачу?

Помогите объяснить задачу!

Program String29 ; var otvet : String ; i : integer ; S0, S : String ; C : char ; begin Writeln('Введите строкy S') ; readln(S) ; Writeln('Введите строкy S0') ; readln(S0) ; Writeln('Введите символ C') ; readln(C) ; for i : = 1 to length(S) do begin if S[i] = C then Otvet : = otvet + S0 + C else Otvet : = otvet + S[i] ; end ; Writeln('Ответ : ', otvet) ; end.

Оорр1 6 мар. 2020 г., 00:18:39 | 5 - 9 классы

Program mimi ;var a, b : integer ;beginreadln (a) ;if 99 < ; a < ; thenwriteln('Неверно')elseif a> ; 999 thenwriteln('Неверно')elsewriten('Верно')end?

Program mimi ;

var a, b : integer ;

begin

readln (a) ;

if 99 < ; a < ; then

writeln('Неверно')

else

if a> ; 999 then

writeln('Неверно')

else

writen('Верно')

end.

Выдаёт : pas(5) : Ожидался идентификатор

Что не так?

Dinifest 8 апр. 2020 г., 04:06:32 | 10 - 11 классы

Procedure F(n : integer) ; begin if n> ; 0 then begin f(n - 1) ; F(n - 3) ; writeln(n) ; end ; writeln (n + 3) ; end ; Что напечатает программа при F(2)?

Procedure F(n : integer) ; begin if n> ; 0 then begin f(n - 1) ; F(n - 3) ; writeln(n) ; end ; writeln (n + 3) ; end ; Что напечатает программа при F(2)?

Как решить подробно?

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Zaika220681 25 нояб. 2020 г., 06:38:19 | 10 - 11 классы

Выдает ошибку Операция > ; не может быть применена к типам boolean и integer Program qq ; var a, b, c, max, min, med : integer ; begin writeln ('введите три числа') ; read (a, b, c) ; if c> ; b>?

Выдает ошибку Операция > ; не может быть применена к типам boolean и integer Program qq ; var a, b, c, max, min, med : integer ; begin writeln ('введите три числа') ; read (a, b, c) ; if c> ; b> ; a then begin max : = c ; med : = b ; min : = a ; End ; if b> ; a> ; c then begin max : = b ; med : = a ; min : = c ; End ; if a> ; c> ; b then begin max : = a ; med : = c ; min : = b ; End ; writeln ('наибольшее число', max) ; writeln ('среднее число', med) ; writeln ('наименьшее число', min) ; End.

Ряжка 25 дек. 2020 г., 18:21:48 | 5 - 9 классы

Помогите пожалуйста, cрочно?

Помогите пожалуйста, cрочно!

Составить блок - схему.

Program primer6 ;

uses crt ;

x : integer ;

begin

clrscr ;

readln(x) ;

if x mod 2 = 0 then writeln ('да')

else writeln ('нет')

end.

На этой странице сайта размещен вопрос Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.