Даны два массива?

Информатика | 10 - 11 классы

Даны два массива.

Получить третий массив который на четных номерах элементы второго массива на нечетных элементы первого массива.

Решите пожалуйста через pascal ABC и опишите программу.

Ответить на вопрос
Ответы (1)
3KoT3 18 июл. 2020 г., 14:37:00

Количество элементов в массивах одинаковое и равно n.

A - первый массив

b - второй массив

c - третий массив

i - цикловая переменная, индекс элемента массива

var

a, b, c : array [1.

100] of integer ;

n, i : integer ;

begin

readln (n) ;

for i : = 1 to n do

readln (a [ i ]) ;

[ввели первый массив]

for i : = 1 to n do

readln (b [ i ]) ;

[ввели второй массив] for i : = 1 to n do

begin

if i mod 2 = 0 then [проверка индекса элемента на чётность]

c [ i ] = b [ i ] ;

else

c [ i ] = a [ i ] ;

end ;

[создали третий] for i : = 1 to n do

writeln (c [ i ] : 4) ;

[вывод третьего массива]

end.

Можно всё это сделать одним циклом.

Var

a, b, c : array [1.

100] of integer ;

n, i : integer ;

begin

readln (n) ;

for i : = 1 to n do

begin

readln (a [ i ]) ;

readln (b [ i ]) ;

if i mod 2 = 0 then

c [ i ] = b [ i ] ;

else

c [ i ] = a [ i ] ;

writeln (c [ i ] : 4) ;

end ;

end.

Vsemhanaotantohi 21 февр. 2020 г., 03:57:36 | 10 - 11 классы

Создать процедуру, которая реализует решение предложенной задачи на паскале Задан массив с количеством элементов N?

Создать процедуру, которая реализует решение предложенной задачи на паскале Задан массив с количеством элементов N.

Сформировать два массива : в первый включить элементы исходного массива с четными номерами, а во второй — с нечетными.

Olpolyak2010 16 авг. 2020 г., 04:26:16 | 5 - 9 классы

СОСТАВИТЬ БЛОК - СХЕМУ АЛГОРИТМА Задан массив с количеством элементов N?

СОСТАВИТЬ БЛОК - СХЕМУ АЛГОРИТМА Задан массив с количеством элементов N.

Сформируйте два массива : в первый включите элементы исходного массива с четными номерами, а во второй – с нечетными.

TATATATAS 1 июл. 2020 г., 05:45:42 | 10 - 11 классы

Заданы два двумерных целочислительных массива ?

Заданы два двумерных целочислительных массива .

Найти максимальный элемент в первом массиве и если он положительный чётный уменьшить его величину все положительные четные элементы второго массива .

Таблица программа блок схемах.

Помогите пожалуйста!

Bashkatovamash 3 нояб. 2020 г., 18:19:30 | 10 - 11 классы

Дан массив B(n * m)?

Дан массив B(n * m).

Элементы массива ввести в программе.

Найти сумму четных элементов массива.

Паскаль.

Vitaly198703 11 сент. 2020 г., 05:36:00 | 10 - 11 классы

Ввести два целочисленныхмассива − по 10 элементов в каждом?

Ввести два целочисленныхмассива − по 10 элементов в каждом.

Сформировать новый массив, на четных местах которого будут элементы с нечетными индексами из первого массива, а нанечетных – с четными индексами из второго.

Написать программу на паскале.

Vika19973 10 февр. 2020 г., 04:51:12 | 10 - 11 классы

Pascal ABC?

Pascal ABC.

Написать программу, которая находит сумму четных элементов массива произвольного размера (размер и элементы массива вводятся с клавиатуры).

Ksenia22111 8 июн. 2020 г., 11:23:19 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста.

1. Дан массив (n * m).

Элементы массива ввести случайным способом.

Найти сумму элементов которые больше данного числа А.

Число А ввести с клавиатуры.

2. Дан массив (n * m).

Элементы массива ввести в программе.

Найти первый элемент, являющийся простым числом и его инедксы.

3. Дан массив (n * m).

Элементы массива ввести с клавиатуры.

Найти количество четных элементов массива.

Катя20045 21 апр. 2020 г., 14:50:56 | 5 - 9 классы

В линейном массиве определить минимальный элемент из элементов массива, имеющих нечетные номера?

В линейном массиве определить минимальный элемент из элементов массива, имеющих нечетные номера.

Artem1918 1 янв. 2020 г., 05:23:47 | 10 - 11 классы

Создать два одномерных массива, состоящих из целых чисел?

Создать два одномерных массива, состоящих из целых чисел.

Элементы массива вводятся с клавиатуры.

В первом массиве найти номер первого нечетного элемента массива.

Во втором массиве найти первый четный элемент массива.

Решить на Pascal ABC (При решении задач обязательно использовать одномерные массивы и процедуры или функции работы с одномерными массивами.

).

DeadGirl5 6 сент. 2020 г., 01:59:41 | 10 - 11 классы

Turbo Pascal * * * * (Дан одномерный числовой массив?

Turbo Pascal * * * * (Дан одномерный числовой массив.

Определить произведение элементов массива, расположенных между максимальным и «центральным» элементами массива (предполагается, что число элементов – нечетное и максимальный единственный).

На этой странице сайта вы найдете ответы на вопрос Даны два массива?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.