Turbo Pascal * * * * (Дан одномерный числовой массив?

Информатика | 10 - 11 классы

Turbo Pascal * * * * (Дан одномерный числовой массив.

Определить произведение элементов массива, расположенных между максимальным и «центральным» элементами массива (предполагается, что число элементов – нечетное и максимальный единственный).

Ответить на вопрос
Ответы (1)
Jva2001 6 сент. 2020 г., 01:59:43

Const n = 15 ;

var a : array[1.

N] of integer ;

i, max, imax : integer ; p : real ;

begin

Randomize ;

for i : = 1 to n do begin

a[i] : = random(21) ;

write(a[i] : 3) ;

end ;

writeln ;

max : = a[1] ; imax : = 1 ;

for i : = 2 to n do

if a[i]>max then begin max : = a[i] ; imax : = i ; end ;

writeln('max = ', max, ' imax = ', imax) ;

p : = 1 ;

if imax > n div 2 + 1

then for i : = n div 2 + 2 to imax - 1 do p : = p * a[i]

else for i : = imax + 1 to n div 2 do p : = p * a[i] ;

writeln('p = ', p) ;

end.

Пример :

16 14 14 20 6 12 16 15 7 0 19 17 0 7 14

max = 20 imax = 4

p = 1152.

FroZen007 14 нояб. 2020 г., 19:08:11 | 10 - 11 классы

Напишите программу пожалуйста в паскалепроизведение элементов массива, расположенных между максимальным и минимальным элементами ?

Напишите программу пожалуйста в паскале

произведение элементов массива, расположенных между максимальным и минимальным элементами ;

Ellada0308 15 мая 2020 г., 03:38:11 | 5 - 9 классы

ПОМОГИТЕ?

ПОМОГИТЕ!

Дан одномерный массив размерностью 40 элементов, изменяющийся от - 100 до 100.

Определить максимальный элемент массива и его номер без учёта максимального.

Это нужно в паскале.

Linevdv 24 янв. 2020 г., 10:35:12 | 10 - 11 классы

Помогите ?

Помогите .

Найти максимальный элемент одномерного массива из 30 элементов.

Julia8282 3 дек. 2020 г., 11:36:00 | 5 - 9 классы

Дан одномерный массив, состоящий из N элементов?

Дан одномерный массив, состоящий из N элементов.

Найти максимальный из нечетных элементов массива.

Megaalinamail 21 авг. 2020 г., 13:14:46 | 5 - 9 классы

Дан одномерный массив чисел?

Дан одномерный массив чисел.

Hайти количество элементов массива, превосходящих по модулю заданное число А, изменить знак максимального элемента на противоположный, найти количество элементов массива, кратных 5.

Aylovat40 16 окт. 2020 г., 08:55:54 | 10 - 11 классы

Дан одномерный массив из 12 чисел?

Дан одномерный массив из 12 чисел.

Элементами массива являются целые числа.

Найти максимальный элемент указанного массива.

Elviraartisheva 5 июн. 2020 г., 06:39:40 | 1 - 4 классы

Дано два одномерных массива A и B?

Дано два одномерных массива A и B.

Заменить местами максимальные элементы массивов A и B.

Использовать процедуру нахождения максимального элемента массива.

Преобразовать эту программу для двумерного массива.

Катюшащенок 21 нояб. 2020 г., 01:23:06 | 10 - 11 классы

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элемен?

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элементов массива, расположенных между максимальным и минимальным элементами.

Сформировать из этих элементов новый массив.

Дашуньяяя 4 дек. 2020 г., 08:21:00 | 10 - 11 классы

Найти максимальный элемент одномерного массива, содержащего А) 10 элементов ; Б) n элементов (число элементов массива вводится с клавиатуры) (в Qbasic)?

Найти максимальный элемент одномерного массива, содержащего А) 10 элементов ; Б) n элементов (число элементов массива вводится с клавиатуры) (в Qbasic).

Osya00 4 дек. 2020 г., 15:10:44 | 10 - 11 классы

В одномерном массиве из 10 элементов определить местоположение минимального и максимального элементов?

В одномерном массиве из 10 элементов определить местоположение минимального и максимального элементов.

Обнулить элементы, стоящие между ними , а также вывести полученный массив.

На этой странице находится вопрос Turbo Pascal * * * * (Дан одномерный числовой массив?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.