Помогите пожалуйста?

Информатика | 10 - 11 классы

Помогите пожалуйста.

1. Дан массив (n * m).

Элементы массива ввести случайным способом.

Найти сумму элементов которые больше данного числа А.

Число А ввести с клавиатуры.

2. Дан массив (n * m).

Элементы массива ввести в программе.

Найти первый элемент, являющийся простым числом и его инедксы.

3. Дан массив (n * m).

Элементы массива ввести с клавиатуры.

Найти количество четных элементов массива.

Ответить на вопрос
Ответы (1)
Арсенийт 8 июн. 2020 г., 11:23:24

Const nx = 20 ; mx = 20 ; var i, j, n, S, a, m : integer ; D : array[1.

Nx, 1.

Nx] of integer ;

begin

write('Введите размер матрицы n и m') ; Readln(n, m) ;

write('Введите число А') ; Readln(a) ;

for i : = 1 to n do begin

for j : = 1 to m do begin

D[i, j] : = random(100) - 50 ;

write(D[i, j] : 4) ;

if D[i, j] > ; a then S : = S + D[i, j] ;

end ; writeln ; end ;

writeln ;

write('S = ', S : 5) ;

end.

Marusialu 26 мар. 2020 г., 16:18:25 | 5 - 9 классы

Программа КуМир (НЕ ПАСКАЛЬ?

Программа КуМир (НЕ ПАСКАЛЬ!

КуМир!

РУССКАЯ ПРОГРАММА!

)Ввести с клавиатуры массив из 5 элементов, найти среднее арифметическое всех элементов массива.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Яапелс 7 июн. 2020 г., 06:57:01 | 5 - 9 классы

С клавиатуры ввести массив А (Б)?

С клавиатуры ввести массив А (Б).

Найти сумму всех элементов массива.

Вывести ее на экран, и массив опять.

Bashkatovamash 3 нояб. 2020 г., 18:19:30 | 10 - 11 классы

Дан массив B(n * m)?

Дан массив B(n * m).

Элементы массива ввести в программе.

Найти сумму четных элементов массива.

Паскаль.

Clashofclans080 30 нояб. 2020 г., 06:32:46 | 10 - 11 классы

Дан массив а, состоящий из 3 элементов, ввести элементы массива с клавиатуры и вывести на экран в обратном порядке?

Дан массив а, состоящий из 3 элементов, ввести элементы массива с клавиатуры и вывести на экран в обратном порядке.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Artembabynin20 3 мая 2020 г., 13:07:17 | 10 - 11 классы

Ввести с клавиатуры массив из 5 элементов, найти среднее арифметическое всех элементов массива?

Ввести с клавиатуры массив из 5 элементов, найти среднее арифметическое всех элементов массива.

Maneckoba0sha 21 апр. 2020 г., 16:28:40 | 10 - 11 классы

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный?

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент.

Лианель 21 сент. 2020 г., 00:02:03 | 5 - 9 классы

Прога на паскале?

Прога на паскале.

Ввести элемент, ввести массив.

Если в массиве присудствует этот элемент, то ничего не делаем.

Если его нет, то нужно вставить его в середину массива (если массив не четный, то по любую сторону от элемента, находящегося в его середине) помогите пожалуйста))).

Nonnn 23 сент. 2020 г., 16:39:40 | 10 - 11 классы

Найти среднее геометрическое элементов массива, принадлежащих [a, b]?

Найти среднее геометрическое элементов массива, принадлежащих [a, b].

Количество элементов и границы ввести с клавиатуры.

На странице вопроса Помогите пожалуйста? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.