Дано натуральное число?

Информатика | 5 - 9 классы

Дано натуральное число.

Вывести произведение его четных цифр (программа).

Ответить на вопрос
Ответы (1)
Andreichernivchan 14 апр. 2020 г., 18:39:09

Uses crt ;

var a, pr, n : integer ;

begin pr : = 1 ; write('Введите число : ') ; readln(a) ; while a> ; 0 do begin n : = a mod 10 ; if (n mod 2 = 0) and (n< ; > ; 0) then pr : = pr * n ; a : = a div 10 ; end ; writeln('Произведение четных цифр числа : ', pr) ;

end.

Zhuzhechko 28 авг. 2020 г., 06:24:19 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль.

Danhek32 14 сент. 2020 г., 13:24:15 | 10 - 11 классы

Водится 2 числа, вывести сумму цифр первого, если оно больше второго и произведение четных цифр второго числа в противном случае(pascal)?

Водится 2 числа, вывести сумму цифр первого, если оно больше второго и произведение четных цифр второго числа в противном случае(pascal).

Lizaaleksandrova95 9 янв. 2020 г., 18:40:49 | 5 - 9 классы

Дано целое двузначное число?

Дано целое двузначное число.

Верно ли, что обе его цифры четные?

(Ответ вывести в форме «Да» либо «Нет»).

Лили20151 10 сент. 2020 г., 02:02:35 | 5 - 9 классы

Составить программу по задаче :Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное"?

Составить программу по задаче :

Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное".

Lenchik364 10 окт. 2020 г., 22:25:45 | 10 - 11 классы

В данном целом числе N, заменить нулями все четные цифры в данном числе?

В данном целом числе N, заменить нулями все четные цифры в данном числе.

Вывести полученное число.

(Паскаль).

Dedit 2 мая 2020 г., 03:57:07 | 5 - 9 классы

Дано 3 двузначных числа?

Дано 3 двузначных числа.

Вывести на экран те числа, в которых сумма цифр является четным числом.

20021114257 21 авг. 2020 г., 00:53:10 | 10 - 11 классы

Помогитe составить программу на Free Pascal?

Помогитe составить программу на Free Pascal.

Дано натуральное число.

Верно ли, что произведение его цифр не больше 50.

Alina30001 11 июн. 2020 г., 10:10:43 | 10 - 11 классы

Дано целое четырехзначное число?

Дано целое четырехзначное число.

Если число четное, найти произведение его цифр, иначе перевернуть число, записав его цифры в обратном порядке.

Написать программу в Паскале.

Streej1 4 окт. 2020 г., 15:08:49 | 10 - 11 классы

Помогите, пожалуйста, написать программу на языке С + + ?

Помогите, пожалуйста, написать программу на языке С + + .

Дано натурально число А в десятичной системе счисления.

Если все цифры числа А различные, то вывести на экран сообщение "Да", иначе - сообщение "Нет".

Yps 1 окт. 2020 г., 23:15:52 | 10 - 11 классы

Составить программу в с + +Дано натуральное число :1) найти кол - во четных цифр этого числа2) верно ли, что в Данном числе встречается A и B (числа A и B вводится с клавиатуры)?

Составить программу в с + +

Дано натуральное число :

1) найти кол - во четных цифр этого числа

2) верно ли, что в Данном числе встречается A и B (числа A и B вводится с клавиатуры).

На этой странице вы найдете ответ на вопрос Дано натуральное число?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.