Дано натуральное число?

Информатика | 10 - 11 классы

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль.

Ответить на вопрос
Ответы (1)
Skaystayl 28 авг. 2020 г., 06:24:23

Var n : longint ; s : string ; i, ch, neCh : integer ;

begin readln(n) ; s : = intToStr(n) ; i : = 1 ; while (i < ; = length(s)) do begin if (strToInt(s[i]) mod 2 = 1) then neCh : = neCh + 1 else ch : = ch + 1 ; i : = i + 1 ; end ; if (ch > ; neCh) then writeln('Чётных чисел больше') ; if (ch < ; neCh) then writeln('Нечётных чисел больше') ; if (ch = neCh) then writeln('Чётных и нечётных чисел поровну') ;

end.

Lapteva240677 21 дек. 2020 г., 02:11:37 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найти максимальную цифру.

В паскале.

Через while.

Belousovaket 27 февр. 2020 г., 11:21:39 | 10 - 11 классы

Дано натуральное четырехзначное число?

Дано натуральное четырехзначное число.

Найти наименьшую нечетную цифру в числовой записи данного числа.

На языке С + + .

Antonkhvorov 20 июн. 2020 г., 12:56:51 | 10 - 11 классы

1) дано натуральное а?

1) дано натуральное а.

Верно ли, что данное число состоит из 3 цифр?

2) дано натуральное число.

Верно ли, что в данном числе четыре цифры?

3) Даны два натуральных числа.

Определить в каком числе первая цифра больше.

4) Дано натуральное n.

Найти количество 6, входящих в данное число.

Нужно решить в программе паскаль.

Если поможет, то мы учим цикл в паскале, div, mod.

Nastya132000 1 сент. 2020 г., 01:35:08 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить количество его нечетных делителей.

Написать программу паскаль).

Lenchik364 10 окт. 2020 г., 22:25:45 | 10 - 11 классы

В данном целом числе N, заменить нулями все четные цифры в данном числе?

В данном целом числе N, заменить нулями все четные цифры в данном числе.

Вывести полученное число.

(Паскаль).

Доббик 4 окт. 2020 г., 05:44:07 | 10 - 11 классы

ПАСКАЛЬ, ИНФОРМАТИКА?

ПАСКАЛЬ, ИНФОРМАТИКА.

П о м о г и т е Дано натуральное число.

Найти количество нечетных цифр в нем.

Ханчик5 14 апр. 2020 г., 18:39:02 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Вывести произведение его четных цифр (программа).

Вадим2351 14 мая 2020 г., 00:59:34 | 10 - 11 классы

Дано натуральное число n?

Дано натуральное число n.

Проверить будут ли все цифры числа различными паскаль.

Ryazanceva0303 28 мая 2020 г., 19:24:24 | 5 - 9 классы

Дано натуральное число ?

Дано натуральное число .

Определить есть ли в нем цифра а Написать с постусловием язык Паскаля !

Lerchik1204 3 нояб. 2020 г., 02:25:45 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Найти максимальную цифру.

В паскале.

Через процедуры.

На этой странице находится ответ на вопрос Дано натуральное число?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.