Помогитe составить программу на Free Pascal?

Информатика | 10 - 11 классы

Помогитe составить программу на Free Pascal.

Дано натуральное число.

Верно ли, что произведение его цифр не больше 50.

Ответить на вопрос
Ответы (1)
Demidenkozhenya 21 авг. 2020 г., 00:53:16

Если число не слишком большое, то :

var n, p : integer ;

begin

write('n = ') ;

readln(n) ;

p : = 1 ;

while n> ; 0 do

begin

p : = p * (n mod 10) ;

n : = n div 10 ;

end ;

if p< ; = 50

then writeln('Произведение цифр числа = ', p, ' (< ; = 50)')

else writeln('Произведение цифр числа = ', p, ' (> ; 50)') ;

end.

Пример :

n = 456

Произведение цифр числа = 120 (> ; 50).

Alexa36 20 мая 2020 г., 14:44:04 | 10 - 11 классы

Написать программу в Free Pascal : Дано целое число неизвестной размерности?

Написать программу в Free Pascal : Дано целое число неизвестной размерности.

Найти сумму цифр его составляющих.

Winterbottom 13 июн. 2020 г., 22:55:51 | 5 - 9 классы

Дано целое число N?

Дано целое число N.

Составить программу нахождения количества цифр числа (Pascal ABC).

Wowwic200 11 окт. 2020 г., 16:06:25 | 5 - 9 классы

Составить программу?

Составить программу.

Дано натуральное число n.

Подсчитать количество цифр этого числа.

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Ivanushun12345 2 июл. 2020 г., 12:04:02 | 5 - 9 классы

Pascal ABC?

Pascal ABC.

Дано натуральное число "n".

Составьте программу которая выводит максимальную цифру этого числа.

Ханчик5 14 апр. 2020 г., 18:39:02 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Вывести произведение его четных цифр (программа).

Саид55 28 мар. 2020 г., 02:25:50 | 5 - 9 классы

Составить программу Pascal : Найти произведение цифр заданого 3х значного числа ?

Составить программу Pascal : Найти произведение цифр заданого 3х значного числа .

Nightmore 21 дек. 2020 г., 09:41:46 | 5 - 9 классы

Как в программе free pascal создать программу которая задает вопросы или загадки если отвечаешь верно он говарит верно и?

Как в программе free pascal создать программу которая задает вопросы или загадки если отвечаешь верно он говарит верно и.

Vksolopova 6 мар. 2020 г., 16:16:29 | 10 - 11 классы

Даны два целых двузначных числа?

Даны два целых двузначных числа.

Верное ли, что все цифры первого числа больше соответствующих цифр второго числа?

Написать программу для Pascal.

Skalok 12 дек. 2020 г., 07:17:43 | 10 - 11 классы

Составить программу, прошу) Дано натуральное число, верно ли что оно начинается и заканчивается одной и той же цифрой?

Составить программу, прошу) Дано натуральное число, верно ли что оно начинается и заканчивается одной и той же цифрой.

На этой странице находится вопрос Помогитe составить программу на Free Pascal?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.