В данном целом числе N, заменить нулями все четные цифры в данном числе?

Информатика | 10 - 11 классы

В данном целом числе N, заменить нулями все четные цифры в данном числе.

Вывести полученное число.

(Паскаль).

Ответить на вопрос
Ответы (1)
Dashik 10 окт. 2020 г., 22:25:47

Program changeNum ;

var

num : string ;

ci : byte ;

begin

readln(num) ;

for ci : = 1 to ord(num[0]) do

if (ord(num[ci]) - 48) mod 2 = 0 thennum[ci] : = '0' ;

writeln ;

write(num) ; readln ;

end.

Vedma12 13 февр. 2020 г., 05:20:31 | 5 - 9 классы

Помогите, пожалуйста, составить программу в паскале?

Помогите, пожалуйста, составить программу в паскале!

Дано четырехзначное число заменить в нем наибольшую цифру нулем.

Nizami2000 29 янв. 2020 г., 23:46:35 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Вывести порядковый номер его минимальной цифры.

Паскаль.

Cordelia 14 окт. 2020 г., 20:22:46 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Паскаль

дано четырехзначное число, заменить нулем максимальную цифру.

Zhuzhechko 28 авг. 2020 г., 06:24:19 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль.

Vikusya16 18 мая 2020 г., 22:28:20 | 10 - 11 классы

3. Дано целое трехзначное число А?

3. Дано целое трехзначное число А.

Вывести цифры этого числа на экран в столбик.

Паскаль.

Lizaaleksandrova95 9 янв. 2020 г., 18:40:49 | 5 - 9 классы

Дано целое двузначное число?

Дано целое двузначное число.

Верно ли, что обе его цифры четные?

(Ответ вывести в форме «Да» либо «Нет»).

8889674 5 февр. 2020 г., 20:27:53 | 5 - 9 классы

1. Дано двузначное число?

1. Дано двузначное число.

Найти разность и частное его цифр.

2. Дано целое число.

Если оно является положительным то прибавить к нему 1.

Емли нулевым то заменить его на 10.

3. Дано двузначное число.

Вывести его левую цифру, потом правую.

4. Дано целое число, определить является ли оно четным.

5. даны два целых числа.

Найти сумму всех целых чисел от а до в.

Написать программы (паскаль).

Ханчик5 14 апр. 2020 г., 18:39:02 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Вывести произведение его четных цифр (программа).

Megoryan 3 сент. 2020 г., 01:31:11 | 5 - 9 классы

Дано целое число N увеличить число в 3 раза если число четное ?

Дано целое число N увеличить число в 3 раза если число четное .

Входные данные 4.

Выводимые данные 12.

Паскаль.

Alina30001 11 июн. 2020 г., 10:10:43 | 10 - 11 классы

Дано целое четырехзначное число?

Дано целое четырехзначное число.

Если число четное, найти произведение его цифр, иначе перевернуть число, записав его цифры в обратном порядке.

Написать программу в Паскале.

На этой странице вы найдете ответ на вопрос В данном целом числе N, заменить нулями все четные цифры в данном числе?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.