Водится 2 числа, вывести сумму цифр первого, если оно больше второго и произведение четных цифр второго числа в противном случае(pascal)?

Информатика | 10 - 11 классы

Водится 2 числа, вывести сумму цифр первого, если оно больше второго и произведение четных цифр второго числа в противном случае(pascal).

Ответить на вопрос
Ответы (1)
Pro100elena1901 14 сент. 2020 г., 13:24:18

Var

S, a, b : integer ;

p : real ;

begin readln(a, b) ; p : = 1 ; s : = 0 ; if a> ; b then begin while abs(a)> ; 0 do begin s : = s + (abs(a) mod 10) ; a : = a div 10 ; end ; writeln('s = ', s) end else begin while abs(b)> ; 0 do begin p : = p * (abs(b) mod 10) ; b : = b div 10 ; end ; writeln('P = ', p : 4 : 2) ; end ;

end.

Simma 23 янв. 2020 г., 23:27:23 | 10 - 11 классы

Написать программу, объясните?

Написать программу, объясните.

Ввести двухзначное число.

Если сумма цифр числа четная, то увеличить число на 2, в противном случае уменьшит на 2.

Милкашоколад 22 дек. 2020 г., 17:50:09 | 5 - 9 классы

Д / З по теме "Алгоритмическая конструкция : цикл" ЗАДАЧА "Разбор числа на цифры" Ввести многозначное число?

Д / З по теме "Алгоритмическая конструкция : цикл" ЗАДАЧА "Разбор числа на цифры" Ввести многозначное число.

Найти : младшую цифру числа ; старшую цифру числа ; сумму цифр числа ; произведение цифр ; количество цифр ; минимальную цифру числа ; максимальную цифру числа ; количество нулевых цифр ; сумму четных цифр ; произведение цифр, кратных 3.

СРОООООООООЧно.

Кира20035 23 февр. 2020 г., 15:11:59 | 5 - 9 классы

Написать алгоритм решения следующей задачи?

Написать алгоритм решения следующей задачи.

Роботу передаются 2 числа.

Если первое число меньше второго, то робот должен вывести на экран их произведение, в противном случае сумму.

Walerik 7 нояб. 2020 г., 01:31:53 | 5 - 9 классы

Дано пятизначное число?

Дано пятизначное число.

Найти сумму первой, третьей , пятой цифр произведение второй и четвертой.

Ханчик5 14 апр. 2020 г., 18:39:02 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Вывести произведение его четных цифр (программа).

Dedit 2 мая 2020 г., 03:57:07 | 5 - 9 классы

Дано 3 двузначных числа?

Дано 3 двузначных числа.

Вывести на экран те числа, в которых сумма цифр является четным числом.

Mary2001S 14 сент. 2020 г., 02:04:00 | 1 - 4 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму кубов первой и второй его цифр.

ТаткаТаточка 3 мая 2020 г., 01:57:08 | 5 - 9 классы

С клавиатуры вводится 5 - значное число?

С клавиатуры вводится 5 - значное число.

Если первая и последняя цифры этого числа четные, вывести на экран "четные", в противном случае вывести "нечетные" помогите пж.

Zharikoffmixa 16 июн. 2020 г., 01:33:30 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Информатика, 10 класс, Паскаль 1)Написать программу.

Вводятся два двухзначных целых числа.

Подсчитать и вывести два числа : сумма десятков первого и второго числа и сумма единиц первого и второго числа.

2)Вводятся два двухзначных целых числа.

Подсчитать и вывести два числа : произведение десятков первого числа и единиц второго числа ; произведение единиц первого числа и десятков второго.

3)Вводятся два двухзначных целых числа.

Подсчитать и вывести два числа : произведение десятков первого числа и единиц второго числа ; сумма единиц первого числа и десятков второго числа.

Alena1901 13 окт. 2020 г., 12:56:56 | 5 - 9 классы

Вывести вторую цифру терёхзначного числа?

Вывести вторую цифру терёхзначного числа.

На этой странице сайта вы найдете ответы на вопрос Водится 2 числа, вывести сумму цифр первого, если оно больше второго и произведение четных цифр второго числа в противном случае(pascal)?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.