Где здесь ошибка ?

Информатика | 5 - 9 классы

Где здесь ошибка ?

Program Ylia ; var A, B, C : real ; Begin Readln (a, b) if a> ; b ; C1 = ab else C2 = a / b ; writeln (c) ; end.

Ответить на вопрос
Ответы (1)
Елена02072003 26 апр. 2020 г., 21:22:59

Readln(a, b) ;

if a> ; b then c : = a * b

else c : = a / b ;

writteln(c) ;

readln ;

End.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

MikaEpt 27 апр. 2020 г., 10:34:15 | 5 - 9 классы

ЧТО НЕ ПРАВИЛЬНО?

ЧТО НЕ ПРАВИЛЬНО?

Program p_1 ;

var x, y : real ;

begin

read(x) ;

if 0< ; x< ; 2 then begin y : = sqr(cos(x)) ;

else begin y : = 1 - sin(sqr(x)) ;

end ;

writeln(y) ;

end.

Toluanchick2014 29 мар. 2020 г., 07:56:03 | 10 - 11 классы

Набрать в программе Pascal программу исправив ошибки : PROGRAM 123 ; USES CRT ; VAR A, S : INTEDGER ; BEGIN WRITELN ( 'ВВЕДИТЕ ДВА ЧИСЛА ') ; READ(Q, W) ; F : = Q / W ; WRITELN ( 'РЕЗУЛЬТАТ ' , F) ; R?

Набрать в программе Pascal программу исправив ошибки : PROGRAM 123 ; USES CRT ; VAR A, S : INTEDGER ; BEGIN WRITELN ( 'ВВЕДИТЕ ДВА ЧИСЛА ') ; READ(Q, W) ; F : = Q / W ; WRITELN ( 'РЕЗУЛЬТАТ ' , F) ; READLN ; END.

Irinakirikovam 24 мая 2020 г., 05:37:28 | 5 - 9 классы

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end.

В чём ошибка?

Оорр1 6 мар. 2020 г., 00:18:39 | 5 - 9 классы

Program mimi ;var a, b : integer ;beginreadln (a) ;if 99 < ; a < ; thenwriteln('Неверно')elseif a> ; 999 thenwriteln('Неверно')elsewriten('Верно')end?

Program mimi ;

var a, b : integer ;

begin

readln (a) ;

if 99 < ; a < ; then

writeln('Неверно')

else

if a> ; 999 then

writeln('Неверно')

else

writen('Верно')

end.

Выдаёт : pas(5) : Ожидался идентификатор

Что не так?

14013 10 мая 2020 г., 01:22:45 | 10 - 11 классы

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе?

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе.

Написать тот вариант программы, который, по Вашему мнению, будет правильным.

Program My_Error ; Var X, Y, Сумма : Integer ; Begin WriteLn( Введите значение X) ; ReadLn(X) ; WriteLn( Введите значение Y) ; ReadLn(Y) ; Сумма = X + Y ; WriteLn(Сумма) End.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Fylhsqre 23 февр. 2020 г., 18:27:31 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

3. Найдите ошибки в программе и запишите исправленную программу в тетрадь : Program 3 funkciy ; Var x : y : integer Writeln (‘введите значение х’) ; Readln(х) ; Begin If x> ; 0 then y : = x ; else y : = x * x ; writeln(значение функции , y) ; end.

4. Дана программа на языке Паскаль : Program a2 ; Var a, b, c, min : real ; Begin Writeln (‘введите 3 числа’) ; Readln(a, b, c) ; min : = a ; if b.

Sashakolesnsk2 20 дек. 2020 г., 18:01:57 | 10 - 11 классы

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3?

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3.

5 ; writeln (a) ; end.

На этой странице вы найдете ответ на вопрос Где здесь ошибка ?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.