Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе?

Информатика | 10 - 11 классы

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе.

Написать тот вариант программы, который, по Вашему мнению, будет правильным.

Program My_Error ; Var X, Y, Сумма : Integer ; Begin WriteLn( Введите значение X) ; ReadLn(X) ; WriteLn( Введите значение Y) ; ReadLn(Y) ; Сумма = X + Y ; WriteLn(Сумма) End.

Ответить на вопрос
Ответы (1)
Громка 10 мая 2020 г., 01:22:51

Название переменной не может состоять из русских букв

то, что выводится на экран, заключается в одинарные кавычки (' ')

знак присвоения значения не = , а : = .

Вариант верной программы :

var x, y, summa : integer ;

begin

writeln('Введите значение Х') ;

readln(x) ;

writeln('Введите значение У') ;

readln(y) ;

summa : = x + y ;

writeln(summa)

end.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Toluanchick2014 29 мар. 2020 г., 07:56:03 | 10 - 11 классы

Набрать в программе Pascal программу исправив ошибки : PROGRAM 123 ; USES CRT ; VAR A, S : INTEDGER ; BEGIN WRITELN ( 'ВВЕДИТЕ ДВА ЧИСЛА ') ; READ(Q, W) ; F : = Q / W ; WRITELN ( 'РЕЗУЛЬТАТ ' , F) ; R?

Набрать в программе Pascal программу исправив ошибки : PROGRAM 123 ; USES CRT ; VAR A, S : INTEDGER ; BEGIN WRITELN ( 'ВВЕДИТЕ ДВА ЧИСЛА ') ; READ(Q, W) ; F : = Q / W ; WRITELN ( 'РЕЗУЛЬТАТ ' , F) ; READLN ; END.

SonyaSkupnova 6 апр. 2020 г., 22:46:23 | 5 - 9 классы

Объяснить, что будет напечатано программой program e3 ; var a, b : integer ; begin read(a, b) ; writeln(a, b, a) ; end?

Объяснить, что будет напечатано программой program e3 ; var a, b : integer ; begin read(a, b) ; writeln(a, b, a) ; end.

Исходные значения а и b : 2 и 0?

Sinfsh 3 дек. 2020 г., 15:01:04 | 5 - 9 классы

Перепишите программу на языке Паскаль, исправив ошибки : Program primer Var a, b : integer ; Begin ; ReadLn( a, b) ; s = a + b ; m : = a * b ; d : = a : b ; WriteLn(s) ; WriteLn(m) ; WriteLn(d) End?

Перепишите программу на языке Паскаль, исправив ошибки : Program primer Var a, b : integer ; Begin ; ReadLn( a, b) ; s = a + b ; m : = a * b ; d : = a : b ; WriteLn(s) ; WriteLn(m) ; WriteLn(d) End.

Smile2200 3 сент. 2020 г., 23:45:34 | 5 - 9 классы

Задание : Написать программу вычисляющую сумму четырех чисел?

Задание : Написать программу вычисляющую сумму четырех чисел.

(PascalABC) Решение : Program sum ; Var a, b, c, d, summa : Integer ; Begin Readln(a, b, c, d) ; summa : = a + b + c + d Writeln('Ответ равен : ', summa) ; End.

На предпоследней строчке(перед End) выдает ошибку - встречено writeln а ожидалось ' ; ' Что не так?

Vadeeme798 20 апр. 2020 г., 06:39:09 | 5 - 9 классы

Вычислить сумму 10 натуральных чисел, вводимых с клавиатуры?

Вычислить сумму 10 натуральных чисел, вводимых с клавиатуры.

Program Demofor1 ;

Var S, P, I : integer ; Begin

For I : = .

To . doBeginWriteln (‘Введите число’) ;

(P) ; S : = S + .

;

End ;

Writeln (‘ Сумма равна’, .

) ;

End.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Fylhsqre 23 февр. 2020 г., 18:27:31 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

3. Найдите ошибки в программе и запишите исправленную программу в тетрадь : Program 3 funkciy ; Var x : y : integer Writeln (‘введите значение х’) ; Readln(х) ; Begin If x> ; 0 then y : = x ; else y : = x * x ; writeln(значение функции , y) ; end.

4. Дана программа на языке Паскаль : Program a2 ; Var a, b, c, min : real ; Begin Writeln (‘введите 3 числа’) ; Readln(a, b, c) ; min : = a ; if b.

Sashakolesnsk2 20 дек. 2020 г., 18:01:57 | 10 - 11 классы

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3?

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3.

5 ; writeln (a) ; end.

Если вам необходимо получить ответ на вопрос Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.