Помогите пожалуйста?

Информатика | 5 - 9 классы

Помогите пожалуйста!

3. Найдите ошибки в программе и запишите исправленную программу в тетрадь : Program 3 funkciy ; Var x : y : integer Writeln (‘введите значение х’) ; Readln(х) ; Begin If x> ; 0 then y : = x ; else y : = x * x ; writeln(значение функции , y) ; end.

4. Дана программа на языке Паскаль : Program a2 ; Var a, b, c, min : real ; Begin Writeln (‘введите 3 числа’) ; Readln(a, b, c) ; min : = a ; if b.

Ответить на вопрос
Ответы (1)
Катенька11111 23 февр. 2020 г., 18:27:36

В задаче №3 вижу только одну ошибку.

Имя программы не может начинаться с цифры.

Задача №4 представлена частично, поэтому определить наличие ошибок здесь проблематично.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Bagira17 2 мая 2020 г., 03:43:31 | 5 - 9 классы

Помогите плиииз))) Надо написать блок - схему на эту программу?

Помогите плиииз))) Надо написать блок - схему на эту программу.

Program a2 ; var a, b, c, min : real ; begin Writeln (‘Введите три числа’) ; readln (а, b, с) ; min : = а ; If b< ; min then min : = b ; if c< ; min then min : = c ; writeln (‘min = ' , min) ; end.

Toluanchick2014 29 мар. 2020 г., 07:56:03 | 10 - 11 классы

Набрать в программе Pascal программу исправив ошибки : PROGRAM 123 ; USES CRT ; VAR A, S : INTEDGER ; BEGIN WRITELN ( 'ВВЕДИТЕ ДВА ЧИСЛА ') ; READ(Q, W) ; F : = Q / W ; WRITELN ( 'РЕЗУЛЬТАТ ' , F) ; R?

Набрать в программе Pascal программу исправив ошибки : PROGRAM 123 ; USES CRT ; VAR A, S : INTEDGER ; BEGIN WRITELN ( 'ВВЕДИТЕ ДВА ЧИСЛА ') ; READ(Q, W) ; F : = Q / W ; WRITELN ( 'РЕЗУЛЬТАТ ' , F) ; READLN ; END.

Roman0877 22 апр. 2020 г., 02:55:11 | 5 - 9 классы

Program naim4 ;var a, b, c, d, min : real ; begin ;writeln('введите 4 числа') ;readln ;min : = a ;if b < ; min then min : = b ;if c < ; min then min : = c ;if d < ; min then min : = d ;writeln('?

Program naim4 ;

var a, b, c, d, min : real ; begin ;

writeln('введите 4 числа') ;

readln ;

min : = a ;

if b < ; min then min : = b ;

if c < ; min then min : = c ;

if d < ; min then min : = d ;

writeln('минимальное ', min) ;

readln ;

end.

Нужно найти минимальное число из 4 данных.

Что не так?

14013 10 мая 2020 г., 01:22:45 | 10 - 11 классы

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе?

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе.

Написать тот вариант программы, который, по Вашему мнению, будет правильным.

Program My_Error ; Var X, Y, Сумма : Integer ; Begin WriteLn( Введите значение X) ; ReadLn(X) ; WriteLn( Введите значение Y) ; ReadLn(Y) ; Сумма = X + Y ; WriteLn(Сумма) End.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Sashakolesnsk2 20 дек. 2020 г., 18:01:57 | 10 - 11 классы

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3?

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3.

5 ; writeln (a) ; end.

12354321000 28 окт. 2020 г., 20:07:00 | 5 - 9 классы

Помогите по программированию?

Помогите по программированию.

Составьте программу по этой блок схеме.

Очень срочно.

Например : program z1 ; var x, y : real ; begin writeln('введите два числа') ; read(x) ; if x> ; 0 then y : = SQRT(x) writeln('y = ', y) ; end.

Zaika220681 25 нояб. 2020 г., 06:38:19 | 10 - 11 классы

Выдает ошибку Операция > ; не может быть применена к типам boolean и integer Program qq ; var a, b, c, max, min, med : integer ; begin writeln ('введите три числа') ; read (a, b, c) ; if c> ; b>?

Выдает ошибку Операция > ; не может быть применена к типам boolean и integer Program qq ; var a, b, c, max, min, med : integer ; begin writeln ('введите три числа') ; read (a, b, c) ; if c> ; b> ; a then begin max : = c ; med : = b ; min : = a ; End ; if b> ; a> ; c then begin max : = b ; med : = a ; min : = c ; End ; if a> ; c> ; b then begin max : = a ; med : = c ; min : = b ; End ; writeln ('наибольшее число', max) ; writeln ('среднее число', med) ; writeln ('наименьшее число', min) ; End.

Вы находитесь на странице вопроса Помогите пожалуйста? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.