Помогите понять программу (Pascal) P?

Информатика | 5 - 9 классы

Помогите понять программу (Pascal) P.

S. Это решение задачи (добавил во вложения) program qq ;

var i, k, m, g : integer ;

begin

writeln('Введите количество цифр в последовательности (Не больше 100)') ;

repeat

readln(i) ;

until i< ; 101 ;

writeln('Вводите числа (не превышающие 300)') ;

for k : = 1 to i do begin

repeat

readln(m) ;

until m< ; 301 ;

if (m mod 3 = 0) then g : = g + m ;

end ;

writeln(g) ;

end.

Ответить на вопрос
Ответы (1)
OLKA191281 18 апр. 2020 г., 04:04:42

Var a, s : integer ;

begin

s : = 0

repeat(a) ;

writeln a< ; > ; 0 do

begin

if(a> ; s) and (a mod 3 = 0) then ;

s : = s + a ;

repeat(a) ;

end ;

writeln(s) ;

end.

Может быть так?

125ww 7 мая 2020 г., 17:44:48 | 5 - 9 классы

Паскаль, помогите?

Паскаль, помогите.

Сделать так, чтобы программа повторилась несколько раз

program z ;

var x, a, k : integer ;

begin

x : = random(100) + 1 ;

repeat

writeln('Введите число от 1 до 100') ;

readln(a) ;

k : = k + 1 ;

if a> ; x then write ('> ; ') ;

if a< ; x then write ('< ; ') ;

until a = x ;

writeln('Вы угадали с ' , k, ' - й попытки') ;

end.

Alena12345678901 2 мар. 2020 г., 20:50:19 | 5 - 9 классы

Ключевые слова программирования Паскаль , что они обозначают : and, end, nil, set, array, file, not, then, begin , for, of, to, case, wrile, downto , recond, with , function , or , type , const , goto?

Ключевые слова программирования Паскаль , что они обозначают : and, end, nil, set, array, file, not, then, begin , for, of, to, case, wrile, downto , recond, with , function , or , type , const , goto, packed, until, div, if, procedure, var , do , in, program , else, mod, repeat!

Помогите очень нужно!

Дулетол3 31 окт. 2020 г., 09:13:31 | 5 - 9 классы

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; w?

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; writeln(s) end.

Temnikt2998 26 июн. 2020 г., 06:21:35 | 5 - 9 классы

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе?

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе.

Вот запись, исправьте пожалуйста : program chisla ; var a, b, k : integer ; begin k : = 0 ; writeln('Введите число') ; readln(a) ; repeat if(a mod 2 = 0)and(a mod 4 = 0)then k : = k + 1 until a = 0 ; writeln('Количество чисел = ', k) end.

Matuchenko86 1 апр. 2020 г., 13:06:51 | 10 - 11 классы

Помогите, пожалуйста с номером 40?

Помогите, пожалуйста с номером 40.

Нужно написать программу в Pascal, используя цикл repeat until.

Первая часть есть : program a1 ; var y, i, a, x : integer ; begin writeln ('введите значение x') ; readln (x) ; y : = 0 ; i : = x ; a : = cos (x) ; repeat y : = y + a.

Sonyatoropchina 24 мар. 2020 г., 12:41:52 | 10 - 11 классы

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ]?

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ].

Вот программа : program yyy ; function prost(var x : integer) : boolean ; var k, i : integer ; t : boolean ; begin t : = true ; k : = 0 ; for i : = 1 to x do begin if x mod i = 0 then k : = k + 1 ; end ; if k = 2 then t : = true else t : = false ; prost : = t end ; var n, m, i : integer ; begin writeln('1') ; readln(n) ; writeln('2') ; readln(m) ; for i : = n to m - 1 do begin if prost(i) and prost(i + 2) then writeln(i , (i + 2)) ; end ; end.

Эллина55555 5 нояб. 2020 г., 15:51:12 | 10 - 11 классы

Помогите, пожалуйста объяснить как работает программа, очень срочно, пожалуйста)))program Zinaida ;const N = 5 ;var i, k : integer ; inString : String ; isize, count : integer ;Beginrepeatwrite('Strin?

Помогите, пожалуйста объяснить как работает программа, очень срочно, пожалуйста)))

program Zinaida ;

const N = 5 ;

var i, k : integer ; inString : String ; isize, count : integer ;

Begin

repeat

write('String : ') ;

readln(inString) ; k : = length(instring) ;

if instring[k] = '.

' then dec(k) ;

for i : = 1 to k do begin if instring[i]< ; > ; ' ' then inc(isize) ; if (instring[i] = ' ') or (i = k) then begin

if isize = 5

then inc(count) ;

isize : = 0 ;

end ;

write('Количество слов из пяти букв', count) ;

End.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Darkangelofl 22 авг. 2020 г., 15:28:59 | 10 - 11 классы

Помогите найти ошибку (паскаль) program u1 ; var max1, max2, k : longint ; begin readln (k) ; max1 : = k ; max2 : = k ; repeat readln (k) ; if k> ; max1 then begin max2 : = max1 ; max1 : = k ; until?

Помогите найти ошибку (паскаль) program u1 ; var max1, max2, k : longint ; begin readln (k) ; max1 : = k ; max2 : = k ; repeat readln (k) ; if k> ; max1 then begin max2 : = max1 ; max1 : = k ; until k< ; > ; 0 ; writeln (max2) ; end ; end.

Выводит ошибку в 12 строчке "встречено until, а ожидалось ; ".

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Вы открыли страницу вопроса Помогите понять программу (Pascal) P?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.