Программисту поставили задачу написать программу, которая по введённому натуральному числу n должна выводить через пробел все нечётные числа из диапазона от 1 до n?

Информатика | 5 - 9 классы

Программисту поставили задачу написать программу, которая по введённому натуральному числу n должна выводить через пробел все нечётные числа из диапазона от 1 до n.

Программист торопился и написал следующую программу : program error ; var n, i : integer ; begin ; write('9') ; readln(n) ; for i : = 1 to 9 do if (i mod 2 = 0) then write(i) ; writeln end.

С помощью откладки найдите и исправьте допущенные ошибки.

Ответить на вопрос
Ответы (1)
Alex200611 26 мая 2020 г., 00:11:31

Program error ;

var

n, i : integer ;

begin ;

write('Введите натуральное число n = ') ;

readln(n) ;

for i : = 1 to n do

if (i mod 2 = 1) then write(i, ' ') ;

writeln

end.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Dim0nGreshNIK 12 февр. 2020 г., 18:24:08 | 10 - 11 классы

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное?

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное.

Была написана следующая программа : var a, b : integer ; begin readln(a, b) ; a : = a mod 2 ; if a > ; 0 then b : = b mod 2 ; if b > ; 0 then writeln ('четных чисел нет') else writeln ('четное число есть') ; end.

Известно, что программа написана с ошибками.

Последовательно выполните три задания : укажите, как, по вашему мнению, нужно доработать программу (не используя слож - ные условия), чтобы не было случаев ее неправильной работы ;

Алеся111111112 18 дек. 2020 г., 19:24:47 | 10 - 11 классы

Требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10 ^ 9, и выводится сумма цифр этого числа?

Требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10 ^ 9, и выводится сумма цифр этого числа.

Программист торопился и написал программу неправильно : var N : longint ; sum, d : integer ; begin readln(n) ; sum : = 0 ; while N > ; 0 do begin d : = N mod 10 ; N : = N div 10 ; sum : = sum + 1 ; end ; writeln(sum) ; end.

Последовательно выполните следующее.

1. Напишите, что выведет эта программа при вводе числа 256.

2. Приведите пример такого трехзначного числа, при вводе которого программа выдаёт правильный результат.

3. Найдите все ошибки в этой программе ( их может быть одна или несколько).

Temnikt2998 26 июн. 2020 г., 06:21:35 | 5 - 9 классы

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе?

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе.

Вот запись, исправьте пожалуйста : program chisla ; var a, b, k : integer ; begin k : = 0 ; writeln('Введите число') ; readln(a) ; repeat if(a mod 2 = 0)and(a mod 4 = 0)then k : = k + 1 until a = 0 ; writeln('Количество чисел = ', k) end.

Lyaschenko 29 мар. 2020 г., 06:07:37 | 5 - 9 классы

Какая задача решается по следующей программе?

Какая задача решается по следующей программе?

Program Test var A, B, C : integer ; begin readln ( A, B) ; C : (A + B) * (B - A) writeln(C) end.

Задача связана с программой паскаль.

Msltv14 28 февр. 2020 г., 15:40:01 | 5 - 9 классы

Програмисту поставили задачу написать программу которая по введённому натуральному числу n должна выводить через пробел все нечетные числа из диапазона от 1 до n?

Програмисту поставили задачу написать программу которая по введённому натуральному числу n должна выводить через пробел все нечетные числа из диапазона от 1 до n.

14013 10 мая 2020 г., 01:22:45 | 10 - 11 классы

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе?

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе.

Написать тот вариант программы, который, по Вашему мнению, будет правильным.

Program My_Error ; Var X, Y, Сумма : Integer ; Begin WriteLn( Введите значение X) ; ReadLn(X) ; WriteLn( Введите значение Y) ; ReadLn(Y) ; Сумма = X + Y ; WriteLn(Сумма) End.

Sonyatoropchina 24 мар. 2020 г., 12:41:52 | 10 - 11 классы

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ]?

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ].

Вот программа : program yyy ; function prost(var x : integer) : boolean ; var k, i : integer ; t : boolean ; begin t : = true ; k : = 0 ; for i : = 1 to x do begin if x mod i = 0 then k : = k + 1 ; end ; if k = 2 then t : = true else t : = false ; prost : = t end ; var n, m, i : integer ; begin writeln('1') ; readln(n) ; writeln('2') ; readln(m) ; for i : = n to m - 1 do begin if prost(i) and prost(i + 2) then writeln(i , (i + 2)) ; end ; end.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Sashakolesnsk2 20 дек. 2020 г., 18:01:57 | 10 - 11 классы

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3?

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3.

5 ; writeln (a) ; end.

Вы зашли на страницу вопроса Программисту поставили задачу написать программу, которая по введённому натуральному числу n должна выводить через пробел все нечётные числа из диапазона от 1 до n?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.