Составить программу для решения задачи : 1)Даны действительные, положительные числа x, y, z?

Информатика | 10 - 11 классы

Составить программу для решения задачи : 1)Даны действительные, положительные числа x, y, z.

Выяснить, существует ли треугольник с длинами сторон x, y, z.

Если треугольник, то является ли он равносторонним?

2)Дан одномерный массив.

Найти количество смен знака между соседними элементами массива.

Программа - Паскаль.

Ответить на вопрос
Ответы (1)
IIMarIonII 8 мая 2020 г., 15:53:39

Var x, y, z : real ;

begin

readln(x, y, z) ;

if (x< ; y + z) and (y< ; x + z) and (z< ; x + y) then begin

if (x = y) and (y = z) then writeln('Ravnostoronnii') else writeln('Ne ravnostoronnii') ;

end else writeln('Ne vozmojno sostavit') ;

end.

Var a : array[1.

10]of integer ;

i, sum : integer ;

begin

for i : = 1 to 10 do readln(a[i]) ;

for i : = 1 to 9 do begin

if (a[i]> ; 0) and (a[i + 1]< ; 0) then sum : = sum + 1 ;

if (a[i]< ; 0) and (a[i + 1]> ; 0) then sum : = sum + 1 ;

end ;

writeln(sum) ;

end.

Жайнуля 22 февр. 2020 г., 08:47:05 | 5 - 9 классы

Найти сторону равностороннего треугольника по его площади в программе паскаль?

Найти сторону равностороннего треугольника по его площади в программе паскаль.

Bodirock 12 февр. 2020 г., 12:44:26 | 5 - 9 классы

Даны действительные положительные числа a, b, c, которые являются длинами сторон треугольника?

Даны действительные положительные числа a, b, c, которые являются длинами сторон треугольника.

Напишите программу позволяющую найти радиус вписанной и описанной окружности.

Диана200356 19 янв. 2020 г., 19:36:48 | 5 - 9 классы

Одномерные массивы?

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов.

Найти сумму элементов массива, кратных данному числу К.

(паскаль).

Missisanat 14 дек. 2020 г., 22:04:05 | 10 - 11 классы

Помогите пж?

Помогите пж.

Составить линейную программу для решения задачи.

Дана сторона равностороннего треугольника.

Найти высоту этого треугольника.

Парkур 14 нояб. 2020 г., 15:28:10 | 5 - 9 классы

Паскаль напишите пожалуйста программу Срочно, прошу?

Паскаль напишите пожалуйста программу Срочно, прошу!

Даны действительные положительные числа a, b, c, которые задают длины сторон треугольника и угол между ними.

Напишите программу, позволяющую найти длину третьей стороны и два остальных угла.

Onishenkoveroni 27 сент. 2020 г., 14:41:57 | 5 - 9 классы

Даны положительных числа a, b, c?

Даны положительных числа a, b, c.

Проверить могут ли они быть длинами сторон треугольника, если да, то вычесли его площадь.

(составить программу для паскаля).

Matveypomoz 20 мар. 2020 г., 15:38:56 | 10 - 11 классы

Помогите оставить программу в Паскале : Дан одномерный массив заменить все чётные элементы массива нулём?

Помогите оставить программу в Паскале : Дан одномерный массив заменить все чётные элементы массива нулём.

Fair5 14 апр. 2020 г., 22:31:32 | 1 - 4 классы

Написать программу которая определяет количество положительных элементов одномерного массива?

Написать программу которая определяет количество положительных элементов одномерного массива.

Kuganova30 1 мар. 2020 г., 11:19:21 | 10 - 11 классы

Даны три натуральных числа?

Даны три натуральных числа.

Напишите программу, определяющую, существует ли треугольник с такими длинами сторон.

Если такой треугольник существует, то определите его тип ( равносторонний, равнобедренный, разносторонний).

Serokurovavika 5 дек. 2020 г., 03:12:15 | 10 - 11 классы

Составить блок - схему и программу для решения задачи?

Составить блок - схему и программу для решения задачи.

Дан одномерный массив С, состоящий из 11 целых чисел, принадлежащих отрезку [0 ; 25].

Элементы массива вывести в строчку через пробел.

Найти количество нечетных элементов массива.

Вы перешли к вопросу Составить программу для решения задачи : 1)Даны действительные, положительные числа x, y, z?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.