Написать функцию которая считает количество цифр натурального числа затем в массиве из 10 натуральных чисел найти число с наибольшим количеством цифр?

Информатика | 5 - 9 классы

Написать функцию которая считает количество цифр натурального числа затем в массиве из 10 натуральных чисел найти число с наибольшим количеством цифр.

ПАСКАЛЬ.

ПОМОГИТЕ ПОЖАЛУЙСТА!

Ответить на вопрос
Ответы (1)
Anyta305 3 дек. 2020 г., 09:02:10

/ / PascalABC.

NET 3.

1, сборка 1172 от 19.

02. 2016

function KolCifr(n : integer) : = n.

ToString.

Length ;

begin var a : = ReadArrInteger(' - > ; ', 10) ; var nmax : = a[0] ; var kmax : = KolCifr(nmax) ; for var i : = 1 to 9 do begin var k : = Kolcifr(a[i]) ; if k> ; kmax then begin nmax : = a[i] ; kmax : = k end end ; Writeln('Число с макс.

Длиной : ', nmax)

end.

Тестовое решение : - > ; 23532 195234523 423324312 6323 8523732 343235623 342 534544324 974535 253235

Число с макс.

Длиной : 195234523.

Julik0899 8 февр. 2020 г., 22:36:18 | 5 - 9 классы

Как найти первые две цифры натурального числа в паскале?

Как найти первые две цифры натурального числа в паскале?

Jimova 20 июл. 2020 г., 08:21:01 | 5 - 9 классы

Определить количество натуральных трехзначных чисел сумма цифр которых равна заданному числу N?

Определить количество натуральных трехзначных чисел сумма цифр которых равна заданному числу N.

Chinianin 30 окт. 2020 г., 16:19:10 | 5 - 9 классы

Определить количество натуральных трехзначных чисел сумма цифр которых равна заданному числу N?

Определить количество натуральных трехзначных чисел сумма цифр которых равна заданному числу N.

Antonkhvorov 20 июн. 2020 г., 12:56:51 | 10 - 11 классы

1) дано натуральное а?

1) дано натуральное а.

Верно ли, что данное число состоит из 3 цифр?

2) дано натуральное число.

Верно ли, что в данном числе четыре цифры?

3) Даны два натуральных числа.

Определить в каком числе первая цифра больше.

4) Дано натуральное n.

Найти количество 6, входящих в данное число.

Нужно решить в программе паскаль.

Если поможет, то мы учим цикл в паскале, div, mod.

Viktoriuakr 27 июл. 2020 г., 23:03:20 | 10 - 11 классы

Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше?

Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше.

Нахождение количество цифр числа оформить в виде функции

Решение на паскале, написать программу.

Доббик 4 окт. 2020 г., 05:44:07 | 10 - 11 классы

ПАСКАЛЬ, ИНФОРМАТИКА?

ПАСКАЛЬ, ИНФОРМАТИКА.

П о м о г и т е Дано натуральное число.

Найти количество нечетных цифр в нем.

Надежжжжжж 13 дек. 2020 г., 19:28:04 | 5 - 9 классы

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа (для программы Паскаль)?

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа (для программы Паскаль).

Harper2307 3 мая 2020 г., 15:21:01 | 5 - 9 классы

Напишите программу которая считает количество четных цифр введенного числа в паскале?

Напишите программу которая считает количество четных цифр введенного числа в паскале.

Kenzzo 24 нояб. 2020 г., 17:16:23 | 5 - 9 классы

Написать программу которая считает количество цифр в числе и их сумму?

Написать программу которая считает количество цифр в числе и их сумму.

Паскаль.

Число вводится с клавиатуры.

ТошаКотов 4 нояб. 2020 г., 06:42:34 | 1 - 4 классы

Вводится натуральное число n требуется найти сумму четных цифр числа 2) найти количество цифр 2 в числе 3) найти максимальную нечетную цифру в числе ПАСКАЛЬ СРОЧНО?

Вводится натуральное число n требуется найти сумму четных цифр числа 2) найти количество цифр 2 в числе 3) найти максимальную нечетную цифру в числе ПАСКАЛЬ СРОЧНО!

На странице вопроса Написать функцию которая считает количество цифр натурального числа затем в массиве из 10 натуральных чисел найти число с наибольшим количеством цифр? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.