Помогите, пожалуйста?

Информатика | 5 - 9 классы

Помогите, пожалуйста!

Паскаль

дано четырехзначное число, заменить нулем максимальную цифру.

Ответить на вопрос
Ответы (1)
Etvamalaya 14 окт. 2020 г., 20:22:50

Uses crt ;

var a : integer ;

b : array[1.

4] of integer ;

max, i, k, t : integer ;

begin

readln(a) ;

k : = 1 ;

repeat

for i : = k to k do

b[i] : = a mod 10 ;

a : = a div 10 ;

inc(k) ;

until a = 0 ;

max : = 0 ;

for i : = 1 to 4 do

if b[i]> ; max then begin max : = b[i] ; t : = i ; end ;

b[t] : = 0 ;

for i : = 4 downto 1 do

write(b[i]) ;

end.

Vedma12 13 февр. 2020 г., 05:20:31 | 5 - 9 классы

Помогите, пожалуйста, составить программу в паскале?

Помогите, пожалуйста, составить программу в паскале!

Дано четырехзначное число заменить в нем наибольшую цифру нулем.

Lapteva240677 21 дек. 2020 г., 02:11:37 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Найти максимальную цифру.

В паскале.

Через while.

Irakorshunova 3 окт. 2020 г., 14:22:46 | 5 - 9 классы

Найти сумму цифр четырехзначного числа в паскалях?

Найти сумму цифр четырехзначного числа в паскалях.

Shuratrofimova 26 мая 2020 г., 04:46:16 | 10 - 11 классы

Задача на Паскаль, Помогите, пожалуйста дано N трехзначное число?

Задача на Паскаль, Помогите, пожалуйста дано N трехзначное число.

Заменить первую цифру на один.

Lenchik364 10 окт. 2020 г., 22:25:45 | 10 - 11 классы

В данном целом числе N, заменить нулями все четные цифры в данном числе?

В данном целом числе N, заменить нулями все четные цифры в данном числе.

Вывести полученное число.

(Паскаль).

2221111333 8 янв. 2020 г., 05:32:47 | 5 - 9 классы

Даны три числа, найти максимальное из них и заменить квадратом этого числа?

Даны три числа, найти максимальное из них и заменить квадратом этого числа.

Помогите решить плииз с помощью паскаля.

Kovanov2014 27 окт. 2020 г., 02:37:24 | 10 - 11 классы

Дано трёхзначное число?

Дано трёхзначное число.

Найти среди цифр этого числа, максимальное.

Программа в Паскале.

3838773 17 июн. 2020 г., 20:06:47 | 5 - 9 классы

ПАСКАЛЬ, ЗАДАЧИ НА МАССИВЫ?

ПАСКАЛЬ, ЗАДАЧИ НА МАССИВЫ.

ДАНА ПОСЛЕДОВАТЕЛЬНОСТЬ, В КОТОРОЙ ВСТРЕЧАЕТСЯ НУЛЬ.

ЗАМЕНИТЬ НУЛЬ ЦИФРОЙ 8.

Настя17092001 6 апр. 2020 г., 02:58:44 | 5 - 9 классы

СРОЧНОООО?

СРОЧНОООО!

ПОМОГИТЕ ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ НА ПАСКАЛЕ!

Дано четырехзначное число.

Определить кратно ли четырем произведение его цифр.

Lerchik1204 3 нояб. 2020 г., 02:25:45 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Найти максимальную цифру.

В паскале.

Через процедуры.

Перед вами страница с вопросом Помогите, пожалуйста?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.