Помогите пожалуйста, завтра экзамен?

Информатика | 10 - 11 классы

Помогите пожалуйста, завтра экзамен!

С клавиатуры вводятся вещественные числа.

Признак конца ввода - 0.

Определить, является ли вводимая последовательность упорядоченной по невозрастанию или по неубыванию (PascalABC).

Ответить на вопрос
Ответы (1)
Sergey1997515 30 сент. 2020 г., 22:20:50

Var a, c : boolean ; b, b1 : integer ;

begin readln(b) ; readln(b1) ; if (b > ; b1) then a : = true else if (b1 > ; b) then a : = false ; while (true) do begin readln(b1) ; if (0 in [b, b1]) then break ; if a then begin if (b < ; b1) then c : = true ; end else if (b > ; b1) then c : = true ; b : = b1 ; end ; if c then writeln('Случайная') else if (a) then writeln('Невозрастающая') else writeln('Неубывающая') ;

end.

Само собой, должно быть минимум 2 числа в последовательности : ).

Пупера 4 апр. 2020 г., 01:59:24 | 5 - 9 классы

Написать программ у, в которой циклически осуществляется ввод целых чисел с клавиатуры, признаком прекращения ввода является число 0?

Написать программ у, в которой циклически осуществляется ввод целых чисел с клавиатуры, признаком прекращения ввода является число 0.

Yulyamamaeva 11 янв. 2020 г., 16:30:54 | 5 - 9 классы

Составить программу для последовательного произведения вводимых с клавиатур целых чисел?

Составить программу для последовательного произведения вводимых с клавиатур целых чисел.

Предусмотреть выход из произведения при вводе нуля.

Евангелина25 4 февр. 2020 г., 12:09:36 | 10 - 11 классы

25 баллов?

25 баллов.

Вводится последовательность вещественных чисел.

Признак конца ввода – 0.

Определить является ли последовательность упорядоченной по убыванию.

Паскаль.

Иииааа 9 янв. 2020 г., 18:20:47 | 10 - 11 классы

Помогите, пожалуйста, с задачей по программированию?

Помогите, пожалуйста, с задачей по программированию.

С клавиатуры вводится неограниченная последовательность чисел.

Ввод последовательности заканчивается 0.

Найти максимальное и минимальное число этой последовательности.

Витанка 8 окт. 2020 г., 13:52:58 | 10 - 11 классы

С клавиатуры вводятся целые числа?

С клавиатуры вводятся целые числа.

Признаком конца ввода чисел является 0.

Изменить знак отрицательных чисел на положительный.

Результаты вывести на экран.

Erfun 15 февр. 2020 г., 08:05:04 | 10 - 11 классы

С клавиатуры вводятся два вещественных числа?

С клавиатуры вводятся два вещественных числа.

Выведите через запятую в одной строке сначала меньшее из них, а потом большее.

Dashulkashugur1 3 июл. 2020 г., 17:10:16 | 10 - 11 классы

Написать программу на Паскале : "найти номер первого максимального элемента во вводимой с клавиатуры последовательности чисел?

Написать программу на Паскале : "найти номер первого максимального элемента во вводимой с клавиатуры последовательности чисел.

Условие окончания ввода – ввод числа 0.

".

Physicsgenius11 20 сент. 2020 г., 19:48:22 | 10 - 11 классы

С клавиатуры вводится 2 вещественных числа?

С клавиатуры вводится 2 вещественных числа.

Найдите целую часть от произведения 2х вещественных чисел.

(Через паскаль).

Olgaiviva 30 апр. 2020 г., 21:34:25 | 10 - 11 классы

Составить программу вычисления суммы цифр 5 - значного числа вводимого с клавиатуры где N вводиться с клавиатуры?

Составить программу вычисления суммы цифр 5 - значного числа вводимого с клавиатуры где N вводиться с клавиатуры.

Alina0606 22 дек. 2020 г., 02:52:07 | 10 - 11 классы

С клавиатуры вводится некоторое количество положительных чисел, результатом конца ввода является любое отрицательное число?

С клавиатуры вводится некоторое количество положительных чисел, результатом конца ввода является любое отрицательное число.

Найти и вывести на экране все числа кратные 3.

Вы открыли страницу вопроса Помогите пожалуйста, завтра экзамен?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.