Надо составить программу в паскале, в которой надо найти процент от заданного числа?

Информатика | 10 - 11 классы

Надо составить программу в паскале, в которой надо найти процент от заданного числа.

Ответить на вопрос
Ответы (1)
777MAG777 18 мар. 2020 г., 14:38:32

Var

q : Single ; / / Результат.

Если число будет больше, то указатьDouble

i : Single ; / / Число из которого необходимо получить результат.

Если число будет больше, то указатьDouble

p : Single ; / / Процент.

Если процент будет всегда целым числом, то указатьByte

begin

writeln('Введите число = > ; ') ;

read(i) ;

writeln('Введите процент, который хотите расcчитать из введенного числа = > ; ') ;

read(p) ;

while p < ; 0 do

begin

writeln('Процент не может быть меньше нуля, введите новое значение = > ; ') ;

read(p) ;

end ;

q : = (i / 100) * p ;

writeln('Ваш результат из числа = > ; ', i, ', ', p, '% = ', q) ;

end.

Sahs20012004 31 янв. 2020 г., 23:41:23 | 5 - 9 классы

Паскаль Составить программу для проверки, можно ли заданное натуральное число N представить в виде куба простого числа?

Паскаль Составить программу для проверки, можно ли заданное натуральное число N представить в виде куба простого числа.

Ленуська132 3 окт. 2020 г., 06:34:07 | 5 - 9 классы

Составить программу вычисляющее наибольшее из 3 заданных чисел(паскаль)?

Составить программу вычисляющее наибольшее из 3 заданных чисел(паскаль).

Azzar26 14 февр. 2020 г., 14:56:07 | 10 - 11 классы

Найдите произведение трёх чисел вводимых с клавиатуры при условии , что они больше заданного числа ( найти по программе паскаль )?

Найдите произведение трёх чисел вводимых с клавиатуры при условии , что они больше заданного числа ( найти по программе паскаль ).

Romastovpets 25 сент. 2020 г., 05:34:38 | 10 - 11 классы

Составить программу, которая считает в формуле, заданной с клавиатуры, колличество плюсов и минусов (программа в паскале)?

Составить программу, которая считает в формуле, заданной с клавиатуры, колличество плюсов и минусов (программа в паскале).

Temich1999 7 окт. 2020 г., 13:57:55 | 10 - 11 классы

Составить программу, которая считает количество букв "а" в заданном слове?

Составить программу, которая считает количество букв "а" в заданном слове.

В паскаль.

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Милена40 2 авг. 2020 г., 13:59:55 | 5 - 9 классы

Составить программу в паскале для определения является ли заданное слово палиндромом?

Составить программу в паскале для определения является ли заданное слово палиндромом.

Gusev2202200 25 мая 2020 г., 06:58:26 | 5 - 9 классы

Составить программу, которая считает количество букв "а" в заданном слове (Секретные материалы)?

Составить программу, которая считает количество букв "а" в заданном слове (Секретные материалы).

В паскаль.

Valenti98 28 дек. 2020 г., 20:05:12 | 10 - 11 классы

Составить программу вывода любого числа любое заданное число раз в одну строчку?

Составить программу вывода любого числа любое заданное число раз в одну строчку.

Язык программирования : Паскаль.

Golden6 3 окт. 2020 г., 07:48:36 | 10 - 11 классы

Составить программу которая удаляет из заданной строки заданное слово паскаль?

Составить программу которая удаляет из заданной строки заданное слово паскаль.

На этой странице находится вопрос Надо составить программу в паскале, в которой надо найти процент от заданного числа?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.