Составить программу в паскале для определения является ли заданное слово палиндромом?

Информатика | 5 - 9 классы

Составить программу в паскале для определения является ли заданное слово палиндромом.

Ответить на вопрос
Ответы (1)
Lesnichdaria20 2 авг. 2020 г., 13:59:58

Var

x : string ;

i, w : integer ;

begin

w : = 0 ;

readln(x) ;

for i : = 1 to length(x) div 2 do

if x[i]< ; > ; x[length(x) - i + 1] then

w : = w + 1 ;

if w = 0 then writeln('Палиндром') else

writeln('Не палиндром') ;

end.

Ленуська132 3 окт. 2020 г., 06:34:07 | 5 - 9 классы

Составить программу вычисляющее наибольшее из 3 заданных чисел(паскаль)?

Составить программу вычисляющее наибольшее из 3 заданных чисел(паскаль).

Romastovpets 25 сент. 2020 г., 05:34:38 | 10 - 11 классы

Составить программу, которая считает в формуле, заданной с клавиатуры, колличество плюсов и минусов (программа в паскале)?

Составить программу, которая считает в формуле, заданной с клавиатуры, колличество плюсов и минусов (программа в паскале).

Aselya5 26 мар. 2020 г., 17:30:08 | 5 - 9 классы

Помогите пожалуйста решить задачу в паскале : Составить программу, проверяющую, является ли заданное натуральное число палиндромом, т?

Помогите пожалуйста решить задачу в паскале : Составить программу, проверяющую, является ли заданное натуральное число палиндромом, т.

Е. таким, которое читается одинаково слева направо и справа налево(например : 23132).

123mr 18 мар. 2020 г., 14:38:29 | 10 - 11 классы

Надо составить программу в паскале, в которой надо найти процент от заданного числа?

Надо составить программу в паскале, в которой надо найти процент от заданного числа.

Temich1999 7 окт. 2020 г., 13:57:55 | 10 - 11 классы

Составить программу, которая считает количество букв "а" в заданном слове?

Составить программу, которая считает количество букв "а" в заданном слове.

В паскаль.

281177 20 нояб. 2020 г., 21:50:28 | 5 - 9 классы

Написать программу для проверки того, является ли введеное пользователем четырехзначное число палиндромом?

Написать программу для проверки того, является ли введеное пользователем четырехзначное число палиндромом.

Gusev2202200 25 мая 2020 г., 06:58:26 | 5 - 9 классы

Составить программу, которая считает количество букв "а" в заданном слове (Секретные материалы)?

Составить программу, которая считает количество букв "а" в заданном слове (Секретные материалы).

В паскаль.

SystemBin 3 нояб. 2020 г., 14:30:12 | 10 - 11 классы

Программу надо составить в паскале : Составить программу определения вида треугольника по двум углам (прямоугольный, остроугольный, тупоугольный)?

Программу надо составить в паскале : Составить программу определения вида треугольника по двум углам (прямоугольный, остроугольный, тупоугольный).

Ирина783 6 дек. 2020 г., 00:03:13 | 5 - 9 классы

Паскаль?

Паскаль.

Составить программу для определения суммы чисел от 1 до N.

Golden6 3 окт. 2020 г., 07:48:36 | 10 - 11 классы

Составить программу которая удаляет из заданной строки заданное слово паскаль?

Составить программу которая удаляет из заданной строки заданное слово паскаль.

На этой странице находится ответ на вопрос Составить программу в паскале для определения является ли заданное слово палиндромом?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.