Дано четырёхзначное число, определить : 1?

Информатика | 10 - 11 классы

Дано четырёхзначное число, определить : 1.

Входит ли в него цифра 4.

Ответить на вопрос
Ответы (1)
Kcobain 11 июл. 2020 г., 19:21:49

Pascal :

var n : integer ; f : boolean ;

begin f : = false ; repeat write ('N = ') ; readln (n) ; until (n> ; = 1000) and (n< ; = 9999) ; while (not f) and (n< ; > ; 0) do begin if n mod 10 = 4 then f : = true ; n : = n div 10 ; end ; if f then writeln ('YES') else writeln ('NO') ;

end.

C + + :

#include < ; iostream> ;

using namespace std ;

int main()

{ int n ; bool f = false ; while (n< ; 1000 || n> ; 9999) { cout < ; < ; "N = " ; cin > ; > ; n ; } while (!

F & ; & ; n!

= 0) { if (n%10 = = 4) f = true ; } if (f) cout < ; < ; "YES" < ; < ; endl ; else cout < ; < ; "NO" < ; < ; endl ; return 0 ;

}.

Tu02 19 мая 2020 г., 09:46:33 | 5 - 9 классы

Ввести с клавиатуры двузначное число и цифру?

Ввести с клавиатуры двузначное число и цифру.

Определить, есть ли данная цифра в этом числе.

Li15 19 сент. 2020 г., 23:20:09 | 5 - 9 классы

1) дано четырёхзначное число?

1) дано четырёхзначное число.

Вывести максимальную и минимальную цифру.

Pascal abc

2) дано четырёхзначное число.

Что больше : произведение цифр числа или их утроенная сумма.

Pascal ABC.

Nikitadanilov3 12 окт. 2020 г., 16:45:38 | 5 - 9 классы

Дано двухзначное(трехзначное)число?

Дано двухзначное(трехзначное)число.

Напишите программу определения - входит ли в него цифра 5 - входят ли в него цифры 4 и 7.

Crashboarding 4 мая 2020 г., 03:45:31 | 1 - 4 классы

Дано трехзначное число?

Дано трехзначное число.

Определить, входит ли в него цифра 6 и если входит, то сколько этих цифр.

Minashkinazhene 18 июн. 2020 г., 15:49:02 | 5 - 9 классы

"Найти сумму цифр четырёхзначного числа" задача pascal?

"Найти сумму цифр четырёхзначного числа" задача pascal.

Alinanna 2 июн. 2020 г., 07:20:10 | 5 - 9 классы

4 «Условный оператор» Написать программу : Дано четырехзначное число?

4 «Условный оператор» Написать программу : Дано четырехзначное число.

Определить, входит ли в него цифра 6.

Djozov2 21 авг. 2020 г., 14:00:56 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Определите входит ли в него цифра b.

Maximka20131998 14 янв. 2020 г., 23:43:33 | 5 - 9 классы

Дано четырёхзначное число n?

Дано четырёхзначное число n.

Проверить, будет ли сумма его цифр чётным числом.

Яна509 23 окт. 2020 г., 14:42:39 | 1 - 4 классы

Дано четырёхзначное число определить является ли нечётным произведение его цифр?

Дано четырёхзначное число определить является ли нечётным произведение его цифр.

Mashakubanova 3 июл. 2020 г., 23:45:07 | 5 - 9 классы

Найти "Сумму цифр четырёхзначного числа" В PaskalABC?

Найти "Сумму цифр четырёхзначного числа" В PaskalABC.

На этой странице находится ответ на вопрос Дано четырёхзначное число, определить : 1?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.