1) дано четырёхзначное число?

Информатика | 5 - 9 классы

1) дано четырёхзначное число.

Вывести максимальную и минимальную цифру.

Pascal abc

2) дано четырёхзначное число.

Что больше : произведение цифр числа или их утроенная сумма.

Pascal ABC.

Ответить на вопрос
Ответы (1)
Step09080 19 сент. 2020 г., 23:20:16

Program task1 ;

var number, max, min, ost, digit : integer ;

begin readln(number) ; max : = 0 ; min : = 9 ; while number > ; 0 do begin digit : = number mod 10 ; if digit < ; min then min : = digit ; if digit > ; max then max : = digit ; number : = number div 10 ; end ; writeln('Минимальная цифра : ', min) ; writeln('Максимальная цифра : ', max) ;

end.

Program task2 ;

var number, digit, sum, p : integer ;

begin readln(number) ; sum : = 0 ; p : = 1 ; while number > ; 0 do begin digit : = number mod 10 ; sum : = sum + digit ; p : = p * digit ; number : = number div 10 ; end ; sum : = sum * 3 ; if sum > ; p then writeln('Утроенная сумма больше произведения') ; if p > ; sum then writeln('Произведение больше утроенного произведения') ;

end.

Winterbottom 13 июн. 2020 г., 22:55:51 | 5 - 9 классы

Дано целое число N?

Дано целое число N.

Составить программу нахождения количества цифр числа (Pascal ABC).

SofArkadiu 12 нояб. 2020 г., 19:12:02 | 5 - 9 классы

PASCAL ABC, программа?

PASCAL ABC, программа!

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

Minashkinazhene 18 июн. 2020 г., 15:49:02 | 5 - 9 классы

"Найти сумму цифр четырёхзначного числа" задача pascal?

"Найти сумму цифр четырёхзначного числа" задача pascal.

Умник2002 3 авг. 2020 г., 04:33:03 | 5 - 9 классы

Дано трехзначное и четырехзначное число?

Дано трехзначное и четырехзначное число.

В каком числе сумма цифр больше?

Напишите, пожалуйста, программу для Pascal.

ABC.

Ivanushun12345 2 июл. 2020 г., 12:04:02 | 5 - 9 классы

Pascal ABC?

Pascal ABC.

Дано натуральное число "n".

Составьте программу которая выводит максимальную цифру этого числа.

Fatik41 21 мар. 2020 г., 13:20:24 | 10 - 11 классы

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу?

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу.

(pascal).

Maximka20131998 14 янв. 2020 г., 23:43:33 | 5 - 9 классы

Дано четырёхзначное число n?

Дано четырёхзначное число n.

Проверить, будет ли сумма его цифр чётным числом.

Яна509 23 окт. 2020 г., 14:42:39 | 1 - 4 классы

Дано четырёхзначное число определить является ли нечётным произведение его цифр?

Дано четырёхзначное число определить является ли нечётным произведение его цифр.

Timi 25 мар. 2020 г., 02:44:19 | 10 - 11 классы

Дано натуральное число N ?

Дано натуральное число N .

Определить наименьшую и наибольшую цифры данного числа (Pascal ABC).

Алиночка2500 19 дек. 2020 г., 04:51:59 | 5 - 9 классы

Pascal abcдано целое число ?

Pascal abc

дано целое число .

Верно ли, что в числе нет 5?

На этой странице сайта, в категории Информатика размещен ответ на вопрос 1) дано четырёхзначное число?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.