Дано четырёхзначное число n?

Информатика | 5 - 9 классы

Дано четырёхзначное число n.

Проверить, будет ли сумма его цифр чётным числом.

Ответить на вопрос
Ответы (1)
Vorobev23ra 14 янв. 2020 г., 23:43:34

Var

n : integer ;

Begin

Write('Введите четырёхзначное число ') ;

Readln(n) ;

if ((n> ; 999) and (n< ; 10000)) or ((n> ; - 10000) and (n< ; - 999)) then Begin

Write('Сумма цифр числа ', n) ;

if ((n div 1000 + n div 100 mod 10 + n div 10 mod 10 + n mod 10) mod 2) = 0 then Write(' чётна') else Write(' не чётна') ;

End

else write('Число ', n, ' не четырёхзначное.

Перезапустите программу') ;

End.

Ксеня19 17 янв. 2020 г., 21:12:49 | 5 - 9 классы

Дано 3 - х значное число N?

Дано 3 - х значное число N.

Проверить, будет ли сумма его цифр чётным числом.

Li15 19 сент. 2020 г., 23:20:09 | 5 - 9 классы

1) дано четырёхзначное число?

1) дано четырёхзначное число.

Вывести максимальную и минимальную цифру.

Pascal abc

2) дано четырёхзначное число.

Что больше : произведение цифр числа или их утроенная сумма.

Pascal ABC.

Karina820202 11 июл. 2020 г., 19:21:46 | 10 - 11 классы

Дано четырёхзначное число, определить : 1?

Дано четырёхзначное число, определить : 1.

Входит ли в него цифра 4.

Tatanka212128 16 авг. 2020 г., 19:41:15 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Определить : а) является ли сумма его цифр двузначным числом ; б) больше ли числа а сумма его цифр.

Minashkinazhene 18 июн. 2020 г., 15:49:02 | 5 - 9 классы

"Найти сумму цифр четырёхзначного числа" задача pascal?

"Найти сумму цифр четырёхзначного числа" задача pascal.

Alexhenderson 9 мар. 2020 г., 04:46:11 | 5 - 9 классы

Составьте программу которая определяет являеться ли сумма цифр введённого целого трёхзначного числа чётным числом?

Составьте программу которая определяет являеться ли сумма цифр введённого целого трёхзначного числа чётным числом.

Любимаямоя 10 февр. 2020 г., 09:47:00 | 10 - 11 классы

Составить программу на Паскале?

Составить программу на Паскале.

Дано двухзначное число N.

Проверить, меньше ли сумма цифр числа N заданного числа К.

Вывести об этом сообщение и значения числа N и К.

Яна509 23 окт. 2020 г., 14:42:39 | 1 - 4 классы

Дано четырёхзначное число определить является ли нечётным произведение его цифр?

Дано четырёхзначное число определить является ли нечётным произведение его цифр.

Алина12532 27 авг. 2020 г., 07:19:39 | 5 - 9 классы

Составьте программу, которая определяет, является ли сумма цифр введённого целого трёхзначного числа чётным числом?

Составьте программу, которая определяет, является ли сумма цифр введённого целого трёхзначного числа чётным числом.

Mashakubanova 3 июл. 2020 г., 23:45:07 | 5 - 9 классы

Найти "Сумму цифр четырёхзначного числа" В PaskalABC?

Найти "Сумму цифр четырёхзначного числа" В PaskalABC.

Вы зашли на страницу вопроса Дано четырёхзначное число n?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.