"Найти сумму цифр четырёхзначного числа" задача pascal?

Информатика | 5 - 9 классы

"Найти сумму цифр четырёхзначного числа" задача pascal.

Ответить на вопрос
Ответы (2)
Olgavesna 18 июн. 2020 г., 15:49:05

Var a, a1, a2, a3, a4 : integer ;

begin

writeln('a = ') ; readln(a) ;

a1 : = a div 1000 ;

a2 : = a div 100 mod 10 ;

a3 : = a mod 100 div 10 ;

a4 : = a mod 10 ;

writeln('цифры : ', a1 : 2, a2 : 2, a3 : 2, a4 : 2) ;

writeln('sum = ', a1 + a2 + a3 + a4) ;

end.

Аняфедорова 18 июн. 2020 г., 15:49:12

Var a, b, c, d, i : integer ;

begin

writeln('Введите 4 Числа = ') ;

readln (a, b, c, d) ;

i : = a + b + c + d ;

writeln('Результат суммы = ', c) ;

writeln(a, ' + ', b, ' + 'c', ' + 'd = ', i) ;

end.

Stasevanne26 5 янв. 2020 г., 18:55:45 | 5 - 9 классы

Среди четырёхзначных чисел найти все числа сумма цифр, которых кратно 3 и больше 15?

Среди четырёхзначных чисел найти все числа сумма цифр, которых кратно 3 и больше 15.

Alexa36 20 мая 2020 г., 14:44:04 | 10 - 11 классы

Написать программу в Free Pascal : Дано целое число неизвестной размерности?

Написать программу в Free Pascal : Дано целое число неизвестной размерности.

Найти сумму цифр его составляющих.

Li15 19 сент. 2020 г., 23:20:09 | 5 - 9 классы

1) дано четырёхзначное число?

1) дано четырёхзначное число.

Вывести максимальную и минимальную цифру.

Pascal abc

2) дано четырёхзначное число.

Что больше : произведение цифр числа или их утроенная сумма.

Pascal ABC.

Edikpro002701 8 авг. 2020 г., 06:55:49 | 10 - 11 классы

Ввести с клавиатуры трехзначное число и корень квадратный из суммы цифр этого числаpascal?

Ввести с клавиатуры трехзначное число и корень квадратный из суммы цифр этого числа

pascal.

Eqorqeiko 11 мар. 2020 г., 07:55:46 | 10 - 11 классы

Код программы в PASCAL, СРОЧНО?

Код программы в PASCAL, СРОЧНО!

Условие : Вводятся 3 натуральных числа.

Найти сумму цифр каждого из них (создать функцию для нахождения суммы цифр произвольного натурального числа).

Fatik41 21 мар. 2020 г., 13:20:24 | 10 - 11 классы

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу?

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу.

(pascal).

Maximka20131998 14 янв. 2020 г., 23:43:33 | 5 - 9 классы

Дано четырёхзначное число n?

Дано четырёхзначное число n.

Проверить, будет ли сумма его цифр чётным числом.

Mashakubanova 3 июл. 2020 г., 23:45:07 | 5 - 9 классы

Найти "Сумму цифр четырёхзначного числа" В PaskalABC?

Найти "Сумму цифр четырёхзначного числа" В PaskalABC.

K99I 6 сент. 2020 г., 11:12:32 | 5 - 9 классы

Срочно?

Срочно!

Найти сумму двух первых цифр заданного четырёхзначного числа если оно кратно 5.

Маришко1 28 дек. 2020 г., 22:17:48 | 10 - 11 классы

Дано двузначное число?

Дано двузначное число.

Определить, кратна ли трем сумма его цифр?

( Pascal).

На этой странице находится вопрос "Найти сумму цифр четырёхзначного числа" задача pascal?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.