Вставить число, введённое с клавиатуры после первого отрицательного элемента массива?

Информатика | 5 - 9 классы

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива.

Если отрицательный элемент отсутствует, то вставить число в конец массива.

Ответить на вопрос
Ответы (1)
Pi1998 17 мая 2020 г., 10:50:57

Vara, b, c, i : longint ;

m : array[1.

1000] of longint ;

Begin

c : = 0 ;

readln(a) ;

readln(b) ;

for i : = 1 to b do

begin

read(m[i + c]) ;

if (m[i + c]< ; 0) and (c = 0) then

begin

m[i + 1] : = a ;

c : = 1 ;

end ;

end ;

for i : = 1 to b + 1 do

write(m[i], ' ') ;

End.

Cmki 17 окт. 2020 г., 09:31:05 | 10 - 11 классы

Написать программу подсчёта числа отрицательных элементов массива?

Написать программу подсчёта числа отрицательных элементов массива.

Plombirka10 17 нояб. 2020 г., 18:38:13 | 10 - 11 классы

Ввести массив A(n) ?

Ввести массив A(n) .

Если в массиве не менее двух отрицательных элементов , то уменьшить отрицательные элементы массива на 2 , иначе найти номер первого минимального элемента массива.

Maksimusmineev33rus 29 апр. 2020 г., 10:26:11 | 10 - 11 классы

ПОМОГИТЕ РЕШИТЬ ЧЕРЕЗ ПОДПРОГРАММУ И БЕЗ "рандома" Дано : массивы А(8), В(11)?

ПОМОГИТЕ РЕШИТЬ ЧЕРЕЗ ПОДПРОГРАММУ И БЕЗ "рандома" Дано : массивы А(8), В(11).

Определить в каком массиве отрицательное число встречается раньше.

Номер первого отрицательного элемента в массиве находить в подпрограмме.

Дарьяна0252 29 мар. 2020 г., 03:24:37 | 10 - 11 классы

Помогите, пожалуйста необходимо написать программу в Паскале Вставить по одному элементу с заданным значением перед всеми отрицательными элементами массива?

Помогите, пожалуйста необходимо написать программу в Паскале Вставить по одному элементу с заданным значением перед всеми отрицательными элементами массива.

Девочка1997 20 мар. 2020 г., 03:22:50 | 10 - 11 классы

Заменить в массиве первый отрицательный элемент нулем?

Заменить в массиве первый отрицательный элемент нулем.

Масяня329 24 сент. 2020 г., 22:22:50 | 5 - 9 классы

ИНФОРМАТИКА, ПОМОГИТЕ?

ИНФОРМАТИКА, ПОМОГИТЕ.

ПАСКАЛЬ, МАССИВЫ.

Задать случайным образом 10 элементов массива : целые числа из интервала от - 5 до 50.

Найти : 2) произведение элементов, стоящих на чётных местах ; 3) количество отрицательных элементов.

4) Ввести с клавиатуры 12 элементов числового массива.

Все положительные увеличить на 100, все отрицательные обнулить.

Makarkolesnich 2 авг. 2020 г., 21:12:38 | 5 - 9 классы

Ребят срочно?

Ребят срочно!

Вывести на печать первый отрицательный элемент массива А(20) и его номер, пологая что в массиве есть хотябы один отрицательный элемент.

Angelina21237 28 июн. 2020 г., 11:26:28 | 5 - 9 классы

Дан массив А [12] Подсчитать сумму отрицательных элементов массива?

Дан массив А [12] Подсчитать сумму отрицательных элементов массива.

Значения элементов массива целые числа от - 20 до 20 СРОЧНО!

Happyboy333 24 июл. 2020 г., 15:59:39 | 5 - 9 классы

ПОМОГИТЕ ОЧЕНЬ НАДО в одномерном массиве элементы которого целые числа вставить новый элемент перед первым отрицательным элементом?

ПОМОГИТЕ ОЧЕНЬ НАДО в одномерном массиве элементы которого целые числа вставить новый элемент перед первым отрицательным элементом.

Pro100zheka 5 нояб. 2020 г., 16:50:49 | 5 - 9 классы

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100?

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100.

Найти :

a) наименьший элемент массива и его порядковый номер ;

b) наибольший элемент массива и его порядковый номер ;

c) сумму отрицательных и положительных элементов массива ;

d) среднее арифметическое отрицательных и положительных элементов массива ;

e) количество значений отрицательных, положительных и равных нулю элементов массива ;

Вопрос Вставить число, введённое с клавиатуры после первого отрицательного элемента массива?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.