Заменить в массиве первый отрицательный элемент нулем?

Информатика | 10 - 11 классы

Заменить в массиве первый отрицательный элемент нулем.

Ответить на вопрос
Ответы (1)
Tanyashmanatova 20 мар. 2020 г., 03:22:57

Program znanija ;

var A : array[1.

10] of integer ;

i, k : integer ;

begin

for i : = 1 to 10 do A[i] : = random(5) - 10 ; / / заполняем массив случайнымиотрицательными числами

for i : = 1 to high(A) do

if (A[i] < ; 0) and (k < ; 1) then begin A[i] : = 0 ; inc(k) ; end ; / / если отрицательное и мы ещё ниразу не заменяли, то заменяем на 0 и ставим флаг в К что уже заменили один раз

for i : = 1 to 10 do write(A[i] : 3) ; / / выводим массив.

Если первое число было отрицательным, то оно будет равно 0

end.

Anna41998 17 мая 2020 г., 10:50:55 | 5 - 9 классы

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива?

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива.

Если отрицательный элемент отсутствует, то вставить число в конец массива.

Plombirka10 17 нояб. 2020 г., 18:38:13 | 10 - 11 классы

Ввести массив A(n) ?

Ввести массив A(n) .

Если в массиве не менее двух отрицательных элементов , то уменьшить отрицательные элементы массива на 2 , иначе найти номер первого минимального элемента массива.

Bikbraze04 21 нояб. 2020 г., 17:11:05 | 5 - 9 классы

Вычислить в массиве сумму элементов от первого отрицательного и до конца?

Вычислить в массиве сумму элементов от первого отрицательного и до конца.

Moskvina04 31 авг. 2020 г., 07:25:56 | 10 - 11 классы

Дан массив А(к)?

Дан массив А(к).

Из элементов массива А сформировать массив В таким образом : сначала поместить все отрицательные массивы элемента А, потом равные нулю, а положительные в конце.

Hdtihst 11 мар. 2020 г., 17:03:16 | 10 - 11 классы

Заменить максимальный по модулю отрицательный элемент нулем?

Заменить максимальный по модулю отрицательный элемент нулем.

Makarkolesnich 2 авг. 2020 г., 21:12:38 | 5 - 9 классы

Ребят срочно?

Ребят срочно!

Вывести на печать первый отрицательный элемент массива А(20) и его номер, пологая что в массиве есть хотябы один отрицательный элемент.

17LIZA17 31 дек. 2020 г., 04:10:58 | 10 - 11 классы

Замените нулями все положительные элементы одномерного массива A длины N?

Замените нулями все положительные элементы одномерного массива A длины N.

Мучение0 14 сент. 2020 г., 05:20:12 | 5 - 9 классы

Составить программу , заменяющую отрицательные элементы элементы массива A[10] нулями?

Составить программу , заменяющую отрицательные элементы элементы массива A[10] нулями.

Aizhan111 12 янв. 2020 г., 12:19:45 | 10 - 11 классы

Что писать дальше?

Что писать дальше?

В массиве М (15) заменить все отрицательные элементы на их положительные значения.

Pro100zheka 5 нояб. 2020 г., 16:50:49 | 5 - 9 классы

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100?

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100.

Найти :

a) наименьший элемент массива и его порядковый номер ;

b) наибольший элемент массива и его порядковый номер ;

c) сумму отрицательных и положительных элементов массива ;

d) среднее арифметическое отрицательных и положительных элементов массива ;

e) количество значений отрицательных, положительных и равных нулю элементов массива ;

Вы зашли на страницу вопроса Заменить в массиве первый отрицательный элемент нулем?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.