Помогите, пожалуйста необходимо написать программу в Паскале Вставить по одному элементу с заданным значением перед всеми отрицательными элементами массива?

Информатика | 10 - 11 классы

Помогите, пожалуйста необходимо написать программу в Паскале Вставить по одному элементу с заданным значением перед всеми отрицательными элементами массива.

Ответить на вопрос
Ответы (2)
Iliada1 29 мар. 2020 г., 03:24:42

Var a : array[1.

10] of integer ; n, i : integer ;

begin readln(n) ; for i : = 1 to 10 do begin a[i] : = random( - 10, 10) ; if (a[i] < ; 0) and (i > ; 1) then begin if a[i - 1] > ; 0 then a[i - 1] : = n ; end ; if (a[i] < ; 0) and (i = 1) then write(n : 3) ; end ; for i : = 1 to 10 do write(a[i] : 3) ;

end.

Саша747642 29 мар. 2020 г., 03:24:46

Pascal ABC.

Artiomkonopli 27 сент. 2020 г., 07:42:34 | 1 - 4 классы

Найти максимальный элемент массива X(10)?

Найти максимальный элемент массива X(10).

Помогите написать программу в паскале пожалуйста.

Rord2014 16 нояб. 2020 г., 12:22:12 | 5 - 9 классы

Написать на Паскале программу нахождения суммы, произведения и среднего значения элементов массива, кол - во элементов ввести в программе?

Написать на Паскале программу нахождения суммы, произведения и среднего значения элементов массива, кол - во элементов ввести в программе.

Cmki 17 окт. 2020 г., 09:31:05 | 10 - 11 классы

Написать программу подсчёта числа отрицательных элементов массива?

Написать программу подсчёта числа отрицательных элементов массива.

Iissrr 8 нояб. 2020 г., 13:25:41 | 10 - 11 классы

Напишите в виде программы для паскаля?

Напишите в виде программы для паскаля.

В массиве А(5) посчитать количество положительных и отрицательных элементов.

Zenks 10 мар. 2020 г., 02:56:58 | 10 - 11 классы

Найди все четные по значению элементы массива?

Найди все четные по значению элементы массива.

Вывести на экран значение элементов и их индекс.

Ввод элементов массива с клавиатуры.

Программа пишется на языке Паскаль.

Kitaev97 27 февр. 2020 г., 01:05:08 | 5 - 9 классы

Написать программу в ПАСКАЛЕ, которая проверяет, есть ли во введенном с клавиатуры массиве элементы с одинаковым значением?

Написать программу в ПАСКАЛЕ, которая проверяет, есть ли во введенном с клавиатуры массиве элементы с одинаковым значением.

Пожалуйста подробно.

D20031 30 авг. 2020 г., 23:29:46 | 5 - 9 классы

Составьте программу вычисления в массиве В, состоящем из восьми элементов, суммы отрицательных элементов?

Составьте программу вычисления в массиве В, состоящем из восьми элементов, суммы отрицательных элементов.

Паскаль.

Элина26 14 февр. 2020 г., 12:25:31 | 10 - 11 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Выполнение в ПАСКАЛЕ.

Составьте ПРОГРАММУ для нахождения ИНДЕКСА первого положительного элемента массива из 10 элементов, заданных случайным образом.

Артур1254 10 окт. 2020 г., 22:10:16 | 5 - 9 классы

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого?

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого элемента.

Leopoldtv 13 нояб. 2020 г., 08:53:33 | 5 - 9 классы

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого?

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого элемента.

Вы открыли страницу вопроса Помогите, пожалуйста необходимо написать программу в Паскале Вставить по одному элементу с заданным значением перед всеми отрицательными элементами массива?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.