ПОМОГИТЕ РЕШИТЬ ЧЕРЕЗ ПОДПРОГРАММУ И БЕЗ "рандома" Дано : массивы А(8), В(11)?

Информатика | 10 - 11 классы

ПОМОГИТЕ РЕШИТЬ ЧЕРЕЗ ПОДПРОГРАММУ И БЕЗ "рандома" Дано : массивы А(8), В(11).

Определить в каком массиве отрицательное число встречается раньше.

Номер первого отрицательного элемента в массиве находить в подпрограмме.

Ответить на вопрос
Ответы (1)
MARGORITTTA 29 апр. 2020 г., 10:26:16

Const lim = 11 ;

type V = array[1.

Lim] of integer ;

function FirstNegative(a : V ; n : integer) : integer ;

var i : integer ;

begin i : = 0 ; Result : = 0 ; repeat i : = i + 1 ; if a[i] < ; 0 then Result : = i until (Result > ; 0) or (i > ; lim)

end ;

procedure InpMass(var a : V ; var n : integer ; mName : string) ; / / Организует ввод массива

var i, p : integer ;

begin writeln('Вводите элементы массива ' + mName + ' ; 7777 - конец ввода') ; i : = 0 ; repeat read(p) ; i : = i + 1 ; if p < ; > ; 7777 then a[i] : = p ; until (p = 7777) or (i > ; lim) ; n : = i - 1

end ;

var a, b : V ; m, n, p, q : integer ;

begin InpMass(a, m, 'A') ; InpMass(b, n, 'B') ; p : = FirstNegative(a, m) ; q : = FirstNegative(b, n) ; if p < ; = q then writeln('Номер первого отрицательного элемента в массива А : ', p) else writeln('Номер первого отрицательного элемента в массива B : ', q)

end.

Тестовое решение :

Вводите элементы массива A ; 7777 - конец ввода

37 14 - 25 32 30 - 29 38 27 7777

Вводите элементы массива B ; 7777 - конец ввода

33 - 36 23 - 17 - 3 - 16 - 33 33 - 48 - 39 30 7777

Номер первого отрицательного элемента в массива B : 2.

Anna41998 17 мая 2020 г., 10:50:55 | 5 - 9 классы

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива?

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива.

Если отрицательный элемент отсутствует, то вставить число в конец массива.

Katya43618 8 авг. 2020 г., 08:23:59 | 5 - 9 классы

Помогите решить, буду очень благодарен?

Помогите решить, буду очень благодарен.

1. Дан массив, найти произведение отрицательных элементов массива.

2. Дан массив, заменить все отрицательные элементы массива их модулями.

Cmki 17 окт. 2020 г., 09:31:05 | 10 - 11 классы

Написать программу подсчёта числа отрицательных элементов массива?

Написать программу подсчёта числа отрицательных элементов массива.

Plombirka10 17 нояб. 2020 г., 18:38:13 | 10 - 11 классы

Ввести массив A(n) ?

Ввести массив A(n) .

Если в массиве не менее двух отрицательных элементов , то уменьшить отрицательные элементы массива на 2 , иначе найти номер первого минимального элемента массива.

Bikbraze04 21 нояб. 2020 г., 17:11:05 | 5 - 9 классы

Вычислить в массиве сумму элементов от первого отрицательного и до конца?

Вычислить в массиве сумму элементов от первого отрицательного и до конца.

Девочка1997 20 мар. 2020 г., 03:22:50 | 10 - 11 классы

Заменить в массиве первый отрицательный элемент нулем?

Заменить в массиве первый отрицательный элемент нулем.

Makarkolesnich 2 авг. 2020 г., 21:12:38 | 5 - 9 классы

Ребят срочно?

Ребят срочно!

Вывести на печать первый отрицательный элемент массива А(20) и его номер, пологая что в массиве есть хотябы один отрицательный элемент.

Angelina21237 28 июн. 2020 г., 11:26:28 | 5 - 9 классы

Дан массив А [12] Подсчитать сумму отрицательных элементов массива?

Дан массив А [12] Подсчитать сумму отрицательных элементов массива.

Значения элементов массива целые числа от - 20 до 20 СРОЧНО!

Cat200235 10 июл. 2020 г., 02:03:00 | 5 - 9 классы

Дано : Массивы А(10), В(15)?

Дано : Массивы А(10), В(15).

Поменять местами их первые положительные элементы .

Для нахождения первого положительного элемента и его номера в массиве использовать подпрограмму.

Сделать в паскале.

Pro100zheka 5 нояб. 2020 г., 16:50:49 | 5 - 9 классы

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100?

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100.

Найти :

a) наименьший элемент массива и его порядковый номер ;

b) наибольший элемент массива и его порядковый номер ;

c) сумму отрицательных и положительных элементов массива ;

d) среднее арифметическое отрицательных и положительных элементов массива ;

e) количество значений отрицательных, положительных и равных нулю элементов массива ;

Вы зашли на страницу вопроса ПОМОГИТЕ РЕШИТЬ ЧЕРЕЗ ПОДПРОГРАММУ И БЕЗ "рандома" Дано : массивы А(8), В(11)?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.