ИНФОРМАТИКА, ПОМОГИТЕ?

Информатика | 5 - 9 классы

ИНФОРМАТИКА, ПОМОГИТЕ.

ПАСКАЛЬ, МАССИВЫ.

Задать случайным образом 10 элементов массива : целые числа из интервала от - 5 до 50.

Найти : 2) произведение элементов, стоящих на чётных местах ; 3) количество отрицательных элементов.

4) Ввести с клавиатуры 12 элементов числового массива.

Все положительные увеличить на 100, все отрицательные обнулить.

Ответить на вопрос
Ответы (1)
Nik2016nik 24 сент. 2020 г., 22:22:53

A : array [1.

50] of integer ;

i, pr, otr : integer ;

begin

randomize ;

for i : = 1 to 10 do a[i] : = random(50) - 5 ;

otr : = 0 ;

pr : = a[2] ;

for i : = 1 to 10 do begin if (a[i] < ; 0) theninc(otr) ; if (i mod 2 = 0) then pr : = pr * a[i] ; end ;

writeln('Отрицательных - ', otr, ' Произведение - ', pr) ;

for i : = 1 to 12 do

begin

read(a[i]) ;

if(a[i] > ; 0) then

inc(a[i], 100)

else

a[i] : = 0 ;

write(a[i], ' ') ;

end ;

end ;

Anna41998 17 мая 2020 г., 10:50:55 | 5 - 9 классы

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива?

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива.

Если отрицательный элемент отсутствует, то вставить число в конец массива.

CATandFOX 23 июн. 2020 г., 17:30:29 | 10 - 11 классы

Обнулить все отрицательные элементы массива и посчитать количество остальных?

Обнулить все отрицательные элементы массива и посчитать количество остальных.

Mirysa230902 6 дек. 2020 г., 07:15:14 | 10 - 11 классы

Найти количество положительных и отрицательных элементов в одномерном массиве?

Найти количество положительных и отрицательных элементов в одномерном массиве.

Vugyggvyub 12 апр. 2020 г., 16:32:30 | 10 - 11 классы

Паскаль, помогите?

Паскаль, помогите!

В числовом массиве из 10 элементов, заданных случайным образом от - 100 до 500.

Найти : 1) сумму положительных элементов, стоящих на чётных местах ; 2) произведение элементов массива, кратных 3 и стоящих на нечётных местах ;

Ventler1002 15 мая 2020 г., 07:08:20 | 10 - 11 классы

Решить задачу в Паскале (абв - всё в одной программе)"В числовом массиве из 10 элементов, заданных с клавиатуры :а) найти сумму положительных эелементов, стоящих на чётных местах ;б) найти произведени?

Решить задачу в Паскале (абв - всё в одной программе)

"В числовом массиве из 10 элементов, заданных с клавиатуры :

а) найти сумму положительных эелементов, стоящих на чётных местах ;

б) найти произведение элементов массива, кратных 3 и стоящих на нечётных местах ;

в) найти кол - во двузначных чисел в массиве.

"

СРОЧНО!

Жду верного решения : ) спасибо заранее.

Plombirka10 17 нояб. 2020 г., 18:38:13 | 10 - 11 классы

Ввести массив A(n) ?

Ввести массив A(n) .

Если в массиве не менее двух отрицательных элементов , то уменьшить отрицательные элементы массива на 2 , иначе найти номер первого минимального элемента массива.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Артёмкекеенреое 10 окт. 2020 г., 17:45:30 | 5 - 9 классы

В одномерном массиве из 20 элементов заполненном случайными числами из интервала [ - 10, 10] определить количество отрицательных элементов?

В одномерном массиве из 20 элементов заполненном случайными числами из интервала [ - 10, 10] определить количество отрицательных элементов.

Pro100zheka 5 нояб. 2020 г., 16:50:49 | 5 - 9 классы

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100?

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100.

Найти :

a) наименьший элемент массива и его порядковый номер ;

b) наибольший элемент массива и его порядковый номер ;

c) сумму отрицательных и положительных элементов массива ;

d) среднее арифметическое отрицательных и положительных элементов массива ;

e) количество значений отрицательных, положительных и равных нулю элементов массива ;

На этой странице сайта, в категории Информатика размещен ответ на вопрос ИНФОРМАТИКА, ПОМОГИТЕ?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.