Ввести массив A(n) ?

Информатика | 10 - 11 классы

Ввести массив A(n) .

Если в массиве не менее двух отрицательных элементов , то уменьшить отрицательные элементы массива на 2 , иначе найти номер первого минимального элемента массива.

Ответить на вопрос
Ответы (1)
Temagriffinofa1337 17 нояб. 2020 г., 18:38:18

Program Zadacha ;

Const n = 10 ;

Var a : Array [1.

N] of Integer ;

i, b : Integer ;

Begin

WriteLn('Введите через пробел ', n, ' чисел') ;

For i : = 1 To n Do

Read(a[i]) ;

b : = 0 ; For i : = 1 To n Do

If a[i] < ; 0 Then

b : = b + 1 ;

If b > ; = 2 Then

Begin

For i : = 1 To n Do

If a[i] < ; 0 Then

a[i] : = a[i] - 2 ;

For i : = 1 To n Do

Write(a[i], ' ') ;

End

Else

Begin

b : = 1 ;

For i : = 1 To n Do

If a[i] < ; a[b] Then

b : = i ; WriteLn('Номер первого минимального элемента массива - ', b) ;

End ;

ReadLn ;

End.

Anna41998 17 мая 2020 г., 10:50:55 | 5 - 9 классы

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива?

Вставить число, введённое с клавиатуры после первого отрицательного элемента массива.

Если отрицательный элемент отсутствует, то вставить число в конец массива.

Olegkudarbekov 12 июл. 2020 г., 05:41:52 | 5 - 9 классы

Дан одновременный массив, состоящий из 10 эллементов?

Дан одновременный массив, состоящий из 10 эллементов.

Пользователь вводит элементы массива.

Ввести массив на экран в строку.

Найти минимальный элемент массива.

Ниже приведен рекомендованный вид экрана во время выполнения программы : Вывод минимального элемента массива Ввод элементов массива Введите 1 элемент массива : 1 Введите 2 элемент массива : 2 Введите 3 элемент массива : 3 и т.

Д. до 10.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Katyahey 17 нояб. 2020 г., 17:52:13 | 10 - 11 классы

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы?

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы.

Настя631прдлвптррии 2 июн. 2020 г., 15:30:58 | 5 - 9 классы

1) Удвоить все элементы массива?

1) Удвоить все элементы массива.

2)Найти сумму элементов двух массивов одинаковой размерности.

4) Найти Минимальные элементы массива и его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива 7) Определить количество максимальных элементов массива P.

S Ребят, все в паскале.

Заранее спасибо = *.

Qleb 12 июн. 2020 г., 21:57:19 | 5 - 9 классы

Дан массив состоящий из 30 элементов?

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

Makarkolesnich 2 авг. 2020 г., 21:12:38 | 5 - 9 классы

Ребят срочно?

Ребят срочно!

Вывести на печать первый отрицательный элемент массива А(20) и его номер, пологая что в массиве есть хотябы один отрицательный элемент.

Лрапо 28 мар. 2020 г., 15:23:38 | 10 - 11 классы

1) Дан массив A(n)?

1) Дан массив A(n).

Положительные элементы массива заменить на их сумму, а отрицательные элементы уменьшить на минимальный.

Tamiktlekov 1 авг. 2020 г., 09:24:08 | 10 - 11 классы

Дан массив А(n)?

Дан массив А(n).

Уменьшить все его элементы на минимальный элемент массива.

Pro100zheka 5 нояб. 2020 г., 16:50:49 | 5 - 9 классы

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100?

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100.

Найти :

a) наименьший элемент массива и его порядковый номер ;

b) наибольший элемент массива и его порядковый номер ;

c) сумму отрицательных и положительных элементов массива ;

d) среднее арифметическое отрицательных и положительных элементов массива ;

e) количество значений отрицательных, положительных и равных нулю элементов массива ;

Вы находитесь на странице вопроса Ввести массив A(n) ? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.