Плиз очень надо даны три положительных числа a b c проверить будут ли они сторонами треугольника?

Информатика | 5 - 9 классы

Плиз очень надо даны три положительных числа a b c проверить будут ли они сторонами треугольника.

Если да, то вычислить площадь этого треугольника.

Через Структурное ветвление.

Ответить на вопрос
Ответы (1)
Konyakola 6 янв. 2020 г., 12:31:08

Паскаль

var a, b, c, p : real ;

begin

readln(a, b, c) ;

If (a< ; b + c)and(b< ; a + b)and(c< ; a + b)then begin writeln('Да') ; p : = (a + b + c) / 2 ; writeln('Площадь : ', sqrt(p * (p - a) * (p - b) * (p - c)) ; end

else writeln('Нет') ;

end.

Можно и на другом языке.

Dsfgh 18 февр. 2020 г., 11:50:16 | 10 - 11 классы

Даны три положительных числа?

Даны три положительных числа.

Если они могут быть длинами сторон остроугольного треугольника, то вычислить его площадь и определить вид треугольника ( равносторонний, равнобедренный или разносторонний), иначе выдать соответсвующее сообщение.

Kenn341 6 мая 2020 г., 22:48:44 | 10 - 11 классы

В программе паскаль : вычислите площадь треугольника по его сторонам?

В программе паскаль : вычислите площадь треугольника по его сторонам.

Сока 3 мая 2020 г., 09:26:31 | 10 - 11 классы

Дан треугольник со стороной a и прилежащими углами Y и B?

Дан треугольник со стороной a и прилежащими углами Y и B.

Вычислить площадь треугольника, найти остальные стороны и угол между ними.

Написать в паскале.

Alisa132 13 июл. 2020 г., 20:23:33 | 10 - 11 классы

Даны стороны треугольника a, b, c?

Даны стороны треугольника a, b, c.

Найти площадь треугольника.

Diana2211 10 апр. 2020 г., 00:43:27 | 5 - 9 классы

Даны три стороны треугольника найти площадь?

Даны три стороны треугольника найти площадь.

Onishenkoveroni 27 сент. 2020 г., 14:41:57 | 5 - 9 классы

Даны положительных числа a, b, c?

Даны положительных числа a, b, c.

Проверить могут ли они быть длинами сторон треугольника, если да, то вычесли его площадь.

(составить программу для паскаля).

110308 28 дек. 2020 г., 02:00:54 | 10 - 11 классы

Помогите с задачками в паскале?

Помогите с задачками в паскале.

Даны три положительных числа а, в, с.

Проверить будут ли они сторонами треугольника.

Если да то вычислить площадь этого треугольника.

Даны два действительных положительных числа х и у.

Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление).

Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.

BogdanovaNadya 27 мая 2020 г., 09:27:51 | 10 - 11 классы

1 задача : Даны три положительных числа a, b, c?

1 задача : Даны три положительных числа a, b, c.

Проверить, могут ли они быть сторонами прямоугольного треугольника.

2 задача : Используя оператор цикла For, найти количество положительных чисел N чисел Заранее спасибо = ).

Leanik1 27 дек. 2020 г., 23:43:49 | 10 - 11 классы

Создать программу, вычисляющую площадь треугольника Входные данные 3 числа(длины сторон треугольника) Выходные данные 1 число(площадь треугольника)?

Создать программу, вычисляющую площадь треугольника Входные данные 3 числа(длины сторон треугольника) Выходные данные 1 число(площадь треугольника).

Islamkyzy2003 3 нояб. 2020 г., 06:18:35 | 10 - 11 классы

Введите три числа?

Введите три числа.

Если они могут быть длинами сторон разностороннего остроугольного треугольника, выведите их в порядке возрастания и вычислите площадь полученного треугольника.

В паскале.

На этой странице сайта вы найдете ответы на вопрос Плиз очень надо даны три положительных числа a b c проверить будут ли они сторонами треугольника?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.