Дана строка, состоящая из русских слов, разделенных пробелом?

Информатика | 10 - 11 классы

Дана строка, состоящая из русских слов, разделенных пробелом.

Определить слово, с наибольшим количеством гласных букв, ребят помогииитее паскаль.

Ответить на вопрос
Ответы (1)
Vitaliyvasilev 16 янв. 2020 г., 11:56:52

Procedure GetWord(s : string ; var p : integer ; var w : string ; delim : string : = ' ') ;

{

Получает в w слово из строки s, которое начинается не ранее позиции p.

Возвращает новое значение p, указывающее на первый разделитель delim,

который следует за найденным словом или 0, если такой разделитель не найден.

По умолчанию слова разделяются не менее чем одним пробелом

}

var i, n : integer ; fBreak : boolean ; { флажок для прерывания циклов }

begin n : = Length(s) ; fBreak : = False ; {ищем первый символ, отличный от разделителя - начало слова } while ((p< ; = n) and (not fBreak)) do if (p = n) or (s[p]< ; > ; delim) then fBreak : = True else Inc(p) ; { ищем очередной разделитель - конец слова } if p< ; n then begin i : = p ; Inc(p) ; fBreak : = False ; while (p< ; = n) and (not fBreak) do begin if (p = n) or (s[p] = ' ') then fBreak : = True else Inc(p) end ; { теперь слово находится между позициями i и p } w : = Copy(s, i, p - i) end ; if p> ; = n then p : = 0

end ;

function CountG(w : string) : integer ;

{ возвращает количество гласных в слове w}

var i, k : integer ;

begin k : = 0 ; for i : = 1 to length(w) do if w[i] in ['а', 'е', 'ё', 'и', 'о', 'у', 'ы', 'э', 'ю', 'я'] then Inc(k) ; CountG : = k

end ;

var s, w, wmax : string ; p, k, gmax : integer ;

begin Writeln('Введите текст, разделяя слова пробелами') ; Readln(s) ; s : = LowerCase(s) ; p : = 1 ; gmax : = 0 ; while p> ; 0 do begin GetWord(s, p, w) ; k : = CountG(w) ; ; if gmax< ; k then begin gmax : = k ; wmax : = w end end ; if gmax> ; 0 then Writeln('В слове "', wmax, '" максимум гласных, равный ', gmax) else Writeln('Во введенной строке гласных букв не найдено')

end.

Ваня147 14 дек. 2020 г., 12:30:36 | 5 - 9 классы

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими)?

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими).

Вывести строку, содержащую эти же слова (разделенные одним пробелом), но расположенные в обратном порядке.

Help me!

Daynat 2 февр. 2020 г., 11:55:02 | 10 - 11 классы

Дана строка, состоящая из русских слов, набранных заглавными буквами и разделенных пробелами (одним или несколькими)?

Дана строка, состоящая из русских слов, набранных заглавными буквами и разделенных пробелами (одним или несколькими).

Найти количество слов, которые содержат хотя бы одну букву «А».

Kulikovacelina 13 дек. 2020 г., 07:54:35 | 10 - 11 классы

Паскаль?

Паскаль.

Дана строка, содержащая слова, разделенные одним пробелом.

Напечатать все слова, предварительно преобразовав каждое из них по следующему правилу : удалить из слова все последующие вхождения первой буквы.

Еваника 10 мар. 2020 г., 08:55:01 | 5 - 9 классы

С клавиатуры вводится строка состоящая из букв, знака пробела и циифр?

С клавиатуры вводится строка состоящая из букв, знака пробела и циифр.

Определите количество цифр в этой строке.

Lenokmalyshok 1 мая 2020 г., 18:53:58 | 1 - 4 классы

Составьте программу вводящую предложения, состоящие из слов, разделенных произвольным количеством пробелов?

Составьте программу вводящую предложения, состоящие из слов, разделенных произвольным количеством пробелов.

Предложения вводятся в одну строку.

Программа должна переписать введенную строку, оставив полько по одному пробелу между словами.

Mada5 10 февр. 2020 г., 11:41:49 | 10 - 11 классы

Паскаль, помогите 1?

Паскаль, помогите 1.

Дана строка состоящая из русских букв.

Преобразовать в ней все прописные буквы в строчные.

Kras22 17 янв. 2020 г., 12:55:20 | 10 - 11 классы

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом?

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом.

Написать программу меняющую части строки до и после пробела местами и добавляющую в конец строки восклицательный знак.

Решить в паскале.

PrayForUkraine 9 апр. 2020 г., 08:48:27 | 10 - 11 классы

Дана строка символов, состоящий из отдельных слов, разделенных пробелом?

Дана строка символов, состоящий из отдельных слов, разделенных пробелом.

Упорядочить слова по длине (в убыванию) и вывести на печать.

Даю 20 баллов.

СинийШар 15 янв. 2020 г., 00:09:44 | 10 - 11 классы

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом?

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом.

Строка вводится с клавиатуры.

Kiti2259 24 июн. 2020 г., 06:59:43 | 10 - 11 классы

Дана строка слова в которой разделены пробелом, подсчитайте количество слов в этой строке?

Дана строка слова в которой разделены пробелом, подсчитайте количество слов в этой строке.

На этой странице находится ответ на вопрос Дана строка, состоящая из русских слов, разделенных пробелом?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.