Составьте программу вводящую предложения, состоящие из слов, разделенных произвольным количеством пробелов?

Информатика | 1 - 4 классы

Составьте программу вводящую предложения, состоящие из слов, разделенных произвольным количеством пробелов.

Предложения вводятся в одну строку.

Программа должна переписать введенную строку, оставив полько по одному пробелу между словами.

Ответить на вопрос
Ответы (1)
MarMar28 1 мая 2020 г., 18:54:05

PROGRAM Probel ;

var s : string ; n, i : integer ;

begin

writeln ('введите текст с пробелами ') ;

readln(s) ; repeat inc(i) ;

n : = length(s) ;

if (s[i] = ' ') and ((s[i + 1] = ' ')) then

begin

delete (s, i, 1) ; dec(i) ;

end ;

until i = n ;

writeln ('удалены лишние пробелы ') ;

writeln(s) ;

end.

Ваня147 14 дек. 2020 г., 12:30:36 | 5 - 9 классы

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими)?

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими).

Вывести строку, содержащую эти же слова (разделенные одним пробелом), но расположенные в обратном порядке.

Help me!

Daynat 2 февр. 2020 г., 11:55:02 | 10 - 11 классы

Дана строка, состоящая из русских слов, набранных заглавными буквами и разделенных пробелами (одним или несколькими)?

Дана строка, состоящая из русских слов, набранных заглавными буквами и разделенных пробелами (одним или несколькими).

Найти количество слов, которые содержат хотя бы одну букву «А».

Kiri4ka2101 25 февр. 2020 г., 02:39:32 | 10 - 11 классы

Дан текст в виде строки?

Дан текст в виде строки.

Слова в строке разделены несколькими пробелами.

Требуется удалить лишние пробелы, оставив только по одному между словами.

Valera1316 28 янв. 2020 г., 05:59:53 | 5 - 9 классы

Составьте программу нахождения количество слов в предложении?

Составьте программу нахождения количество слов в предложении.

Предложение состоит из слов, отделёный друг от друга одним пробелом, вводится с клавиатуры.

Идиото 4 апр. 2020 г., 08:03:45 | 10 - 11 классы

1. С клавиатуры вводится слово, распечатать все его буквы через пробел?

1. С клавиатуры вводится слово, распечатать все его буквы через пробел.

(после последней буквы пробела быть не должно).

2. Написать программу, которая удаляет первое слово из строки введенной с клавиатуры и вместо него вставляет заданное.

Kras22 17 янв. 2020 г., 12:55:20 | 10 - 11 классы

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом?

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом.

Написать программу меняющую части строки до и после пробела местами и добавляющую в конец строки восклицательный знак.

Решить в паскале.

Shavkat1979 21 нояб. 2020 г., 08:04:02 | 5 - 9 классы

Составьте программу, которая введенное с клавиатуры предложение выводит в первой строке экрана, а затем по одному слову перемещает на последнюю строку?

Составьте программу, которая введенное с клавиатуры предложение выводит в первой строке экрана, а затем по одному слову перемещает на последнюю строку.

Семеныч6666666 11 дек. 2020 г., 16:46:08 | 5 - 9 классы

Составьте программу выводящую на экран в одну строку через пробел числа от 1 до 50?

Составьте программу выводящую на экран в одну строку через пробел числа от 1 до 50.

СинийШар 15 янв. 2020 г., 00:09:44 | 10 - 11 классы

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом?

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом.

Строка вводится с клавиатуры.

Цааж 18 окт. 2020 г., 12:53:20 | 10 - 11 классы

Решить либо на С, С + + , PascalДана строка, состоящая из слов, разделенных пробелами?

Решить либо на С, С + + , Pascal

Дана строка, состоящая из слов, разделенных пробелами.

Напишите программу, удаляющую лишние пробелы и добавляющую недостающие пробелы.

Пробел считается лишним, если он : * стоит в начале строки ; * стоит перед знаком препинания ; * стоит в конце строки ; * следует за пробелом.

Добавить пробел после знака препинания, при условии выполнения предыдущих пунктов.

На этой странице находится ответ на вопрос Составьте программу вводящую предложения, состоящие из слов, разделенных произвольным количеством пробелов?, из категории Информатика, соответствующий программе для 1 - 4 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.