Ребят, помогите решить?

Информатика | 5 - 9 классы

Ребят, помогите решить!

Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел.

Незначащих нулей в найденном числе быть не должно.

Формат входных данных :

Входной файл INPUT.

TXT содержит два натуральных числа N (10< ; = N< ; = 10 ^ 100) и M (10< ; = M< ; = 10 ^ 100), разделенных одним пробелом.

Формат выходных данных :

Выходной файл OUTPUT.

TXT должен содержать найденной наименьшее число.

Пример

INPUT.

Txt. OUTPUT.

Txt

423 42 22344.

Ответить на вопрос
Ответы (1)
Fidoev63 30 нояб. 2020 г., 11:01:56

Procedure ShellStr(var s : string) ;

{ сортирует символы строки методом Шелла }

var i, j, n, step : integer ; c : char ;

begin s : = Trim(s) ; n : = Length(s) ; step : = n div 2 ; while step > ; 0 do begin for j : = n - step downto 1 do begin i : = j ; while i < ; = n - step do begin if s[i] > ; s[i + step] then begin c : = s[i] ; s[i] : = s[i + 1] ; s[i + 1] : = c end ; i : = i + step end end ; step : = step div 2 end

end ;

procedure TrimNullsLeft(var s : string) ;

{ Усекает левые (незначащие нули) в строке s }

var i, n : integer ;

begin i : = 1 ; n : = Length(s) ; while (s[i] = '0') do i : = i + 1 ; s : = Copy(s, i, n - i + 1)

end ;

var p : integer ; s, M, N : string ; f : text ;

begin Assign(f, 'input.

Txt') ; Reset(f) ; Readln(f, s) ; Close(f) ; Assign(f, 'output.

Txt') ; Rewrite(f) ; s : = Trim(s) ; p : = Pos(' ', s) ; M : = Copy(s, 1, p - 1) ; N : = Copy(s, p + 1, Length(s) - p) ; s : = M + N ; ShellStr(s) ; TrimNullsLeft(s) ; Writeln(f, s) ; Close(f) ; Writeln('Программа завершила работу')

end.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

Kartashovaa79 11 окт. 2020 г., 06:44:01 | 10 - 11 классы

Дано два натуральных числа N и M?

Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел.

Незначащих нулей в найденном числе быть не должно.

Формат входных данных : Входной файл INPUT.

TXT содержит два натуральных числа N (10N10100) и M (10M10100), разделенных одним пробелом.

Формат выходных данных : Выходной файл OUTPUT.

TXT должен содержать найденное наименьшее число.

Ghfgdfg 16 сент. 2020 г., 11:45:38 | 1 - 4 классы

Дано натуральное трехзначное число N ?

Дано натуральное трехзначное число N .

Определить сумму и произведение его цифр.

Имя входного файла Input.

Txt, имя выходного файла output.

Txt.

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Varry 12 мар. 2020 г., 01:50:56 | 5 - 9 классы

Даны два файла : input?

Даны два файла : input.

Txt и output.

Txt. В input.

Txt дана последовательность чисел : 1, 6, 11, 16, 21.

В Output.

Txt отобразить размах ряда (т.

Е разность между наибольшим и наименьшим числом).

Pascal.

Adamgulova2002 28 сент. 2020 г., 16:42:34 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Shmalkoalya 28 февр. 2020 г., 01:25:39 | 10 - 11 классы

ТреугольникВычислите, в какой координатной четверти расположен треугольник, образованный прямой, заданной уравнением y = ax + b, и осями координат?

Треугольник

Вычислите, в какой координатной четверти расположен треугольник, образованный прямой, заданной уравнением y = ax + b, и осями координат.

Числа a и b такие, что треугольник всегда существует.

Формат входных данных :

входной файл INPUT.

TXT содержит заданные целые числа a и b ( - 100£a, b£100)

Формат выходных данных :

Выходной файл OUTPUT.

TXT должен содержать номер четверти.

Пример

Input.

Txt

Output.

Txt

423 402 2.

Gramotey2281 9 окт. 2020 г., 07:16:58 | 5 - 9 классы

Задана последовательность неотрицательных целых чисел?

Задана последовательность неотрицательных целых чисел.

Требуется определить длину последовательности, завершающуюся первым встретившимся нолем (число 0 не входит в последовательность).

Входные данные Входной файл INPUT.

TXT содержит последовательность неотрицательных целых чисел, не превышающих значения 100.

Гарантируется, что во входных данных не более 100 чисел и среди них есть хотя бы одно число 0.

Выходные данные В выходной файл OUTPUT.

TXT выведите целое число – длину последовательности.

Пожалуйста решите, на C + + или на Pascal.

Анфиса8586 8 дек. 2020 г., 14:54:28 | 5 - 9 классы

В файле input?

В файле input.

Txt записаны числа, сколько их - неизвестно.

Определить и записать в файл output.

Txt количество чисел с одинаковыми цифрами (11, 22.

).

Salamatovna05 5 нояб. 2020 г., 23:25:31 | 10 - 11 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

Дано натуральное число N.

Требуется представить его в виде суммы двух натуральных чисел A и B таких, что НОД (наибольший общий делитель) чисел A и B — максимален.

Входные данные Во входном файле INPUT.

TXT записано натуральное число N (2< ; = N< ; = 109) Выходные данные В выходной файл OUTPUT.

TXT выведите два искомых числа A и B.

Если решений несколько, выведите то из них, где A принимает наименьшее возможное значение.

На этой странице находится ответ на вопрос Ребят, помогите решить?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.