ТреугольникВычислите, в какой координатной четверти расположен треугольник, образованный прямой, заданной уравнением y = ax + b, и осями координат?

Информатика | 10 - 11 классы

Треугольник

Вычислите, в какой координатной четверти расположен треугольник, образованный прямой, заданной уравнением y = ax + b, и осями координат.

Числа a и b такие, что треугольник всегда существует.

Формат входных данных :

входной файл INPUT.

TXT содержит заданные целые числа a и b ( - 100£a, b£100)

Формат выходных данных :

Выходной файл OUTPUT.

TXT должен содержать номер четверти.

Пример

Input.

Txt

Output.

Txt

423 402 2.

Ответить на вопрос
Ответы (1)
Светлана7905 28 февр. 2020 г., 01:25:42

Заданная уравнением прямая всегда будет гипотенузой прямоугольного треугольника, а его прямой угол всегда будет лежать в точке пересечения осей координат.

Таким образом, размещение гипотенузы всегда будет определять четверть, в которой находится треугольник.

Гипотенуза пересекает ось Х в точке с координатами (х1 ; 0), а ось Y - в точке с координатами (0 ; y2).

Найдем эти координаты, считая коэффициенты a и b в уравнении прямой заданными.

$y=ax+b \\ y_1=ax_1+b; \ y_1=0 \to x_1=- \frac{b}{a} \\ y_2=ax_2+b; \ x_2=0 \to y_2=b$

Теперь можно определить номера четвертей n, в которых располагается гипотенуза.

$n=\begin {cases} 1, \ a<0, \, b>0 \\ 2, \ a>0, \, b>0 \\ 3, \ a<0, \, b<0 \\ 4, \ a>0, \, b<0 \end {cases}$

var a, b : integer ; f : Text ;

begin Assign(f, 'input.

Txt') ; Reset(f) ; Readln(f, a, b) ; Close(f) ; Assign(f, 'output.

Txt') ; Rewrite(f) ; if a < ; 0 then if b < ; 0 then Writeln(f, '3') else Writeln(f, '1') else if b < ; 0 then Writeln(f, '4') else Writeln(f, '2') ; Close(f)

end.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

Kartashovaa79 11 окт. 2020 г., 06:44:01 | 10 - 11 классы

Дано два натуральных числа N и M?

Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел.

Незначащих нулей в найденном числе быть не должно.

Формат входных данных : Входной файл INPUT.

TXT содержит два натуральных числа N (10N10100) и M (10M10100), разделенных одним пробелом.

Формат выходных данных : Выходной файл OUTPUT.

TXT должен содержать найденное наименьшее число.

АвАтАрОчКа 30 нояб. 2020 г., 11:01:51 | 5 - 9 классы

Ребят, помогите решить?

Ребят, помогите решить!

Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел.

Незначащих нулей в найденном числе быть не должно.

Формат входных данных :

Входной файл INPUT.

TXT содержит два натуральных числа N (10< ; = N< ; = 10 ^ 100) и M (10< ; = M< ; = 10 ^ 100), разделенных одним пробелом.

Формат выходных данных :

Выходной файл OUTPUT.

TXT должен содержать найденной наименьшее число.

Пример

INPUT.

Txt. OUTPUT.

Txt

423 42 22344.

Ghfgdfg 16 сент. 2020 г., 11:45:38 | 1 - 4 классы

Дано натуральное трехзначное число N ?

Дано натуральное трехзначное число N .

Определить сумму и произведение его цифр.

Имя входного файла Input.

Txt, имя выходного файла output.

Txt.

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Komogorova07 5 июн. 2020 г., 07:16:59 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Varry 12 мар. 2020 г., 01:50:56 | 5 - 9 классы

Даны два файла : input?

Даны два файла : input.

Txt и output.

Txt. В input.

Txt дана последовательность чисел : 1, 6, 11, 16, 21.

В Output.

Txt отобразить размах ряда (т.

Е разность между наибольшим и наименьшим числом).

Pascal.

Adamgulova2002 28 сент. 2020 г., 16:42:34 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Gramotey2281 9 окт. 2020 г., 07:16:58 | 5 - 9 классы

Задана последовательность неотрицательных целых чисел?

Задана последовательность неотрицательных целых чисел.

Требуется определить длину последовательности, завершающуюся первым встретившимся нолем (число 0 не входит в последовательность).

Входные данные Входной файл INPUT.

TXT содержит последовательность неотрицательных целых чисел, не превышающих значения 100.

Гарантируется, что во входных данных не более 100 чисел и среди них есть хотя бы одно число 0.

Выходные данные В выходной файл OUTPUT.

TXT выведите целое число – длину последовательности.

Пожалуйста решите, на C + + или на Pascal.

Анфиса8586 8 дек. 2020 г., 14:54:28 | 5 - 9 классы

В файле input?

В файле input.

Txt записаны числа, сколько их - неизвестно.

Определить и записать в файл output.

Txt количество чисел с одинаковыми цифрами (11, 22.

).

На этой странице сайта, в категории Информатика размещен ответ на вопрос ТреугольникВычислите, в какой координатной четверти расположен треугольник, образованный прямой, заданной уравнением y = ax + b, и осями координат?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.