ПАСКАЛЬ?

Информатика | 10 - 11 классы

ПАСКАЛЬ.

Дано натуральное число N.

Требуется представить его в виде суммы двух натуральных чисел A и B таких, что НОД (наибольший общий делитель) чисел A и B — максимален.

Входные данные Во входном файле INPUT.

TXT записано натуральное число N (2< ; = N< ; = 109) Выходные данные В выходной файл OUTPUT.

TXT выведите два искомых числа A и B.

Если решений несколько, выведите то из них, где A принимает наименьшее возможное значение.

Ответить на вопрос
Ответы (1)
Поличка8 5 нояб. 2020 г., 23:25:35

Если A, B имеют общий делитель d, то и A + B делится на d.

Отсюда идея : найдем наибольший делитель N, меньший N, и представим всё в виде d + (N - d).

D будем искать так : найдём наименьший делитель q, не равный 1 (если число составное, он не больше корня из N), тогда d = N / q.

Var q, d, n : longint ; isfound : boolean ;

begin readln(n) ; isfound : = false ; for q : = 2 to trunc(sqrt(n)) + 1 do if n mod q = 0 then begin d : = n div q ; write(d, ' ', n - d) ; isfound : = true ; break ; end ; if not isfound then write(1, ' ', n - 1) ;

end.

Kartashovaa79 11 окт. 2020 г., 06:44:01 | 10 - 11 классы

Дано два натуральных числа N и M?

Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел.

Незначащих нулей в найденном числе быть не должно.

Формат входных данных : Входной файл INPUT.

TXT содержит два натуральных числа N (10N10100) и M (10M10100), разделенных одним пробелом.

Формат выходных данных : Выходной файл OUTPUT.

TXT должен содержать найденное наименьшее число.

АвАтАрОчКа 30 нояб. 2020 г., 11:01:51 | 5 - 9 классы

Ребят, помогите решить?

Ребят, помогите решить!

Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел.

Незначащих нулей в найденном числе быть не должно.

Формат входных данных :

Входной файл INPUT.

TXT содержит два натуральных числа N (10< ; = N< ; = 10 ^ 100) и M (10< ; = M< ; = 10 ^ 100), разделенных одним пробелом.

Формат выходных данных :

Выходной файл OUTPUT.

TXT должен содержать найденной наименьшее число.

Пример

INPUT.

Txt. OUTPUT.

Txt

423 42 22344.

Ghfgdfg 16 сент. 2020 г., 11:45:38 | 1 - 4 классы

Дано натуральное трехзначное число N ?

Дано натуральное трехзначное число N .

Определить сумму и произведение его цифр.

Имя входного файла Input.

Txt, имя выходного файла output.

Txt.

Borodyha123 28 дек. 2020 г., 21:12:44 | 10 - 11 классы

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу ?

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу .

Формат входных данных

Входной файл содержит числа , ().

Формат выходных данных

Выведите искомые делители.

Примеры :

Вход6 3

Выход3 6.

Komogorova07 5 июн. 2020 г., 07:16:59 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Varry 12 мар. 2020 г., 01:50:56 | 5 - 9 классы

Даны два файла : input?

Даны два файла : input.

Txt и output.

Txt. В input.

Txt дана последовательность чисел : 1, 6, 11, 16, 21.

В Output.

Txt отобразить размах ряда (т.

Е разность между наибольшим и наименьшим числом).

Pascal.

Ммутыл 16 нояб. 2020 г., 15:25:50 | 5 - 9 классы

ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000)?

ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000).

Входные данные Вводится натуральное число x.

Выходные данные Выведите наименьший делитель числа x, отличный от 1.

Примеры входные данные 2 выходные данные 2 входные данные 6 выходные данные 2.

Adamgulova2002 28 сент. 2020 г., 16:42:34 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Gramotey2281 9 окт. 2020 г., 07:16:58 | 5 - 9 классы

Задана последовательность неотрицательных целых чисел?

Задана последовательность неотрицательных целых чисел.

Требуется определить длину последовательности, завершающуюся первым встретившимся нолем (число 0 не входит в последовательность).

Входные данные Входной файл INPUT.

TXT содержит последовательность неотрицательных целых чисел, не превышающих значения 100.

Гарантируется, что во входных данных не более 100 чисел и среди них есть хотя бы одно число 0.

Выходные данные В выходной файл OUTPUT.

TXT выведите целое число – длину последовательности.

Пожалуйста решите, на C + + или на Pascal.

Kabakova2003 20 сент. 2020 г., 07:05:20 | 5 - 9 классы

C + + или паскаль?

C + + или паскаль.

Нужно решение (Динамическое программирование) Найдите количество невырожденных прямоугольников со сторонами, параллельными осям координат, вершины которых лежат в точках с целыми координатами внутри или на границе прямоугольника, противоположные углы которого находятся в точках (0, 0) и (W, Н).

Входные данные Входной файл INPUT.

TXT содержит два натуральных числа W и Н, не превосходящих 1000.

Выходные данные В выходной файл OUTPUT.

TXT выведите ответ на задачу.

На этой странице находится вопрос ПАСКАЛЬ?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.