Задана последовательность неотрицательных целых чисел?

Информатика | 5 - 9 классы

Задана последовательность неотрицательных целых чисел.

Требуется определить длину последовательности, завершающуюся первым встретившимся нолем (число 0 не входит в последовательность).

Входные данные Входной файл INPUT.

TXT содержит последовательность неотрицательных целых чисел, не превышающих значения 100.

Гарантируется, что во входных данных не более 100 чисел и среди них есть хотя бы одно число 0.

Выходные данные В выходной файл OUTPUT.

TXT выведите целое число – длину последовательности.

Пожалуйста решите, на C + + или на Pascal.

Ответить на вопрос
Ответы (1)
Ed1 9 окт. 2020 г., 07:17:03

Program arr_length ;

const IN_FILENAME = 'INPUT.

Txt' ; OUT_FILENAME = 'OUTPUT.

Txt' ;

var fileIn, fileOut : TextFile ; s, t : string ;

begin writeln('Загружаю входные данные.

') ; t : = '' ; AssignFile(fileIn, IN_FILENAME) ; AssignFile(fileOut, OUT_FILENAME) ; reset(fileIn) ; while not eof(fileIn) do begin readln(fileIn, s) ; if (s = '0') then break else t : = t + s ; end ; CloseFile(fileIn) ; rewrite(fileOut) ; writeln(fileOut, Length(t)) ; CloseFile(fileOut) ;

end.

Макс451564 3 янв. 2020 г., 16:14:15 | 10 - 11 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных Первая строка входного файла содержит целое число N (1 < ; = N < ; = 100000).

В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

Larisapolukhin1 25 февр. 2020 г., 23:19:20 | 5 - 9 классы

Вывести все значения элементов заданной числовой последовательности?

Вывести все значения элементов заданной числовой последовательности.

Входные данные : Выходные данные : Во входном потоке в первой строке записано единственное целое число N (0 < ; N < ; = 100) - число элементов числовой последовательности ; Во второй строке перечислены значения элементов целочисленной последовательности (через пробел).

Значения элементов по модулю не превышают 1000.

В выходной поток вывести значения элементов числовой последовательности в столбик, каждое с новой строки.

Пример входного файла (input.

Txt) : 10 43 564 32 76 342 76 43 342 876 42 Пример выходного файла (output.

Txt) : 43 564 32 76 342 76 43 342 876 42 ПОМОГИТЕ ПОЖАЛУЙСТААА!

Ghfgdfg 16 сент. 2020 г., 11:45:38 | 1 - 4 классы

Дано натуральное трехзначное число N ?

Дано натуральное трехзначное число N .

Определить сумму и произведение его цифр.

Имя входного файла Input.

Txt, имя выходного файла output.

Txt.

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Atey94033 9 апр. 2020 г., 22:40:15 | 5 - 9 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных Первая строка входного файла содержит целое число N (1 < ; = N < ; = 100000).

В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Формат выходных данных Выведите ответ к задаче.

Varry 12 мар. 2020 г., 01:50:56 | 5 - 9 классы

Даны два файла : input?

Даны два файла : input.

Txt и output.

Txt. В input.

Txt дана последовательность чисел : 1, 6, 11, 16, 21.

В Output.

Txt отобразить размах ряда (т.

Е разность между наибольшим и наименьшим числом).

Pascal.

Makarchuksm 27 нояб. 2020 г., 13:14:58 | 10 - 11 классы

Дана последовательность чисел А длины N?

Дана последовательность чисел А длины N.

Требуется вывести в обратном порядке.

Первая строка входного файла содержит целое число N (1 < ; = N < ; = 1000000) - длину последовательности.

Вторая строка входного файла содержит N целых чисел - элементы последовательности A.

Все элементы последовательности не превосходят 100000 по абсолютному значению.

В единственной строке выходного файла выведите элементы последовательности A в обратном порядке.

Для наглядности обратите внимание на примеры.

A in 3 a out 321 123 4 a out 1231 1321.

FalosElena 21 окт. 2020 г., 00:36:49 | 5 - 9 классы

Последовательность состоит из различных натуральных чисел и завершается числом 0?

Последовательность состоит из различных натуральных чисел и завершается числом 0.

Определите значение второго по величине элемента в этой последовательности.

Числа, следующие за числом 0, считывать не нужно.

Входные данные

Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

1

7

9

0

выходные данные

7

Помогите пж программирование очень срочно pascal abc.

Желательно написать целый код а не подсказывать.

12345678164 29 нояб. 2020 г., 12:16:09 | 5 - 9 классы

Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке?

Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке.

Последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и вывести количество членов последовательности (не считая завершающего числа 0).

Числа, следующие за числом 0, считывать не нужно.

Входные данные

Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

1

7

9

0

5

выходные данные

3.

Если вам необходимо получить ответ на вопрос Задана последовательность неотрицательных целых чисел?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.