Заданы два натуральных числа N и K?

Информатика | 10 - 11 классы

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Ответить на вопрос
Ответы (1)
RendyWhatson 28 сент. 2020 г., 16:42:38

Program Task ;

Var t : Text ; N, K, M : LongInt ;

Begin Assign(t, 'd : \ input.

Txt') ; Reset(t) ; While Not EOF(t) Do Begin Read(t, N) ; Read(t, K) ; End ; If (N < ; 1) Or (N > ; Exp(100 * Ln(10))) Or (K < ; 1) Or (K > ; Exp(9 * Ln(10))) Then WriteLn('Input error!

') Else Begin M : = N Mod K ; Assign(t, 'd : \ output.

Txt') ; Rewrite(t) ; Write(t, M) ; Close(t) ; Write('Done.

') ; End ; ReadLn ;

End.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

Lfitymrf123 8 сент. 2020 г., 10:12:24 | 5 - 9 классы

В кафе продается мороженое по 3 или по 5 шариков в порции?

В кафе продается мороженое по 3 или по 5 шариков в порции.

Определить, можно ли купить K шариков мороженного.

Входные данные : Во входном потоке в первой строке задано натуральное число К (K < ; = 1000) Выходные данные : Вывести YES или NO.

Пример входного файла (input.

Txt) : 2.

Kartashovaa79 11 окт. 2020 г., 06:44:01 | 10 - 11 классы

Дано два натуральных числа N и M?

Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел.

Незначащих нулей в найденном числе быть не должно.

Формат входных данных : Входной файл INPUT.

TXT содержит два натуральных числа N (10N10100) и M (10M10100), разделенных одним пробелом.

Формат выходных данных : Выходной файл OUTPUT.

TXT должен содержать найденное наименьшее число.

АвАтАрОчКа 30 нояб. 2020 г., 11:01:51 | 5 - 9 классы

Ребят, помогите решить?

Ребят, помогите решить!

Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел.

Незначащих нулей в найденном числе быть не должно.

Формат входных данных :

Входной файл INPUT.

TXT содержит два натуральных числа N (10< ; = N< ; = 10 ^ 100) и M (10< ; = M< ; = 10 ^ 100), разделенных одним пробелом.

Формат выходных данных :

Выходной файл OUTPUT.

TXT должен содержать найденной наименьшее число.

Пример

INPUT.

Txt. OUTPUT.

Txt

423 42 22344.

Ghfgdfg 16 сент. 2020 г., 11:45:38 | 1 - 4 классы

Дано натуральное трехзначное число N ?

Дано натуральное трехзначное число N .

Определить сумму и произведение его цифр.

Имя входного файла Input.

Txt, имя выходного файла output.

Txt.

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Komogorova07 5 июн. 2020 г., 07:16:59 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Shmalkoalya 28 февр. 2020 г., 01:25:39 | 10 - 11 классы

ТреугольникВычислите, в какой координатной четверти расположен треугольник, образованный прямой, заданной уравнением y = ax + b, и осями координат?

Треугольник

Вычислите, в какой координатной четверти расположен треугольник, образованный прямой, заданной уравнением y = ax + b, и осями координат.

Числа a и b такие, что треугольник всегда существует.

Формат входных данных :

входной файл INPUT.

TXT содержит заданные целые числа a и b ( - 100£a, b£100)

Формат выходных данных :

Выходной файл OUTPUT.

TXT должен содержать номер четверти.

Пример

Input.

Txt

Output.

Txt

423 402 2.

Gramotey2281 9 окт. 2020 г., 07:16:58 | 5 - 9 классы

Задана последовательность неотрицательных целых чисел?

Задана последовательность неотрицательных целых чисел.

Требуется определить длину последовательности, завершающуюся первым встретившимся нолем (число 0 не входит в последовательность).

Входные данные Входной файл INPUT.

TXT содержит последовательность неотрицательных целых чисел, не превышающих значения 100.

Гарантируется, что во входных данных не более 100 чисел и среди них есть хотя бы одно число 0.

Выходные данные В выходной файл OUTPUT.

TXT выведите целое число – длину последовательности.

Пожалуйста решите, на C + + или на Pascal.

Salamatovna05 5 нояб. 2020 г., 23:25:31 | 10 - 11 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

Дано натуральное число N.

Требуется представить его в виде суммы двух натуральных чисел A и B таких, что НОД (наибольший общий делитель) чисел A и B — максимален.

Входные данные Во входном файле INPUT.

TXT записано натуральное число N (2< ; = N< ; = 109) Выходные данные В выходной файл OUTPUT.

TXT выведите два искомых числа A и B.

Если решений несколько, выведите то из них, где A принимает наименьшее возможное значение.

Вы открыли страницу вопроса Заданы два натуральных числа N и K?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.