Составить программу Pascal : Вводят число от 1 - 12 - номер месяца?

Информатика | 5 - 9 классы

Составить программу Pascal : Вводят число от 1 - 12 - номер месяца.

Если число входит в интервал от 1 до 12, то высвечивается месяц, а если нет то выходит слово ошибка!

Помогите срочно!

Ответить на вопрос
Ответы (1)
Tsikalo84 20 июн. 2020 г., 08:32:45

Var months : array [1.

12] of string ; x : integer ;

begin months[1] : = 'January' ; months[2] : = 'February' ; months[3] : = 'March' ; months[4] : = 'April' ; months[5] : = 'May' ; months[6] : = 'June' ; months[7] : = 'July' ; months[8] : = 'August' ; months[9] : = 'September' ; months[10] : = 'October' ; months[11] : = 'November' ; months[12] : = 'December' ; read(x) ; if ((x < ; 1) or (x > ; 12)) then begin write('Error!

') ; end else begin write(months[x]) ; end ;

end.

ТанТан 22 июл. 2020 г., 05:59:26 | 10 - 11 классы

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце?

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце.

При вводе неверного номера месяца должно быть выведено сообщение об ошибке.

Считается, что год невисокосный.

Входные данные Входная строка содержит единственное целое число – номер месяца (возможно, неправильный).

Выходные данные Выходная строка должна содержать одно целое число – количество дней в этом месяце или 0, если был введён неверный номер месяца.

Для ABCpascal.

Stepa200326 2 дек. 2020 г., 09:23:29 | 5 - 9 классы

Составить программу для вычисления числа дней в месяце по введенному номеру месяца?

Составить программу для вычисления числа дней в месяце по введенному номеру месяца.

ВладиславКуцак 1 апр. 2020 г., 20:19:44 | 10 - 11 классы

Pascal написать программу которая выводит все делители числа число вводится пользователем?

Pascal написать программу которая выводит все делители числа число вводится пользователем.

Хинори7337 12 июн. 2020 г., 13:28:17 | 5 - 9 классы

Ученик вводит число соответствующее месяцу?

Ученик вводит число соответствующее месяцу.

Определить какому времени года соответствует этот месяц.

(написать программу в паскале).

BakAniki 4 февр. 2020 г., 13:09:12 | 5 - 9 классы

Структурные операторы в языке pascal : Развилка и выбор?

Структурные операторы в языке pascal : Развилка и выбор.

1. Даны целые цисла m и n.

Если числа не равны, то заменить каждое из них одним и тем же числом, равным большему из исходных, а если равны, то заменить числа нулями.

2. Составить программу, которая по заданному году и номера месяца m определяет количество дней в этом месяце.

Davletyarov 18 апр. 2020 г., 09:41:14 | 10 - 11 классы

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке?

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке.

При вводе неверного номера месяца должно быть выведено слово 'NO'.

Maxorliov 22 апр. 2020 г., 20:47:12 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

Помогите решить задачу в Pascal.

"С клавиатуры вводятся два слова.

Требуется найти множество гласных букв , которые входят в первое слово , но не входят во второе слово.

" Помогите срочно , пожалуйста, в PASCAL!

Nikki09 15 мая 2020 г., 14:49:26 | 5 - 9 классы

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце?

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце.

При вводе неверного номера месяца должно быть выведено сообщение об ошибке.

Считается, что год невисокосный.

Входные данные Входная строка содержит единственное целое число – номер месяца (возможно, неправильный).

Выходные данные Выходная строка должна содержать одно целое число – количество дней в этом месяце или 0, если был введён неверный номер месяца.

Для PYTHON, не для Pascal.

Rossy11 21 авг. 2020 г., 03:29:11 | 5 - 9 классы

Составьте программу, которая, учитывая наименование года и день недели соответствующий 1 января, выводит на экран наименования месяцев в которых число 13 выпадет на пятницу (программа pascal abc) сроч?

Составьте программу, которая, учитывая наименование года и день недели соответствующий 1 января, выводит на экран наименования месяцев в которых число 13 выпадет на пятницу (программа pascal abc) срочно надо, не понимаю как составить(.

ReginaJ98 12 сент. 2020 г., 06:25:02 | 5 - 9 классы

Помогите составить программу с помощью которой можно было бы ввести номер месяца, а программа бы ответила к какому времени года соответствует этот месяц(Паскаль)?

Помогите составить программу с помощью которой можно было бы ввести номер месяца, а программа бы ответила к какому времени года соответствует этот месяц(Паскаль).

Вы перешли к вопросу Составить программу Pascal : Вводят число от 1 - 12 - номер месяца?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.