СРОЧНО?

Информатика | 10 - 11 классы

СРОЧНО!

Помогите решить задачу в Pascal.

"С клавиатуры вводятся два слова.

Требуется найти множество гласных букв , которые входят в первое слово , но не входят во второе слово.

" Помогите срочно , пожалуйста, в PASCAL!

Ответить на вопрос
Ответы (1)
Aleksikdon11 22 апр. 2020 г., 20:47:17

Const gl = ['а', 'е', 'ё', 'и', 'о', 'у', 'ы', 'э', 'ю', 'я'] ;

var w1, w2 : string ; m : set of char ; c : char ; i : integer ;

begin Writeln('Введите первое "слово"') ; Readln(w1) ; Writeln('Введите второе "слово"') ; Readln(w2) ; m : = [] ; w1 : = LowerCase(w1) ; w2 : = LowerCase(w2) ; for i : = 1 to length(w1) do if w1[i] in gl then Include(m, w1[i]) ; for i : = 1 to length(w2) do if w2[i] in m then Exclude(m, w2[i]) ; Writeln('Гласные, присутствующие в первом слове и отсутствующие во втором : ') ; foreach c in m do Write(c, ' ') ; Writeln

end.

Тестовое решение :

Введите первое "слово"

Дай, Джим, на счастье лапу мне!

Введите второе "слово"

Сергей Есенин

Гласные, присутствующие в первом слове и отсутствующие во втором :

а у.

Smirnovatu15 20 июн. 2020 г., 08:32:42 | 5 - 9 классы

Составить программу Pascal : Вводят число от 1 - 12 - номер месяца?

Составить программу Pascal : Вводят число от 1 - 12 - номер месяца.

Если число входит в интервал от 1 до 12, то высвечивается месяц, а если нет то выходит слово ошибка!

Помогите срочно!

Music333 10 мар. 2020 г., 19:03:49 | 10 - 11 классы

Напишите программу которая вводит с клавиатуры 10 чисел и вычисляет их сумму и произведениеpascal?

Напишите программу которая вводит с клавиатуры 10 чисел и вычисляет их сумму и произведение

pascal.

Bikovaanastasi 20 мая 2020 г., 02:58:53 | 5 - 9 классы

Решите задачу по Free Pascal IDE?

Решите задачу по Free Pascal IDE.

С клавиатуры вводится два вещественных числа.

Найти целую часть от произведения двух вещественных чисел.

Qazxswedc2014 11 июл. 2020 г., 02:56:10 | 10 - 11 классы

Программа в Pascal ABC?

Программа в Pascal ABC.

С клавиатуры вводится два слова.

Надо вывести на экран те буквы, которые есть и в одном и во втором слове (печатать буквы без повторений).

Asdfar2002 24 окт. 2020 г., 11:55:33 | 10 - 11 классы

С клавиатуры вводится n чисел?

С клавиатуры вводится n чисел.

Найти сумму и количество трехзначных и нечетных чисел.

Pascal.

ЛенаК010 22 апр. 2020 г., 07:08:57 | 10 - 11 классы

Найти наибольшее число, кратное 3, в матрице размером mxn, элементы которой вводятся с клавиатуры?

Найти наибольшее число, кратное 3, в матрице размером mxn, элементы которой вводятся с клавиатуры.

Pascal.

Goodmodex 26 апр. 2020 г., 19:47:42 | 5 - 9 классы

Помогите решить задачу?

Помогите решить задачу.

Срочно!

Дана последовательность от 1 до 30 слов.

Напечатать : все слова в алфавитном порядке.

ПОЖАЛУЙСТА!

На Pascal ABC.

Zhibek68 22 апр. 2020 г., 01:21:19 | 5 - 9 классы

ПОМОГИТе?

ПОМОГИТе.

Очень срочно!

С клавиатуры вводится слово не менее чем из 5 букв.

Найти и напечатать последнюю букву этого слова.

Xtreme999 9 сент. 2020 г., 13:53:39 | 10 - 11 классы

Нужно написать прогу в Pascal ABC?

Нужно написать прогу в Pascal ABC.

В заданном тексте заменить все слова A1 на слова A2 (слова в тексте разделены пробелами слова A1 и A2 вводятся с клавиатуры).

Dimaddd 9 сент. 2020 г., 22:08:46 | 10 - 11 классы

(Pascal) Дана непустая последовательность слов из строчных латинских букв?

(Pascal) Дана непустая последовательность слов из строчных латинских букв.

Напечатать в алфавитном порядке :

1)все глухие согласные , которые не входят ни в одно нечетное слово

2)все звонкие согласные которые входят хотя бы в одно не четное слово и не входят ни в одно четное .

Помогите пожалуйста , вообще ничего не получается.

На этой странице находится вопрос СРОЧНО?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.